Samsung Button on AC power

Sorry, not sure if this is the right place to put this but I figure it can get moved if needed.

I have a Samsung Button that's dropping battery power fairly fast. It's already down about 20% in the first 1.5 weeks. Honestly I dropped about 15 % in the first few days and has really slowed down so time will tell, but...

I've been thinking about soldering and ac/dc converter to it so it's on main power instead. I can get a configurable converter like this Robot or human?) and just do a quick solder.

Thoughts? Anyone else done it? I thought I remember a post about it but couldn't find one here so asking my fellow Hubitat folks. My Aeotech multisensor bit the dust, so I'm using this for temperature monitoring as it's so much cheaper.

Here's what I posted recently for a plug in motion sensor..

The nice thing about that button is portability though which you would lose if you hard-wired it - I have 2 to control some bedside sconces and they work well. Have been running for a few months and are still around 90% & 84% (just checked).

I do prefer hard-wired devices though. I think those regulators will work in the button but not sure if they would fit properly. might have to go external.

How many zigbee repeaters do you have in your mesh? I would be suspect that your zigbee mesh is the issue of battery drain on a zigbee device. Check out the information on building a solid zigbee mesh.


It may be running one of the older firmware's. I had 2 buttons I ordered last year from Amazon that had older firmware that were having a drain issue also. I kept a smartthings hub around for firmware updates. I had to remove them from Hubitat and add them to smartthings and then watched the events on the developer portal for the firmware to be flashed.

I then removed them from SmartThings and put them back on Hubitat and everything was fine. Buttons are "sleepy" devices. They will only push messages to the network on a button press and when they are reporting temperature or battery level. The rest of the time their network connection is in a sleep state.


How old is the button? You have have a defective one. Can you connect it to SmartThings and check firmware? Latest is 0x11

Good suggestion.

This. These are known as sleepy end devices (SEDs). They don't have to wake up to check for commands since they only emit events, not receive them, so they spend most of their time asleep. A weak mesh (inteference, lack of repeaters, etc) would manifest itself as poor button performance.. ie.. delays between a press and the command being received by the hub, duplicate events, etc.

I also do not believe it's an issue with Hubitat either. Here's a tale of two buttons...

I have two of these bedside.. One operates a bedside lamp, ceiling fan, and overhead lights. The second is the master mode button for the house.

Both were put in as new when I transitioned to Hubitat a bit over a year ago and both were on the same hub until recently. I have changed the battery in the bedside lamp button twice, most recently in December. It's battery life averages about 6 months.

The mode button, has been though way more batteries.. I stopped counting. The original battery lasted about 2 months. Each replacement seems to not last as long as the battery it replaces. Around Thanksgiving, I connected the button to ST and found the firmware current. Installed a new battery (with install date written on it) and re-connected to Hubitat as a brand new device. Exactly 21 days later, battery is dead.

Now it's December... Replaced battery and moved to another Hubitat hub. At the same time, connected a brand new Samsung button fresh out of the box. Battery dead in 18 days. The new button? Battery going strong at 90% after the same amount of time, and still at 90% after more than a month.

The button now sits in a box with other devices that have "issues".

Honestly.. I would get a 2x AA or AAA battery holder and power it from that. You can probably still get a year of life out of a set of conventional batteries.


That’s a great idea. Then I can just use rechargeable batteries.

Still, I agree that it’s likely defective, but given that I haven’t been able to figure out how to update the firmware my only other option would be to return it and try again. I think that’s a bit like trying over and over to win the lottery. I got it as Best Buy so I don’t know if their stock is as old as Amazon but it’s possible. My bigger problem is that I have it tied into a bunch of rules, and I reeeealy don’t feel like rewriting them again. There’s some considerable conditional logic that I got just right.

Maybe I bit the bullet and swap it out. If it’s not better I can always use the battery tray. Failing that go with the suggestion above. I will say, I used to have one in my car I tried to use for my garage door and it definitely had issues when it took it away from it’s buddies, so there’s something to the network strength. I was contemplating just getting another zigbee plug, but honestly that’s more money than I want to spend right now. I have a lot of Zwave.

Any way to check the firmware separate from Smartthings?

Depending on technology, rechargeable batteries can start out at roughly 1.2 volts and last a long time delivering a steady 1.2 volts until they very quickly fall off. With 2 cells, you will likely start with 2.4 volts give or take. Devices using a 3 volt battery, may look at 2.4 volts as dead and not function. Not saying that this is the case for that button but . . .

I have a bunch of these and I remember the batteries dying very quickly prior the updating the firmware on SmartThings. I also notice shorter battery life if one is in an area with frequent temperature changes. I believe they send an event with every temp change because one that is near a furnace vent reports over 100 changes a day and one in my son’s bedroom reports fewer than 10. They have been very reliable in that regard.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.