Rule Machine - Pause Rule


#1

So in my living room during the week @ 10PM we have the lights turn on a Night scene that dims the lights down.

When someone enters the living room the lights change scenes to a brighter scene. After 1 minute of inactivity they go back to the night scene.

This works wonderfully - except when we're in the room and motionless. the scene keeps trying to go back to the night scene when we are in the room.

Ie we are decorating the living room and wanting to keep all the lights on bright while we're working - but sometimes the motion isn't detected and lights switch scenes so I have to go to my computer and pause the scene. (only after everyone is frustrated saying can't the lights just stay on ?)

What is the best way to override the motion+change scene affect and just leave the lights on bright.

** I have a pico that has an button 1 configured to turn everything on and set the scene to bright and button 5 to set the scene to off.

I tried to find something but couldn't find it in the community.


#2

Maybe a virtual switch as a condition for the motion rules ... and use pico buttons 'held' options to control the virtual switch state (as well as perform the lighting actions you'd get with a normal button push).


#3

There are many ways to do this.

In the rule that button 1 fires, add pausing the rule that makes the lights go dim. And for button 5, resume (un-pause) that rule.


#4

This exactly what I do. I have added a virtual switch that will trigger a rule with a 90 minute delay to unpause the motion rule. I do this in case someone forgets to push button 5.


Override motion rule and reset after 90 minute?
#5

Just build that into the first rule with an appended Action, no need for a switch.


Override motion rule and reset after 90 minute?
#6

Wonderful - Getting it now. I am trying to avoid any third party apps at this time (trying) ...


#7

Have a similar issue I’m trying to solve. For a sunset routine. But my experience is that pausing the rule doesn’t stop the action that’s already executed. Is there a way to stop the already executed rule so that it doesn’t run?

Example is the sunset routine is changing color temp over 900 seconds. But if the light is turned off while running it pops the lights back on and starts over. Enter a frustrating loop.


#8

You need another rule that can do Cancel Rule Timers on the rule doing the 900 second fade.


#9

Thanks. Didn’t know I could do that. Built a rule. We’ll see if it works as I hope.


#10

Doesn’t seem to be working. Must not have the right rule setup. Help?