Rule Machine Misses Devices and is Slow

I just completed erased my device and started over. I have six light switches. When one of the 6 turns on, it will turn on the other five. Seems simple enough. I have one rule for ON and one for OFF.

When you trigger it, it is really slow to turn any of the devices on or off. Then a lot of the time it misses devices. If I go to the device directly I can click the on/off for it and it's pretty much instant so I know the connection is there and is working right.

I've seen many other complain about RM being slow. Is there anything I can do about it and to help out with it missing devices? Seems like there is room for improvement in RM4 in the reliability department.

Any thoughts or suggestions on how I can make this better?

A few questions:

  • Can you post your rule here
  • What brand/type of switches

There are ways to group lights/devices together with the Groups and Scenes app that may help.

Hi there, thanks for the help. Here is a list of my switches and the rules in RM4 that I'm working with:

Rule: When switch 1 turns on, turn on switches 2-6
Rule: When switch 1 turns off, turn off switches 2-6

  1. GE Enbrighten Z-Wave Smart Switch (Jasco made, part number 46201)
  2. GE Enbrighten Z-Wave Smart Switch (Jasco made, part number 46201)
  3. GE Enbrighten Z-Wave Smart Switch (Jasco made, part number 46201)
  4. GE Enbrighten Z-Wave Smart Switch (Jasco made, part number 46201)
  5. Enbrighten Plus Smart Receptical (Jasco made, part number 14297)
  6. Enbrighten Plus Smart Receptical (Jasco made, part number 14297)

Separate rules and different times:
When switch 1 turns on, turn on 2
When switch 2 turns off, turn off 2

  1. Leviton Decora Smart Switch (Part number DZ15S-1BZ)
  2. Leviton Decora Smart Switch (Part number DZ15S-1BZ)

After.I posted this, I modified the rules to delay each switch by 1 second. In my first couple of tests of the rule it seems to be a lot better already. I'll roll with this and see how it plays out in the long run.

Is it blasting out all the commands at the same time and some get there and some don't?

Here is a setup of the rule now for the ON part: Is there any way to make a single rule for ON and OFF functionality without having to make two rules - one for ON and one for OFF?



What hub model and software version are you running?

Hi team,

I know there are a number of threads on this issue already, so hopefully I'm "contributing" rather than "polluting"!

Running a C7 at my end and can confirm --

Rules: Running on 2.2.3 > Rules trigger instantly for simply things like a contact sensor turning on a switch.

Rules: Running on (and all prior .4 iterations) > the same rules take 10-60 seconds to affect their specified action. It is not a mesh issue. Reverting to 2.2.3 repeatedly and immediately restores the functionality of these rules, and the devices in question are routed directly to the hub with messages not hopping through other nodes.

Scenes: Running on 2.2.3 > Scenes fire semi-reliably. Some devices are occasionally missed, or take ~1 minute to execute fully.

Scenes: Running on 2.2.4 > After a reboot, the first scene activation succeeds successfully and lightning-fast; all devices react almost immediately and with no visible "popcorning". Subsequent activations quickly become less reliable, with devices being missed or no devices reacting at all for up to 3 minutes.

I've followed all best-practices and recommendations including strategic repairs, removing-and-rediscovering devices, reboots, resets, and lots and lots of waiting. I'm not convinced that these are mesh issues. It seems instead that the processing of Z-Wave broadcasts from the hub gets overwhelmed and locks up.

If it helps the investigatory process and in turn can help others, I'm more than happy to give full access to my system to the powers at Hubitat - just let me know how I can assist! Happy to set-up a Teamviewer system, a webcam, share my passwords, social insurance number... whatever can help the cause! :slight_smile:


1 Like

Just got a C7 on Sunday and it is running v2.2.4.147. Spacing out each device by 1 second allows them all to turn on more reliably. Should I have to do that?

Well.. No, you shouldn’t have to do that.. curiosity.. Could you update to and try again without the extra spacing?

Sure. I'll give that a whirl and report back.

With all the devices turning on/off together, I get the same erratic inconsistent behavior. I also notice that when monitoring the devices from a dashboard, even though the devices have turned off, they still show on in the dashboard. It seems that the log entries for devices are delayed - because I can see some lights are off but no log and still on in the dashboard.

If enough time goes by, any devices left out will stay left out.

I'd also like to note that the device becomes sluggish when it comes to controlling devices when I run rules for a bunch of devices at the same time. Setting them manually seems to be delayed, etc. Seems like something is clogging up the command pipeline or something. When I do them individually, things flow through good and stay good. Even my serial rule gets caught up with problems if I run it AFTER running the rule that clogs things up. Once the command pipeline is clear, then the serial rule runs smoothly from there on out.

Hope this helps, let me know if there is any other information I can get from you. Logs maybe?

In your rules, please turn on Action logging, and make sure in your devices that Text Description Logging is on. Then run the action that seems clogged up. Take a screenshot of the logs, and post it here.

Here is the log. For what it's worth, I could see that one of the Bocce lights were on even though it is not in the log.

Also, after things get clogged up, if I try and manipulate any of the switches from a dashboard, this is what I get until things are cleared which can be quite a few seconds.. to maybe a minute or so.


Here you can see the serial rule acting weird because the pipeline hasn't cleared yet. Look at the delay for the items in the list. One was near a minute.

Things aren't recovering anymore. Going to reboot and will report back with the log of the serial rule running.

Something is screwy. After a reboot.. manually flipping the switches via a dashboard results in this:

It sounds like the radio could be in a weird state. I'm going to shutdown and then power cycle.

Please show a screenshot of your Z-Wave Details page.

After the reboot... The Garage Main Door sensor is a battery operated one so guessing that's why it's listed as failed. All others are hardwired.

Ah, I dunno.. the serial one is acting weird still. I can see some of the lights are on but they're not logged in the log for a long while. The bocce lights were on well before it showed up in the log.