Rule Machine HTTP Get/Post Ignore SSL

Hey everybody!
I'm trying to get a rule machine rule to do an HTTP Get to an internal URL, unfortunately it's only accessible to Hubitat via IP, and the SSL certificate doesn't have the IP in it... can't seem to fix the cert, so how can I make Hubitat ignore that? HTTP only is not an option, has to be HTTPS.

this is a simple rule, to trigger recording on synology surveillance station when HSM detects an intrusion.

Thanks!

I don't think you can get RM to ignore self-signed or bad certs but I know you can flag HubActions or httpGet to ignore them... one of the two or both. So, if you feel like moving it out of RM into an app you can tackle it that way.

1 Like

I figured as much, that's a bummer... now to figure out where to deposit a feature request.

@tjquinn did you figure it out to get a solution?

nope.... @BrunoVoeten, I let it go since it doesn't seem possible at this time. which is a little unfortunate.

I suppose I could write a button driver to do the same thing, but I didn't want to get that involved.

1 Like

For me this helps:-)

Of Course it is HTTP not HTTPS