Rule Machine 5.1 Local Variables "Stuck" in Edit Mode

I was working on a Rule 5.1.3 App and I clicked into Local Variables to edit a variable, and it's "stuck" in edit mode. The table is greyed-out and not "clickable" as if there is supposed to be a field displayed below to edit/update, but nothing appears as shown in the image. The variables do update when the app runs, so it's functioning, but I'm left without any way to make any changes.

I tried rebooting the hub, and I exported the app and imported it as a clone, but this stuck edit mode remains in the imported app. I was working in Safari on an iMac and tried Chrome, but it occurs there as well. It would seem that this "edit mode" is set in a line of code, and I could probably fix it in the raw JSON output, but I can't identify where that is. Any help fixing this would be appreciated.

@support - Hi, is there a solution for fixing this rule?

@bobbyD - Any help on this one? Thanks!

@bravenel - Would you be able to help with a solution for this?

I wonder if your use of the name "now" could mess with the app? Not a solution, just a thought....

Perhaps you could try removing it from the json exported....

Has there been any feedback on this? Same issue you are experiencing. rules machine 5.1. Can add or delete variables but when you click on one to set a new value the Local Variables table grays out and nothing appears to set the variable value. You can then do nothing with local variables. Can exit out of the rule, go back into it, and will still have the variables greyed out and unable to do anything with. First experienced this in macOS Monterey 12.4 Safari 15.5. Have tried macOS FireFox, Win 10 Edge, Win 10 FireFox, iPhone Safari, and iPad Safari. All have the local variables table grey'd out and cannot select any variable. Tried cloning the rule and local variables were locked from the start. I reverted to a backup taken at 2:17 this morning, losing multiple updates but hoping it would resolve the issue and no joy. Recreated a rule that had been working on and same issue. Was able to create the variables but once created and click one to update the value the table locks up and nothing I've tried has been able to unlock it. Attached are screen shots of the rule. At this point Rules Machine can’t be used with local variables.

Hub: C-7
Platform: 2.3.2.141
Rules Machine 5.1


See PM I just sent you.

I just had the same thing happen. Is there a way to get it back to an editable state or am I stuck recreating the rule?

I am trying, so far unsuccessfully, to be able to reproduce this. I need to see the rule. You can go to the Apps page, and open it again. Please post a screenshot. If you can tell me the exact steps that caused it, that would help.

It is possible for you to recover this by exporting the rule and editing the JSON file. In the file you will find this text:

,"editGV":"ratchet", where you the word "ratchet" is the name of the variable you were editing. Replace that with this:
,"editGV":"",

Then import that file, and you should be able to go on with the rule.

Until I can reproduce it, I can't find the problem to fix.

1 Like

I wish I had something useful to describe -- all I did was:

  • open the rule
  • click local variables box
  • click a variable I wanted to edit

after that I wasn't able to edit the variable but things seemed "locked". I've edited this rule and the variables many times in the past and never had this happen and there wasn't anything different about this time.

thanks for the hint on how to recover - that worked perfectly.

it's a rather long rule - what part of it would you like to see? All or just the variable section, something else?

What type of variable was it? Had you entered a new value for it yet? What browser?

Did it bring up the edit screen or not? By that I mean the input for "Set value' and the Update and Cancel buttons??

It was a boolean, I did not enter a new value and the edit portion of that screen never showed up. This is on Chrome MacOS version 103.0.5060.134. I got as far as clicking the variable and then nothing after that - the screen grayed out and nothing happened (e.g, no "set value" input, no update button).

OK, thanks. I can track that down. There was a change made, and for a Boolean it should just change the value in place, since there are only two possible values.

Except, of course, it works for me in testing...

I'm not sure it's helpful but I think I've changed a boolean in this fashion as well (probably even this rule) and it's worked so I'm not really sure why this case was different... if I can come up with something I'll PM you

We have some idea of what is happening. We think it's a weird timing issue in the UI. We also think we have a fix for it in the next release.

4 Likes

Just had this happen to me. In my case it was a Boolean. I added it as True and then decided I wanted to start it at false. When I clicked the true to change it, the variable edit screen hung as shown above.

2 posts were split to a new topic: Problems with Hub Variables

There is a way you can fix this be exporting the rule and editing the JSON file, then importing that back. Search the JSON text for "editGV":"

What you will see there is something like this: "editGV":"nameOfVariable" -- with your variable name there. Remove the variable name so that it is this: "editGV":""

Then you can import that rule back.

3 Likes

Download the Hubitat app