Room Lights: Scenes, Groups & Voice Assistants

Webcore activated a specific scene at a specific time of day on active and inactive. Is using five room lights instances per room the way to go?

I don't want to tackle this until I resolve the null pointer. It sounds like I may need to remove room lights and reinstall.

How was this done? By turning on the switch activator device? If so, the same approach will work for Room Lights.

If you have a specific instance of Room Lights that is messed up, you should only remove that particular instance.

How do I delete an orphan scene activator that is a child of one of room lights instances? If I delete the text in the "Command with:" box, it fills in again. It advises against deleting the device directly. I uninstalled groups and scenes since it is deprecated.

Command with: [Office evening scene Activator]

You can simply delete the Activator Device from its device page. After doing that, RL will prompt you to either create a new one, or clear out the Activate Device name.

With Release I see Groups and Scenes are being deprecated. Per the recommendation, I'm migrating my Groups to Room Lighting. I was able to create new Room Lighting child apps from the existing Groups. A lot of my Groups child devices are being used in other apps (e.g., dashboards, Amazon Echo, etc.). I was hoping to swap a legacy Group device with a replacement Room Lighting activator device, but the swap apps option in hub settings doesn't list Groups nor Room Lighting devices. Thoughts on how to make this part of the migration less tedious?

There is no way. Child devices cannot be swapped. Only migrate if you want. Please note the remark in the release notes:

So this warning message does not apply:

Remove it from the app first or they may be damaged by the device removal.

I have created a virtual switch to enable triggering the app by Alexa.

Only if it is in use by other apps. Those should be cleaned up. But simply removing the child device from its parent is harmless.

There is no need to do this. You can simply use the app's Activator Device for Alexa. Depending on what sort of lights you are using, this is better. Only the Activator Device can do things like set level, set color, etc., when commanded by Alexa.

My attempt to use room lights scenes with room lights for motion like I was doing in ST was a failure. Also, with ST, I could activate any scene in any sequence using Alexa. How can I do this with RL?

The level of the activator device called from RL motion overrides the levels that I had set for the devices in my RL scene. If the activator device was set to 100%, all the devices in my "dark" scene were set to 100 %. I now have to set all the devices directly in my RL motion app. I could activate the same scenes from my Webcore motion routines.

The activator devices appear to be stateful as switches. If the activator device is already turned on, turning it on again via Alexa does not work. I have to turn it off first, then turn it back on. I have not been able to nail down exactly how/where this is happening. I want the behaviour to be like a button, but virtual buttons do not map over to Alexa.

The activator device for RL is stateless, it will send ON command to the app even if already on. It would help understand what's going on if you would post a screenshot of your RL setup that isn't working as you expect.

If the Activator for the scene is set to 100%, it overrides the levels set in the scene. The scenes do not always activate either.

To activate a scene, only turning ON the activator will do that. Once you start giving it other commands, such as setLevel, that will override the table settings.

Since the scene activator has the properties of a color dimmer, when I check the “Act” box in my motion instance of RL, it gets level and color attributes. The activator should be a button which is stateless. With Alexa, I can only get scenes to activate if I turn them off first.

Where it says CT, you can make a different selection. RL doesn't know anything about a device a priori. Presumably, Family Scene is the activator for some other RL instance, right?

I just noticed that a couple of the Room Lights Activator drivers lack the button capability. Will fix that. In the meantime, you can change the driver to Room Lights Activator, and that will give you the button capability.

1 Like

The type of the activator was a key point I was missing. Why is a button type not available? Should button or switch not be the default for an automation? If I am to understand correctly, when the type is dimmer, RGB or CT, it behaves like a group, overriding all the scene device parameters.
Screen Shot 2022-10-05 at 8.49.08 AM

When the activator is created, before being used, it has all the attributes of a color bulb.

Did you see my post just above? Switch that device to "Room Lights Activator", instead of "Room Lights Activator Bulb". Fix for this in next release.

I did. Nice to see you are adding the button property.

Dashboards for Scenes
How do I set the dashboard to use a button type for an activator? I changed the type from the default color bulb to button 1 press, but it does not work. If I set it to a switch, the behaviour is stateful. If I activate family bright(on) then family dark(on), then family bright(off) all the lights are turned off. Should the default for an automation activator not be a button?