RM Rule not working after upgrading to 2.2.7

Pretty much need to see the logs to know what is going on.

This is all I get in the logsScreen Shot 2021-05-07 at 2.33.56 PM

Doesn't show any actions, etc.

If I go into the rule and "Run Actions" I get all the stuff I would expect

Ever since this update my whole hub locks up and won't respond until I power cycle it. I am trying to disable various automation to pin down which ones the update might be hanging on. Really considering a rollback as the hub is mostly a brick now.

Show the Event Subscription section of App Status page for the rule. It doesn't appear that it is being triggered. Also, you might open the rule and hit Done, to see if that fixes it. Look at the Events logs from the device page as well.

It's a big one, so multiple screen caps

I went in and hit "Done" and it's still not triggering when it goes to home and armed via the Ring app... Interestingly when I disarmed via the Ring app immediately after it DID trigger

I don't have a clue what's going on here, but it sounds as though the events are not being sent as you expect. Look at the Events from the device page.

They look okay to me:

Also, this has been working for months as-is

Try, that fixed my issues so far

As I said, I don't have a clue why this is happening, or not happening.

May I suggest, as a test, change the trigger to "reports mode 'home'". Maybe it has to do with the handling of "changed".

Sounds a lot like my issue

HSM status rule not triggering - Support - Hubitat

Did you try re-creating your rule? I’d be curious if it would fix this instance too…

I didn't recreate it, I just changed the trigger into something more or less equivilent.. then it started working.. have a look at the 3rd entry in my post

Yes, I just did and it works! @bravenel something's wacky with taking old rules in RM to the new version... Similar to the issue I had with my simple rule triggering for sunrise not working after update.

Could be, although it's not clear what change would cause this.

What fixed it? Recreating the rule?

Yeah, I recreated it from scratch and it worked (at least in my one test).

In my case it was changing the trigger to something which basically did the same thing. See my earlier post

Yeah, seems to be triggers are not working the same

1 Like

I had exactly the same issue and raised a thread. Full logging showed the trigger happening but the actions did not appear in the logs.
Re-writing the rule from scratch solved the problem.