RM 3.0 Unexpected Error

Hi all,

Working to create an If-Else-Then Rule and ended up with this

It started when I was working in and selecting Actions for True. I was able to save the Rule and go back in, once I select Actions for True, the error pops up. Get the same error when I select Actions for False

I'll delete it and start over and go from there


Can you please show me the rule setup, or what you were trying to do.

Once I select Actions for True, I get the error

I was trying to build conditional actions similar to

I wasn't able to initially select the If (condition) so I added an action to turn on an outlet, then I added the If(condition) then I deleted the outlet, that is when the error occurred.

Now I can't do anything with the Rule other than delete it, which is fine since I was just playing


I tried something this morning that worked fine for me.

I was checking out long delays, delays on individual actions, etc. I won't say I didn't make some data entry errors and had some delete's and insert before's. But I never encountered an error. And in the end, the rule worked. I doubt I'll keep it since it's a 'big hammer' approach, but it certainly is fun to try new Rule 3.0 actions. :slight_smile:

Edit1: I just built a 2nd copy of that one, using minutes instead of hours, and again, no errors. Maybe it has to be AND, because mine uses OR.. let me delete and try that.

Edit2: built the 3rd time, using AND and no error. :frowning:

I suspect you did something else as well to throw it off the rails. The action creation is not bullet proof for every type of edit you can make to it. It begins a set of actions knowing there is no IF-THEN involved, and goes from there. Once there is an IF-THEN, it's looking for ELSE, ELSE-IF or ENDIF. It can be tricked into a bad state if care is not taken. Once in a bad state, that rule is toast. It's not a compiler, it doesn't have error messages when the syntax is trampled.

1 Like

Thanks Bruce


Hi @bravenel, I managed to get the same error message, but probably for different reasons.

Starting RM gives the following error message:


[app:9] 2019-05-04 11:34:51.436 am [error] groovy.lang.GroovyRuntimeException: Ambiguous method overloading for method java.util.LinkedHashMap#leftShift. Cannot resolve which method to invoke for [null] due to overlapping prototypes between: [interface java.util.Map] [interface java.util.Map$Entry] (mainPage)

I can edit the child rules, simply cannot start the parent RM app.

I tried to create a Custom Command that invokes the launchAppPackage command in @gavincampbell's Fully DTH ([RELEASE] Fully Kiosk Browser Controller) with 1 parameter (type: string, value: com.spotify.music). It failed, and I cannot start the RM app since then.

Did I do something wrong? :slight_smile:

Edit: fw version

I suggest that you restore a prior backup of your database. Otherwise, recovery from this is going to be quite difficult. Restore from before you you attempted the Custom Command.

@bravenel I'm also getting the "Unexpected Error" page. v9.133

This comes when clicking on rule actions. Previously, I edited the action list and made a mistake by specifying a condition as presence (like the first two IF conditions) but realized my error and tried to change the condition to switch. When trying to enter the changed criteria, RM would not allow me to select any type except presence. I backed out and upon clicking to change true actions, the above appeared. I cannot enter into the rule actions. Although I don't have any "when false" actions, RM will allow me to enter that field if I wished.

My next step is to delete the entire rule and start over but I'm keeping it for now in case you need to see it.

So it broke when you tried to change the condition capability, right?

Yeah, you pretty much have to trash one that does that...


(Just happy you didn't tell me to restore the whole hub from a backup. )