RL won't turn off lights

For the purposes of testing out the Room Lighting app, I have a single zigbee light bulb and a ThirdReality motion sensor.

I've tried several of permutations for setup, but currently I have the app setup this way:

The light always turns on when motion is detected. The problem is the light never turns off by itself. If I click "Turn Off" in the RL configuration, it turns off. If I turn the device off manually through the device page, it turns off. The RL automation however, never turns it off.

Here's what I see in the log:

Some extra things I've tried that had no effect:

  • Updated to latest system software.
  • Changing "CT" to "Switch"
  • Removing the "Other Turning Off Options" but that usually results in it saying "device is already off"
  • Removing the elapsed timer.
  • Only using the elapsed timer (no "inactive" motion sensor)
  • Deleting and recreating the RL app

What am I doing wrong?

Something else "interesting" is if I click the little red circle in Device Control, I can see a log entry for "setColorTemperature: Stairs Light, temp: 3300, level: 100". If I click it again to turn the light off (which it does), there's no log entry.

you need this

obviously don't use the mode specific time if not wanted just the and stay inactive

Hello, I just tried that and it did not work. It exhibits the same behavior int that the timer expires and nothing happens.

New RL settings:


Log from events:

Possible device issue. Include the light device logs to see the full chain of events. You can try using the 'Force' option, make sure to check the box in the table. Since you are only controlling 1 light the 'partially off' setting won't do anything, it's not harmful though.


Agree with @bill.d's suggestion to use the "Force" option. This is found under Additional Options>> Command devices on/off irrespective of reported state. As @bill.d states make sure to check the box in the table.

I have a plug that does not report its state correctly. I had to use this option to correctly turn this plug on/off.

1 Like

@bill.d / @Sakman's advice worked. It is indeed a light that Hubitat has a problem with maintaining the state of. Looking at it more, that seems to occur with most of the lights in my basement, but not the ones on the first floor (all Sengleds).

Thanks all who offered help.

1 Like

Wow, I wrote too soon.

I have the exact opposite problem now. The light won't go on :face_with_raised_eyebrow:

Edit: I'm going to give up for the time being. I disabled this app. I went back to "Motion and Mode Lighting" because it still works perfectly (I did not have it installed while testing with RL). If anyone has any ideas to try, I'm happy to debug further into what's causing RL to misbehave, I can just re-enable it.

I'm going to chime in here because I'm seeing this exact same thing. However my setup is NOT new. I've had a few RL apps that are now doing this that never did this before. One example is my office lighting I have some LED strips (zigbee) that have worked in RL for many months. Very recently I noticed these lights never turning off. Sure enough they were turning ON, however their state was not reflecting that. So now they don't turn off. I understand that using the "force" option will fix the issue, but they were working fine. So something else has to have changed?

This is using the Advanced RGBW bulb driver.

Also to note, yes when I click "refresh" the driver then updates and sees that the lights are on. However turning them on through RL should work.

1 Like

I am also having issues, but mine are related to some Lutron Pico buttons. They work fine for turning on/activating the RL, but the off works for everything except the single Zigbee Sengled bulb. If I turn off the bulb from the device page, it works fine. If I use the "Turn Off" button in the RL app, it works fine. If I watch the logs when I press the off button on my Pico, it shows that it's firing the "Off" command in RL, but the single bulb doesn't turn off. Everything else in the RL app goes off just fine, except the Zigbee bulb. This started about 2 weeks ago and was working fine ever since RL was launched.

I've pointed to the bulb that has the issue. The other devices works just fine.

Actually, Force doesn't work either. That light is not turning off from RL. It turns on/off fine from the device page. But when RL turns it on, it goes on with no indication on the device page or the logs that it actually turned on. Then it seems as if everything thinks it's off. If I go to the device page and hit refresh it does refresh the state to show that it is on. I can also just click off on the device page and it will turn off. I would say it was a few weeks ago also for me that this started. I wonder if it was with one of the recent releases.

I'm seeing something similar in Room Lighting and my lights that are using the Advanced Zigbee RGBW driver. For me, it appears to be a change made somewhere between release and I was on vacation and running .125 when I left and all was well. Updated to .134 when I got home and things stopped working. Revert to .125 and it's all good again. The Generic Zigbee RGBW driver would allow the state to be reported currently in RL in .134 but setting a level doesn't on my LEDVANCE strips. Mike Maxwell is taking a look at the driver as he has been making changes to fix other issues.

I'd suggest also posting logs for the RL app and the problematic device(s), for others to trawl through when trying to troubleshoot the issues.

When RL gets activated

However here is the device:

And it is ON. I'm looking at it.

(FYI, I've turned OFF the force command in RL to go back to how it used to work and not changing more things)

1 Like

I'd include logs for the device as well, to see what is happening there when the RL app is trying to control it.

Exactly what I'm seeing too.

Well there are none in the logs. This is from the events though for the device:

Make sure you've turned on logging on the Device page for the device. Both info logging and debug logging.

1 Like

1 Like

Am I right in thinking the set color temperature 2000,85,5 doesn't match the RL setup?

Seems legit to me. CT 2000 at 85% brightness fade over 5 seconds.

I'm not sure why when it is turning on the light it's not reflecting that...and for sure it used to.