Ring Range Extender (2nd gen)

I'm having trouble excluding this from my C-5. I've tried through the "Remove Device" and through the "Z-Wave Exclusion" process. The instructions (for the v1) say to press the button on the right side of the device, but that is not working.

I have also tried the following steps from the Ring support site:

What if I need to remove my Range Extender (1st gen and 2nd gen) ?

  1. In the Ring app, tap Menu , then tap Devices , then tap Alarm Base Station , then tap the Range Extender you wish to remove.
  2. Tap the Gear icon on the top right corner, then tap Remove .
  3. Unplug the Range Extender and then plug it back in.
  4. Wait a few seconds and if nothing happens then press and release the button on the right hand side.
  5. The app will let you know the device was removed. Leave the Range Extender unplugged until ready to use again.

Any suggestions on next steps? If I do a force exclude, will that mess up my Z-Wave mesh?

Unlike C-7, the C-5 model will not let you remove a ghost device. By force removing a Z-Wave device, you leave a "ghost" device behind. The hub will eventually remove it during the nightly clean-up process. To avoid "ghosts" always exclude the device first, if possible and never force remove it, unless the device is dead or has a non-functional Z-Wave radio.

1 Like

That's what I'm trying to do, but it will not exclude. The device is still connected to the C-5 and if I unplug it and hit refresh on the device page, I can see the powerSource change to "battery". Then when I plug it back in and hit refresh again, the powerSource changes to "mains".

Not sure what I can do to get it to exclude now... is force remove the only option?

I tested with a C-5. The spontaneous generated powerSource events are not transmitted. Other functions, repeater, range and power test function as intended. Sorry.


Thanks for doing this. Unfortunately, it's the powerSource attribute that I really need. Maybe I will come back to it when (if) I upgrade to a C-7 :man_shrugging:t4:

EDIT: Follow up Q - were you able to exclude it from the C-5? If so, what steps did you take? I can't get the exclusion to work on my C-5

You should be able to remove it using a Z-Wave USB stick and SiLabs Simplicity Studio. Yes, it’s not a ghost, but procedure is the same.

1 Like

Challenge is that all I have are Mac computers! Going to try and see if I can get this to work...:crossed_fingers:

Same here. I have an intel iMac, and I use Bootcamp with Windows 10. Works fine. It’s the only thing I use Bootcamp for.

While there is an installable version of Simplicity Studio for Mac OS, The PC Controller module only runs on Windows (including on Bootcamp) and is not a part of the MacOS install.

1 Like

M1 Mac here...:slight_smile: There is a Mac installer for SimplicityStudio5.. going to see if that is even a possibility

See my edited post above. No, that won’t work.


OK - I have a 2012 MacBook Pro with Parallels but it runs mySQL database, Node-RED and a bunch of other stuff... going to try there. Wish me luck!

1 Like

That will work.


Quick q - do I first "force remove" the device from HE? I'm on a C-5, so my Z-Wave details page is different and I don't see "ghosts". Currently, I can see the Ring Extender in the PC Controller app and also in my HE Z-Wave Details page...

Also, the Ring Extender is battery powered, so I cannot "remove power" from it!

Faraday cage that beast - Wrap it in foil or something.


Also you have to do the "Is Failed" test first to get it to be marked for removal.

1 Like

:rofl: - seriously? I guess I can do that. Also, force remove from HE before?

You can or wait and remove after you've removed from PC controller. Not sure it matters either way.

1 Like

Yeah you need someway to block the signal from the Extender to the hub.. you could also take it out of range but the foil wrap trick works. I had to do that with my Aeotec Stick which also has a built in battery - talk about ghost-ception.. :ghost:
(fortunately had another stick on hand I could use to remove it)


Yes. Kind of a weird process:

  • Unplug the RE2 from the wall
  • Put the hub in exclusion mode
  • Use a paper clip to momentarily press the reset button on the back of the RE2

Well - I got the Ring Extender removed using the PC Controller and also removed it from HE. But I can't get the Z-Wave stick (PC Controller) excluded now

I'm selecting ID 30 in the PC controller software, doing the NWE (HE is in exclusion mode) and ....nothing!