Ring integration

Maybe I'm in a minority? Or maybe I'm just stupid and can't search properly?

I decided that I would give it a shot trying to integrate Ring. I'm not looking to do anything crazy. I only want when someone rings my doorbell and it's nightime that my lights on my front porch go on so I can see who is out there before I open the door. Seems logical, no? Something I liked with the integration with Ring / Wink but Wink.... well, ehhh

I've tried this a few times and spent several hours this afternoon so I'm going to start from scratch and keep this window open and document all of the different things I'm doing as I do it


I cut/paste the code from here

And I pasted it under the "Apps Code"


I cut/paste the code from here

And I pasted it under "Drivers Code"


I went to Apps and then to "Add User App" and clicked on "Unofficial Ring Connect"

The very first drop down is "Log into Your Ring Account" so I selected that

I logged in keeping the 2FA toggled since I know Ring wants that. Got the text and provided the code. Got alerts on both of my phones that a new device was added (at this point I'm thinking Ring is going to cut me off since I've done this nearly 20 times this afternoon!)

I select the location I want and get an error

Error: Device type 'Ring API Virtual Device' in namespace 'ring-hubitat-codahq' not found


I search the Apps Code for 'ring-hubitat-codahq' and find it toward the bottom under @field static def DEVICE TYPES

I changed a few things on the WS_API_DNI line

for name : "Ring API Virtual Device" >>> "Ring Video Doorbell" since that's what I have
for driver : "Ring API Virtual Device" >>> "Ring Virtual Camera"
and for dingable "false" >>> "true"


I went back to Apps and "Add User App" and "Unofficial Ring Connect" and log in again with the same error as above.


I realize that I read somewhere that I need the 0AUTH enabled so I go back to "Apps Code" and click to enable the 0AUTH


I go back to Apps and "Add User App" and "Unofficial Ring Connect" and it won't even let me try to log in. So now I uninstall the "Unnofficial Ring Connect" app and re-add it and log in again and it works (interestingly it was only at this point that I got a text from Ring from a different number (22395 vs 78156)


Now I click on "Getting Events from Ring" and then "IFTTT Integration and Documentation for Motion and Ring Alerts" and I get an error

Error: Cannot invoke method getDataValue() on null object

This is where I'm kind of stuck. At some point earlier this afternoon I got past this and was configuring an applet with IFTTT but the action I was posting didn't populate on the tutorial and I got stuck there as well

It's not a HUGE deal and I've been dealing without this functionality but it's kind of nice and, at this point, I've invested so much time I really want to conquer this one

Honestly, I would forget about Ring and just put a motion sensor out by the door. Set it up so the porch light comes on with motion when dark. Lights come on whether bell rung or not.

Ask this in the proper thread... [Re-release] Hubitat Ring Integration (Unofficial)

1 Like