[RESOLVED]Aeotec Doorbell 6 After Update

Anyone else having trouble with the Aeotec Doorbell 6 since the latest update. Mine is no longer reporting events when the button is pushed on the doorbell. The doorbell still goes off correctly, so i know it isn't a problem between the button and the base unit. And I'm able to send beep and strobe commands to the doorbell, so I know the device is still on my mesh. Wondering if this is just a one-off or are other people having Z-wave issues since the latest update?

Oddly enough, there are no events logged even if I "push" the button from the edit device page. It's like the events just disappear and go nowhere. I've turned on Debug logging and I see the event occurs (and I can hear the doorbell go off) but the event is still not be initiated from the device.

Try a volume up/down and see if you see those in the log.

Yes, I see those in the Events just fine. And the volume is changing. The only thing that is not working is the events for the button presses. So, that tells me that something changed with the driver in the latest release. There was a change for the Aeotec Range Extender 7, I wonder if something is common between the two.

Would probably need to ask @mike.maxwell if the Aeotec Range Extender and the Siren/Doorbell share some common code.

I'd really like to avoid having to exclude and pair it again as I use it as a tone device for SEVERAL rules. Would take forever to add it back in again.

Nothing changed with the doorbell drivers in 2.1.7.
If you enable debug logging in the driver do you see button presses?
Also have you tried running the configure command again?

I have tried running configure again, no help. I do not see the button presses in the logs for physical button presses but do when I issue "push" from the driver. The doorbell always makes the correct sound, whether from the driver or the physical button. Just no events for either.

(Note: Ignore the numbers, I was playing around to see if using a different number would get the "pushed" attribute to change but obviously it didn't. It stayed at 1.)

Same here. @mike.maxwell has something has changed in 2.1.7 with respect to the Doorbell 6 driver?

1 Like

So, I'm not going crazy! (Or crazier, depending on your perspective :wink: ) Good to know that I'm not alone!

hmmm, and rolling back to 2.1.6 and the doorbell works right?

I didn't want to roll back if I don't have to as it will screw up my Thermostat Scheduler...as noted by Bruce. But it was working before upgrading to 2.1.7. I can see both switch and button events in the list for before upgrading to 2.1.7

If rolling back is the only way to tell, I can. But if somebody with a dev hub and a doorbell could, I would appreciate it. Not as easy for us "one-hubbers" to do that kinda stuff.

understood, I have one of these, but the remote button has never worked.

DOH! Well, if the only thing that will be affected by rolling back to 2.1.7 is that I won't be able to control my thermostat scheduler app, then I can try rolling back. I don't have to restore an old backup too, do I? Cause I'm not sure that I have one old enough.

no, no need to restore the database

Okay. I can do it later this afternoon.

Could this be related to the change to z-wave.

1 Like

don't know, that's why I'm hoping to get confirmation that the issue is specific and was introduced in 2.1.7

Just had a friend with this doorbell try it (I don't have one) on the latest firmware, and he said the same thing: doorbell button doesn't do anything, but all aspects of the siren portion seem to be fine.

@bertabcd1234 had me try mine and as he said it is experiencing the same issues. If I use the device page and press button one, the doorbell still chimes even though nothing is in the log. However the chime is contorted sounding and sometimes will sound 4 or 5 times in about 15 seconds. If I press the physical button, everything is normal except there is no record of it being pressed in Hubitat.


In the latest version ( no chime playing events were showing up in the system logs. I rolled my Hubitat back to, played the chime, and it shows in the log:

dev:2602019-12-06 01:10:06.666 pm infoSiren 1 - Chime (Aeotec) stopped
dev:2602019-12-06 01:10:01.781 pm infoSiren 1 - Chime (Aeotec) playing '1. Ding Dong'

I have the Aeotec Siren, not the doorbell version. Therefore I do not have the button to test. I used the Beep from the Chime child device page of Hubitat.