Repeated hub crashes with 2.2.5 on a C-5 hub

Don't recall one directly commented on by staff, although I'm sure that there probably is, but if you do a search on 3210-L and Zwave issues or device lockups you'll end up with a few pages of threads.


Yup. To add to this, my recollection is that the issue crops up dependent on the fw version on the the 3210-L outlets.

1 Like

I've been having the same crashes since upgrading to 2.2.5. I'm also on a c5. The crashes happen intermittently, sometimes after a few days, mostly every day, and one time an hour after unplugging and plugging it back in.

Did you figure out what caused it, or did you get a response from support?

Just an update here: the hub was fairly stable (making it multiple days without crashing) for a few weeks.

In the past couple of days, it's started crashing multiple times a day. (No device or config changes)

I'm rolling back to 2.2.4 to see if that helps.

@ari I have had the same issues as you. I rolled back to 2.2.4 and have not had a single issue in weeks.

1 Like

I haven’t read this entire thread, but if you’re experiencing crashing, I recommend taking a backup, doing a soft reset, and then restore your backup.

I was recently having issues with some hanging with my C5 and that resolved it.


If you didn’t properly shut it down first, you will get database corruption. This is the main reason my hubs are plugged into a UPS.


+1 - there is a host of weird issues that a soft reset may resolve.


I took the advice above. I upgraded back to, created a backup, did a soft reset, then restored the backup. Woke up the next morning to find out the box froze up again overnight after working flawless the past few weeks on 2.2.4. I've rolled back to 2.2.4 and will probably stay here for a while as I need my routines to reliability work.

So this may be kind of related - I have a set of test virtual switches - one for each of my 3 hubs (C-7, C-5, & C-4). I use an external system to toggle them on/off for heartbeat testing every 15 seconds via the Maker API. It's been running constantly for a few weeks and I noticed my C-5 starting to act up a bit. Slow responses, appearing to disconnect/reconnect - got a severe load message etc.. The other hubs did not seem to be experiencing the same issue. Ended up disabling for now on all hubs and rebooting the C-5. Everything is back to normal.

The C-5 is on the latest firmware and only has Zigbee enabled + grouping, lock code manager and 3 instances of maker api.

Anybody solved this problem with the C5? I have this problem for weeks now trying to find out what it is.
On the 2.2.4 i had no problems then after an upgrade to a newer version the system kept hanging so i switched back to 2.2.4 for a long time.
Now a couple of weeks ago i decided to upgrade the firmware beacuse i thougt the problem would be solved but the system keeps hanging again and now i can't go back to 2.2.4 anymore.
already did soft reset then device hangs after 2 days.
even removing apps and diffrent drivers has no effect device keeps hanging after a day.
i even soft reset device and didn't add any devices with an empty hubitat and then it hangs after days.
i think this is a problem in the firmware and im not going to solve this.
my ip range is in the 192.2.xx.xx maybe this has to do with it.
the logs don't say anything.

Even the device and app stats logs? Usually you can find something there,,

I have a C-5 and have not had any issues like that and am on the latest firmware, In my case I am running Zigbee only, minimal apps and only a few custom drivers so that’s probably the reason.

One of my residential clients is running a C-5 with a similar config except ZW & ZB are both active. No issues to report there either,

If you’ve already tried a soft reset and DB restore it sounds like you may need support (@bobbyD) to take a look at your hub.

1 Like

I will soft reset the device again and leave it complete empty without drivers/apps and devices and will wait till it crashes maybe i can get more information from it.
if i know more i will try contact @bobbyD.
thanks for your replies.

Did this ever get fixed for anyone? I decided to upgrade for the first time in 5 months and yup, it crashed a few hours later! I'm betting they're forcing C-5 users to buy the new hub. And guess what! When you upgrade to 2.2.7.*** downgrading doesn't work!

So now I have a bunch of equipment that doesn't work. Thanks Hubitat! I guess it's back to SmartThings for me....

I have two C-5s and one C-7 on the latest platform (2.2.7.x) with no issues.

Your accusation is malicious and untrue.

I’d suggest contacting support to figure out what the issue is with your C-5. I suspect a corrupted database that can be fixed by a soft reset.

Tagging @bobbyD.


I did, they stopped responding when they couldn't figure it out.

Have you tried using the community?

Yes, I had an open ticket months ago before I gave up and an open forum post which also went cold.

Today I decided to upgrade again after 4 months and ~4 hours later it crashed. I did just figure out how to rollback, the restore function from the app doesn't work.

Did you restore the Database? Or did you use the Diagnostics Tool to revert to a previous platform/firmware version?

1 Like