Remote Administration Subscription Question?

Hello, is Remote Subscription required to make use of Google Home/Assistance ?

No. Google Home and Alexa can be integrated for free. Also, Hubitat Dashboards can be used remotely for free as well.

The Remote Admin subscription is only for connecting directly to you hub when away from home.

3 Likes

Without the use of a VPN*

1 Like

Well, then after much studying the problem of it not working (Error: "The parameter "State" must be set in the query string." I will consider the Google Home/Assistant a bust on the Hubitat or Google platform not sure what background code on which platform is the problem. Sure wish that Error was a bit more descriptive. I see the Errors URL mention "cloud" thats why I asked this question.
I watched the video on Hubitats website to setup Google Home/Assistant. I read all the postings on the subject at the Hubitat community.
Thanks for clarifying my question.
T

Well....maybe we can assist. Can you post a screenshot of the error you're seeing and a little more information about how you got the error? (e.g. what were you doing when it occurred).

2 Likes

Just to make sure we're all clear... Are you trying to integrate a Google/Nest Home Hub device with Hubitat? The typical voice assistant device from Google?

Or, are you attempting to integrate Hubitat with Google Assistant Relay, using a NodeJS server on a RPi (or similar)?

Google Home Hub and Google Assistant Relay are different, from my perspective.

2 Likes

Just my google pixl 4a phone. I don't have any google voice products at my home other than my google phone
I will post a screen shot and where the error took place

Okay, so I assume you're simply following these instructions from Hubitat?

https://docs.hubitat.com/index.php?title=Google_Home

1 Like

I agree that the error is not helpful, but is distinctive enough to make searching the community stand out. Here is another thread that featured the same error:

https://oauth-redirect.googleusercontent.com/r/hubitat-intent?error=invalid_request&error_description=Hub%20is%20not%20responding,%20please%20verify%20it%20is%20running%20and%20connected%20to%20the%20Internet

"The parameter "State" must be set in the query string."

&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
The above is the URL Error
&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
https://oauth.cloud.hubitat.com/oauth/select_hub?scope=app&response_type=code&redirect_uri=https://oauth-redirect.googleusercontent.com/r/hubitat-intent&client_id=940ad5fc-0f0a-4653-b6d4-520346d11678&state=ABJZP0rOerDHdTVhAxZEGWhezdzHZtF963IAoHifBF5rUzxNPWm1FA1Ii3aVyDBjnpp158gE92Gco2UkNPcxonmna8ER9bdZgQ0uIfJhR7NHi9rFjyESydzAfxBWvd1rJBdXHpJayP-DNVvJu0PbZGrmhhnx2Pd9xtbyyZqbY9guKw6M8Qa_M9g6IPgGCLECr5nK8vIkSZv8GGy5mS7JzPtF8OIDGtY1pdBOPEE6Wu4BaTYALai9I-RJJVQvn5GLu8-ds10e8Bhn-dBgJAueKeEUynyUW5rc_43bpAQAlXX8wgDvyXJd5ck0DvyGhvbHQwrS8F670BLrZxFsU1CUjrAnWvlFXKU5m-baMGZPB2AUexGup3WRdjlglMNmdiORExoMo6cubAdai-nhxAJLFqk9cqTMy1IR-27RO09k-mTYZ32KKRoQkEI7t12Q7VopgxgKb6sTLyEs7N68jojPw37Oo6ubM0ry75j8LpFJUeTMCzFm09gc7kST2Lf4NklenswsFLQ9bLwYDRJsJAZej97V7O6zsLzTL0Md6GdhnhwrU84QjhQ6q4kOTjT-HBppS4ZmJ0pMXNtG3_nKU14Tt6bezROUSZmn5P4kjcDkJ61-yjW6QAipyR1xKMpT-Con-1IAc7czc9ltHKyb5IZ3uAgYZ10PXY1xnw

This one here is the URL right before I click "Select the Hub you would like to allow access to"
your example on the setup page says Scottsdale and a radio button for selecting it.
My setup page on my phone says Friend Home with a radio button. So, when I click the Select button I get the URL Error at the top of this page.

It looks like a connection error, maybe Im wrong.

T

Maybe my Frontier Router firewall is blocking it...

Hum, just following the directions to set it up. Its all local here at home and my phone is connected to my local home network here.
It is my hope that others with this issue would also submit their evidence/clues/URL strings and screen shots so that this issue could be laid to rest.
I will have some more evidence to submit later on...would this be the correct thread to post it?

Thanks for the feedback. Do you have any Google Home compatible devices connected to Hubitat, yet?

1 Like

Yes, I have 2 "Z-Wave Smart Plug Dimmers Model #N4002. Trade Mark name: 'new one'.
They both work fine with a rule I set up. These are the only two devices on the zwave network.

These are the Broken items on my new Hubitat in Florida.

  1. When clicking Hub system update the page just goes on and on and never responds...
  2. I get no hubs registered or associated with my email address...
  3. After signing up and getting verification that I have Remote Access. It does not connect when
    away from home using a Chrome browser on my google phone...
  4. Google Home/Assistant can not see or connect to my hub from my google phone local or
    remotely.
  5. I rebooted Router, Hubitat, PC, and the phone. The Hubitat Hub features above do not work. The only
    two devices on it are two plugin dimmer switches for lights which work fine locally, But not remotely.

I would like to get these Items repaired or should I pursue warranty course to get my Hub replaced or a refund.

Who should I contact for this support ???

Thanks,
T

All of those issues seem to point to an issue with the Hubitat hub and the local area network. By any chance, did you configure the hub’s network settings to use a static TCP/IP address? If so, try using DHCP instead to see if that resolves the network connectivity issues.

4 Likes

There isn't much on our side that we can do. Your hub isn't connecting to the cloud. Identifying what is preventing the hub to access the internet is the only way to resolve this problem.

Do you have any special rules in your router's firewall that could prevent hub's access?

3 Likes

Thanks for getting back to me, I will check into the firewall settings and rules and test it.
I will get this done in the Morning and post back here what I find.
T

2 Likes

I did set my hub to a Static IP address at the initial installation. My bad.
After I changed to using DHCP server setting on the Hub and rebooted, all of the problems I was having have been resolved.
Thanks for your help ogiewon Ambassador, and bobbyD

3 Likes

Very happy to hear that! Now you can really start enjoying your hub. Have fun!

2 Likes

Download the Hubitat app