Remote Admin service doesn't work

Any tricks to get assistance from Hubitat support? I requested assistance on February 16th and I am receiving the same emails that other users have complained about, the "we're referring you to engineering" and "any further replies from you the customer will be ignored by our system" emails.

All that I'm seeking is to have a hub deregistered so that I can re-register it. It has an incorrect IP in the registration and is therefore unreachable locally via the phone app and calls in drivers that reference the local IP via variable fail.

Suggestions to get support to respond?

I don't think re-registering the hub will fix this.

Maybe we can try to help while we try to get you connected with support?

  • Have you set a static IP in your internet router?
  • And the hub IS accessible via computer, just not phone?
  • Have you tried uninstalling and reinstalling the phone app IF it is just the app not working?
  • Anything else you have tried to resolve the problem, like rebooting the hub, changing ethernet cables, or any settings in the hub or phone app?

@aaiyar @ogiewon or @bertabcd1234 any ideas of stuff to check?

3 Likes

@sarah-norbert If you set a static IP and cannot remember what it is, here are the instructions to reset the hub to use a DHCP IP address assigned by your router.

https://docs.hubitat.com/index.php?title=Network_Setup

7 Likes

Good afternoon Sarah. I have had an incident where my hub was "unreachable". I don't know why or how it happened, although I have some theories. In any event, the important thing is to get reconnected.
You might be sure your computer is on the same local network and go to this address...

https://portal.hubitat.com/findmyhub

Hubitat will search for your hub, and most likely find it. Then you can see what the IP address truly is.

2 Likes

Thank you everyone for the suggestions on a fix and my apologies as what I'm really seeking is a suggestion to prompt Hubitat Support to respond.

I checked your case and is still under review. The registration wouldn't change the IP address. The IP address is assigned by your router. Your case may be indicative of a hardware malfunction. A reset would not resolve the issue. If you set up a static IP using the networking settings on the hub, you may want to try to reset the network by holding down the physical button on the hub for 10 seconds, as @SmartHomePrimer pointed out above.

1 Like

A bit of further information on the actual issue itself. I have assigned a static IP for the hub in my router. I have made no such change in my Hubitat itself. The Hubitat is connected via a WiFi extender with a Ethernet port as a temporary fix until the electrician fixes the Ethernet line in our newly constructed home. The Hubitat is assigned to static IP 192.168.68.56 and is up and running. Our entire house runs on this hub, not a light switch in the place, etc. Everything worked properly for the last 2 months until one day when we had an internet outage. Following the outage I had to work a bit to get the WiFi extender back up and running. A soft reboot of the extender did not work so I had to bring it down entirely and power it back up. Following that event the IP address on the Hubitat registration page changed to 169.254.9.222. It is my suspicion that this IP is in some way associated with the AWS server that is used for remote access. Due to this registry entry I am no unable to connect locally via the Android app. I can still connect directly via the Hubitat's IP of 192.168.68.56. The Hubitat is functioning well and I can administrator via remote admin and via direct IP connection. In addition, code that calls location.hub.localIP will fail as location.hub.localIP returns 169.254.9.222 and not the correct local IP 192.168.68.56. A picture of my registration entry is attached.

Again my thanks for all of the responses and I continue to believe that it might be best to try the simple approach of dropping the registration entry and allowing the hub to re-register. Indeed I recall finding a post here in the community with a similar issue and that was the recommendation. If I can find that thread again I'll add it here.

Thank you @neonturbo and I have covered off on your questions in another comment just now.

Thank you @SmartHomePrimer and as you will see in another comment I have only assigned a static IP at the router itself. The Hubitat is up and running and reachable via IP. The IP in the registration data is preventing Android app access and it fails code that calls location.hub.localIP.

That 169 address is used when devices cannot find an IP to use. I found this on google.

If you see a 169.254.x.x address, it means that the DHCP server is not reachable. The PC will not work because there is not a router to or from that PC. Troubleshoot this by finding out why the PC cannot see the DHCP server.

Have you tried just power down the hub totally, and then restarting it? I should try to ping the DHCP again to get a valid IP. Or maybe there is a problem between your extender and the router where DHCP is not reachable. Try connecting another device to the extender, to see if it can get an IP from the router DHCP.

3 Likes

Thank you @robertsonslodge and I believe that the URL you posted is the one for hub discovery. If so, I have tried this on many occasions but it does not find the hub again because it believes, I think, that it has already found it and registered it. Hence my request to unregister the hub so that I can re-register it and hopefully overcome the incorrect IP address in the registration record.

Thank you @bobbyD and to clarify I am trying to change the IP information in the registration entry itself not the IP assigned to the hub in actuality. The Hubitat hub is up, running and addressable at it's assigned static IP. It is only the registration entry and the value of location.hub.localIP that reflect the odd IP.

Thank you @jtp10181 I did not know this about 169.254. It is a good piece to the puzzle. As everything works correctly now except for the registration entry your information leads me to a new working theory. I suspect that when my extender went down the Hubitat registration system picked up the 169.254 address. Unfortunately it has retained that address even though I am up and running just fine now. Oh and to answer your question, yes I performed a fully reboot and power up and down when the issue initially occurred last month.

And for those with further interest attaching the info from my router

That IP listed in the device info is not how your hub is contacted from outside your local network. Mine is a 192.168 address which is behind a NAT firewall in my home, which is likely the same for the majority of people. First step I would do I go to Settings > Network setup. Launch the network test page. Try running the various tests on there to see what you get. I suspect the hub will not be able to communicate outside your local network. From the network setup page you could also try manually setting a static IP on the hub interface, the same as what you have assigned on the router. Reboot the hub and see if it picks up the correct IP on the device info. If that works, then try switching it back to DHCP and rebooting again.

3 Likes

Ah heck, just noticed that the first 6 of the Hubitat MAC address changed. See the two attached pictures in this thread. This is the second device that has reported a MAC address change in my environment. I posted about a similar occurrence these community pages. I wonder if this MAC address change is a "cause" and, how in the world does a MAC address up and change? I'll need to check the physical label on the hub when I get back in town.

This is common with range extenders when using a Wifi backhaul. They change out the start of the MAC to make it unique so it can differentiate between the packets coming and going. The range extender is basically acting as another router, but on the same subnet. I have a Netgear one which also does this, it is quite annoying which is why I only use it if I have to. Although once devices got the modified MAC from the extender I think it was consistent. Maybe when you reset your extender it changed the MAC prefix it was using.

Further info, the MAC reported on the Hubitat interface would be the true MAC. The one reported on the router is the modified MAC from the range extender.

5 Likes

@jtp10181 I will when I return home and as secondary info the hub is communicating well with Alexa and other cloud services. In other words no loss of functionality. I'll be intrigued to see the results of the tests that you recommend. Thanks!

Hmm, then I suspect somehow it is still able to communicate outside the network even with that bad IP in there. That bad IP might just be confusing the hubitat services for some reason making them not work.

Maybe if you set it to a static IP and then back to DHCP as I said above it will reset that IP and get it working again. Let me know when you can test it and what you find out.

2 Likes

I had the same issue with a TP-Link extender and switched to using MoCa adaptors and my old coax cable. Now my MAC addresses stay the same.... And it acts like a ethernet line now.

3 Likes

Download the Hubitat app