[Released] Rule 4.0


#964

No, that doesn't work. Tried that multiple times. I just get the screens I show.


#965

What happens when you click on Done with this Action?

ELSE is always 'blank', on a line by itself.


#966

This is exactly what I get when I save ELSE.


#967

I tried that... It didn't work correctly.


#968

So Insert Action before does nothing ? Works for me....


#969

That’s as it should be. You could delete the END-IF for now, and add the cancel.

It's going to look like this:

IF (Large Bathroom fan is on) THEN
   action
ELSE
   action
END-IF

#970

I tried ELSE before END IF and I couldn't get that to work either. I cannot add ELSE actions anywhere that I can find. There is no menu, no selection box, no toggle, nothing. Just what I show in the screenshots above.


#971

Do you see the button called Insert Action Before? Click on that and select END-IF. Then you can add an action that will be after the ELSE.


#972

There is END IF, but there is no cancel. I have (had, see below)

Now without touching anything, I can no longer even edit the actions. I only can edit conditions. I even exited out of the rule, tried updating and exiting, and everything. I literally walked away to grab a snack, and now the whole rule is messed up without editing or touching a thing.

Now I can't get any rules to add actions, it just keeps looping back to conditions when I try to add actions.

Restarting hub...


#973

There is no cancel because you haven't added it yet. Cancel Delayed Actions is its own action. It is not part of the ELSE. It has to be added after the ELSE. It will be on its own line.

Just delete the rule, and start over on it. It's not at all clear from your descriptions what is wrong.


#974

Bruce, I have redone this rule from scratch a dozen times. I am telling you, there is no way to insert anything after ELSE. I either am not pushing the right button, or something is wrong. Maybe I need a step by step, but there is no inserting anything before, after, or otherwise to ELSE.

What exactly should I be doing after I press done when inserting ELSE?


#975

Add another action after that.

At this point, you click on Select Action Type to add, and pick Cancel Delayed Actions, like this:

Then Done with this action. Then you will have this:

Click on Select Action Type to add again, and pick Conditional Action - END-IF, Done with this action.


#976

Bruce, I believe I already tried that.

Something is totally screwed up now. No rule new or otherwise will now let me add IF>THEN statements, or maybe even any actions. It seems to loop me back to triggers every time I try to add an action. I even restarted the hub and that didn't help.

I hate to uninstall RM and delete the few simple rules I have, but at this point I might have to, it seems something is totally F'd.

I think I am going to have to take a break from this tonight. I just can not wrap my head around Rule Machine. I cannot possibly be that stupid that I can't find that one setting.

I am using Chrome on Windows 10 desktop, so nothing particularly funky here.


#977

Here is how you had it.


Indeed. I've never heard of anyone having this problem. Which is it, you can't add actions or you can't add IF-THEN? Those are entirely different problems. You have to show step by step screenshots.


#978

I will try all this again tomorrow. I am going to delete everything, and reinstall RM. It keeps doing different things, and seems to be getting worse every time I attempt to build another rule. Nothing is working, I can't even get back to where it was somewhat working a while ago. It is stuck in some weird place where I cannot do anything other than add a trigger.

I am trying to follow the documentation, but that is making it worse than trying to copy a rule I saw on the forum. It is also confusing when your box that says "Delay or Repeat Actions, Wait" then has a sub-menu with something entirely different than the first selection. Shouldn't that say "Delay Repeat CANCEL Wait" if that is where cancel is hidden?


#979

There is only so much space, and Cancel Delayed Actions is clearly related to Delay.


#980

OK, I get there is only so many characters per box.

Why aren't all the similar actions grouped together then instead of cramming them in one selection? Put all the waits in one selection, cancels in another, exit/exit in their own, and so on. Sure the actions dropdown would be longer, but that to me would be better than just cramming everything leftover into one poorly named item. This would really help when you are looking for a particular phrase or item.

I think my RM installation is corrupted or somehow damaged, so I am not sure this would have helped me, but please consider the above suggestions.


#981

Are you ever using the "back" funtion of you browser? Because I can advise you to never do that if you have. It will make things even harder too grasp. RM will save where you were and by going "back" with you browser you expect it to cancel what you do and go back but instead it doesn't cancel what you where doing. So when you press something else after going "back" you'll end up where you were because you haven't finished that yet. It's really something what messed up my brain at first. But it was pretty simple once I learned myself never to go "back" with the browser.


#982

No, I only used the Done or Cancel buttons. Someone suggested that to me before. I didn't think I was using the browser back button, but after that I paid closer attention. And I was definitely not using anything but Done or Cancel or whatever was available in the Hubitat UI.

I actually went ahead and deleted RM, rebooted, and reinstalled and rebooted again. I can no longer add an IF > THEN. It gives the IF option, and I can (for example) add a switch or something, but no ability to add sub expressions of any type. It doesn't even give that option any more. It also sometimes adds two identical actions when I save only one.

I don't know where to go from here, I lost the few rules that did work, and now I cannot get even those working. Multiple reboots with no change either. The whole thing is completely fubared.

I am totally bewildered at this point. I didn't do anything, and it somehow got into a state where I no longer can do anything. I swear something has been wrong all along, but almost nobody has had this issue so it must be something unique to my hub or software.

I have been observing this same weird behavior with RM for months now, but it is worse than ever. At one point I thought it was some type of bug, and there was a bugfix in the (latest?) update or two for an issue I think I was having. But this is far worse than a simple bug at this point, it is unusable period.

Everything else seems to work fine, I have well over 100 Zigbee/Z-Wave/Caseta devices that seem great, and the community apps and drivers I installed all seem to work fine too. The stock apps like Motion and Simple lighting all seem to be working fine, but I don't have every stock app installed. I don't want to mess with rolling back or anything for fear I will lose everything at this point. Maybe the upcoming update will clean things up? I don't know, but I will just find other ways to do things other than by using rules.


#983

Here's my development Hub.. Apps page. Yesterday I fully factory reset it because I wanted to test some of the code I was getting ready to release. No RM.

10%20PM 31%20PM

I install RM and then, before creating a rule, I click Done.

06%20PM

So now, my hub should be like your hub....

I Create and name a new v4.0 Rule...

Created the Trigger...

08%20PM

All of the above you've indicated works properly....

50%20PM

I click Done with Trigger Events and get back to the 'outer level' of Rule building. If I were to click Done here.. I'd go back to the main Apps list. Not going to do that, but could...

I click Select Actions to Run and get:

I click Conditional Actions and get that choice...

I'm going to pick IF (conditions) THEN

52%20PM

and New Condition...

49%20PM

Then I create an action... if a switch is off

45%20PM

and click Done with this Condition in the lower right.

06%20PM

Ive got no more conditions to add for this IF-THEN, so I click Done with Conditional Action

I want to DO something with this condition... so I pick a switch.

33%20PM

22%20PM

And turn it off too. And Click Done with this Action..

36%20PM

SO that's it for the IF-THEN case, I want to add the ELSE case....

51%20PM

Pick Conditional Action again, and ELSE is available, so I pick that.

04%20PM

Click Done with this Action

27%20PM

ELSE shows in the evolving rule and I pick to control a switch again...

49%20PM

This time turn On the switch.

13%20PM

Done with this Action, again because it's all I want to do inside the ELSE.

All that's left is to close out the Rule with an END-IF.. so back to Conditional and select it.

25%20PM

38%20PM

I'm done but the Rule is ready to carry on with yet another IF-THEN-ELSE if you wanted to...

57%20PM

Click Done with Actions and the Rule is Done.

59%20PM

Click the final Done... and the Rule is in the Apps list.

48%20PM