[Released] Rule 4.0


#984

A ton of screen caps for nothing if I completely misunderstood the symptoms. :frowning:


#985

I got burned by some really strange things happening with RM once, and just for the hell of it, tried a different browser. Everything worked ok then. Before giving up on RM, try a different browser, and try making a new rule there. At this point it can't hurt to try it.


#986

All of the Above was from Firefox on a Mac.


#987

I think having a step by step visualization like this is great. Need to find a way or place to post it to where beginners can easily find it.


#988

And then @bravenel "improves" the UI and it's obsolete by September. :smiley: :smiley:


#989

No, not obsolete. Just a way of saying csteele, you have to update the doc :wink::yum::innocent:

btw: Big + for sharing the screens!!!


#990

We can't help you if you don't show screenshots of what you are seeing. Also, rebooting the hub repeatedly is pointless. You could roll back the platform software to a prior release without risk. Also, you should have backups saved to your PC.

Have you tried Rule 3.0? Does it have the same behavior as Rule 4.0?


#991

Is there a way to override a rule?

I currently have
image

If my Lamps are on and I turn them off using google home I would like to cancel them coming back on if motion is detected and then reset back to my rule at 5:00 AM


#992

You could Pause the rule, using another rule that is triggered by google home turning something specific off (add a virtual switch for example), and then resumes the rule at 5:00 AM (using Wait until 5:00 AM after the first action that Pauses it).


#993

Ill get on that


#994

So I re-enabled RM after today's 214 update. I don't know what or why, but RM 4.0 it seems to be OK at this point. I don't know how or why it was so messed up the other day, but I am able to rebuild rules I had and able to add new ones.

I am not seeing any of the weird behavior like the other day. I am using the same browser, computer, and everything from when I was having the issue.

I still wonder if there is a bug somewhere but I can not duplicate it at this time. Can one built in app get corrupted somehow and the update did something to straighten it out??? :confused:

So I guess call this solved? :thinking:


#995

I definitely noticed that repeat every 30 sec of anything and excessive logging slows down the hub few hours after a trigger event.
RULE OF THUMB: no often repeats and no excessive logging in order to have stable hub


#996

Always good practice to properly close IF clauses explicitly :smiley:


#997

Oh man, I updated my hub this morning, and RM died completely... any way to fix this on my end? I tried a reboot, but no dice.

Hubitat Elevation® Platform Version

2.1.4.125

Hardware Version

Rev C-4


#998

Do you know what you were doing when that happened. Try restoring a backup of your database and see if it still does it. If so, then you should roll back from this release.


#999

I was logging in with the intent to create a new rule, and also to reboot the hub due to some instability issues when I saw the update. After triggering the update, I did not touch it again for about an hour, IIRC.

Does the database back up automatically? I've not touched any of these functions before.


#1000

browse to Settings: Backup and Restore.

Click "Create a new backup and download locally"
That will get a current copy of the DB onto your computer, in case it's needed later. If you're not in a rush, go ahead and click Download for at least one older too.

Then click restore of the Oldest (probably the last line showing) and let it complete.

TEST
Is it working right now?

Yes? Wonderful. Get comfortable with taking a backup periodically.

No? OK, same deal, Settings: Backup and Restore and above the list of on-hub backups is a sentence it's easy to overlook:

"If you want to restore a previous Platform Version click here."

"Restore Previous version"

Click there and choose 2.1.3.128 or 2.1.4.119, which ever one you were on before.

56%20PM


#1001

Got it -- I tried to restore DB of one today, (after it started having issues,) and also restored one from yesterday, which was on another version.

Still get the same error.

Sounds like maybe I'll need to roll back to the previous OS, then restore a compatible DB.


#1002

Thanks for reporting this, and for your patience. What you've told me is what I needed to know. This bug will be fixed shortly.


#1003

The latest release should fix this problem. Please give it a try and let us know!