[Released] Rule 4.0


#904

If the trigger is active, then why do you need the IF-THEN at all?


#905

By jove I think you're onto something.


#906

If I remember the steps it went like this.

Setup triggers
Setup actions in this order

  • Conditional action
    • IF
    • device or device or device has these triggers
    • THEN
    • turn on fan
    • ELSE
    • turn off fan -> delay 30 minutes

This created the rule correctly and I can edit it.

It's the same steps I have always taken for setting up 4.0 rules. But it failed 2 nights ago and then last night it failed twice. The 3rd attempt worked just like this one.

Come to think of it when 4.0 came out I tried it the first time and I recall having the same problem happen and ended up just making a 3.0 rule.


#907

Do you mean the Conditions created from those triggers?


#908

correct


#909

Can you reproduce the fail?


#910

I just tried again and it didn't fail...

Im going to try something else and see if that's the step that foobars it up


#911

Can't make a fail still.. I even tried a nested IF IF

IF
THEN
ELSE
IF
THEN
ELSE
END IF

Still saved and editable


#912

Well shit this is a stumper.

I went in to change the trigger values because I thought that would have triggered the fail but it didn't.

What I don't think should be happening is that after I change a trigger value the action for that trigger should also update... instead I have to go in and edit each action for the corresponding trigger. That really should have to be done.

I though that was the fail but nope.... I can still edit the conditional actions.


#913

@bravenel rule broke after I changed a trigger value.


#914

Could you show the rule, here or by PM. The main page, and describe what you changed.


#915

You wont believe what's breaking it...

My cell phone chrome browser. And I can reproduce it....

Update: It's fixable though.

To Break it:
I use my cell phone to edit the rule trigger. Any trigger from any rule. I save it and when I go to edit the actions the rule seems to be broken but its not.

Cell phone is a Samsung S7.

To fix it:
I use my desktop chrome browser and go into the same rule and simply edit and save the trigger the actions are editable again.


#916

When I VPN into my RPi and open apps with the browser on the RPi all sorts of weird things happen. I have to make sure I leave everything alone apart from defining new, very basic rules. Anything else and things go haywire.


#917

So essentially this is a browser induced UI break? Interesting. Is the rule actually broken? Or just its presentation? When you go into the desktop browser, is it still broken before you edit?


#918

Make sure you have the latest Chromium. It will work fine with the latest, but for whatever reason, the rPI builds with an ancient version of Chromium


#919

Can you provide more specifics as to exactly how to reproduce this from a new rule?

I tested on my pixel 3xl and can't get anything to error, but could be missing something without step by step instructions.

Can you reproduce with a fresh / clean rule?

Can you reproduce on a different mobile device, if any available?

What version of Chrome is running on the Samsung S7? And does the issue also appear if you use a different browser (like brave, based on Chromium) on the device?


#920

Yes it's still broken when I use my desktop.

No its not "really" broken. All I have to do is use my desktop google chrome browser and edit the same trigger I edited on my cell phone and just re-save it.

I can reproduce it only on a 4.0 rule and it can be a new rule or a old one.

Don't have another cell phone.

I haven't tried another browser yet... I'll do so after I post this.


#921

Using Firefox does not cause this issue.


#922

Great, any steps to reproduce, able to reproduce on a fresh rule? Able to reproduce on a different android device?

What version of chrome?


#923

I laid out the steps here --> [Released] Rule 4.0

Posted screenshot of my Google chrome version