[RELEASE] Zooz ZEN32 Scene Controller (community driver)

I did not! I will try that when I get home. I also reached out to Zooz for the firmware update. Hopefully I’ll hear back from them today.

I'm getting an odd behavior when using 'Set Indicator' from either the device page or in code.

HT: C-7
Zooz 32: FW 10.10

Regardless what options I choose for 'Set Indicator' or what color the LED is, it sets the led color (for that button) back to white. It leaves the brightness alone.


I think that is just how they implemented it. If you would like different (better? :grinning:) behavior, I'd suggest contacting them with this feature request.

1 Like

Does anyone happen to have the link for the C5 hub update? I contacted Zooz and they sent me the C7 file, which their instructions specifically say do not work for the C5. The link they provide for a C5 hub told me to contact them for the firmware file. I don’t understand why they don’t just have those links available on their support page. Anyway, I was hoping to get this done tonight so I thought I’d see if anyone else has it since their office is now closed. Thanks!

OK, This has got to be a bug...

Send a 'setIndicator' flash sequence eg(3,'flash',10,20,5)
BEFORE it finishes the sequence, send 'setIndicator' ON (3,on). I was doing this to interrupt the flash sequence.

The LED will be stuck on White. It will change brightness but not color with 'setLED'. It stays this way indefinitely.

To unstick the color send another 'setIndicator' flash sequence even a very short one. (3,'flash',1,1,1).

This will also interrupt a flash sequence and let the setLED work normally.

The firmware update file is the same. What you need is a way to perform the update, as Hubitat's Device Firmware Updater app does not work on the C-5 or earlier. There is a "community" firmware update driver that should work for this. You need the "binary" version for this update (I think--assuming the update is a .GBL or similar format), which can be found in this post: [RELEASE] Z-Wave Firmware Updater - #860 by bcopeland

I didn't do extensive testing with combinations of commands, just verified that each alone with various parameters I tried appeared to work as expected. I assume you mean a bug in the device firmware? I can't imagine anything the driver could be doing that would cause that. Again, you may want to reach out to Zooz to report this. (I don't have easy access to a real device except on weekends, so I'm unable to test this myself now...)

That link was VERY helpful - I wish Zooz had provided it. Their email was extremely unclear. The one thing I can’t figure out is what firmware target to use with the binary updater. Any suggestions? I am so appreciative of your help.

I thought this device only had one, target 0. I suppose the driver doesn't show you in a friendly list like the app does.

1 Like

You need the current firmware for it to keep the same color. One of the firmware version there was a bug where it always used white with the indicator class but I got Zooz to fix it :slight_smile:

Let us know what firmware you are on now, so if thats the problem others will know.

Do you know what version is current? Their changelog only goes to 10.10, so I assumed that was it; this is also what I have and tested this on, and I think I saw this behavior there. If there's something newer, I'll have to reach out to them again and ask for it. Glad to know it should have been addressed (and thanks for asking them!). :smiley:

This is incredible - thank you to those who contributed and took the time to guide newbies.
I'm leaving Insteon and recently purchased a Hubitat. I am brand new to this - JUST started learning, I was looking for something to replace my Keypadlincs. I purchased a Zen32 to play with, but ran into the issues everyone else was talking about here, and in other threads. From the posts here, I installed my first user (community) driver and got this scene controller working as desired. The Zen32 is now controlling AND responding to scenes with Green for on, and Red for off. Just wanted to post my gratitude.

I asked for the latest firmware from Zooz on Sunday (2/20) and specifically mentioned this thread and that @jtp10181 had referenced firmware 10.11 in another thread. They sent me version 10.10 anyway, so that seems like the latest version. 10.11 must not have been released yet.

@bertabcd1234 @JCS @benjamin

Can confirm from my emails that 10.11 is where they fixed is so when using the indicator class it will keep the color you have set already. Anything older than 10.11 and it will go white when you use the indicator commands.

Have been using it on mine with no other major issues. I confirmed with Zooz back on Jan 9th that it fixed it, so not sure why they have not been sending it out. Maybe ask for 10.11 specifically?

Only issues I have is some weird stuff with the main button LED when I disabled physical control but I figured out the settings to make it how I wanted. Was trying to get the main LED to always stay on like the other buttons and I am just using it to toggle a zwave outlet via button push events. No load connected to mine, it replaced a useless switch that was toggling the top half of outlets in a room. I hard wired the outlets always on now.

1 Like

I just updated to firmware 10.10 (and version 2.0 of the community driver) and am having the same issue as @JCS (and the issue described by @jtp10181 ).

To start with, I couldn't get the setLED() command to change the color of any LED except the main button (button 5). If I tried to change the color of any of the other LEDs the main button would blink green but the other LED would remain white. I tested with both the built-in driver and the community driver from @bertabcd1234.

However, then I started playing with the setIndicator() command and told it to flash all 5 buttons (using LED number 0) and after it finished flashing LEDs 1-4 changed green. Now things seem to be working better. I can change each LED color. The LED color persists unless I tell them to flash or shut off. If I tell the to flash they flash white then return to the other color. If I shut them off they return to white when I turn them back on. However, if I flash them again after they turn all white, they go back to the other colors.

I'll reach out to Zooz to see if version 10.11 is available.

poling my ZEN32 shows that I have firmware 10.10
I got new drivers last week (Feb19th) and they sent me ZEN32_V10R10P01.gbl
I too will reach out again and ask for 10.11

Yes this is exactly what I found with 10.10 previously and Zooz fixed in 10.11, not sure why they are sending people 10.10 version that is known to have this issue.

This is the response I got from Zooz when I inquired about the 10.11 firmware for the ZEN32:


Hi All, Hope this is the correct place to post this question. when I go to install this driver I am getting a java.sql.SQLException error. See below. If I try to install through package manager I also get an error. Any Ideas? Thanks in advance

I am not able to reproduce that problem. What hub platform version are you running?

I just updated the hub to the latest firmware (Hubitat Elevation® Platform Version but I and am still getting the same issue.