[RELEASE] Tuya Temperature Humidity Illuminance LCD Display with a Clock

Hey, in my searching I was always looking for "zigbee scene controller with LCD" or something like that. It occurred to me today that perhaps there was a Z-Wave device that might do it and I found this. Nexia NX1000 and there is a Hubitat driver for it that looks pretty comprehensive. I'm looking to see if I can get one cheap to try out.

Seems close to what we are looking for, but... see the notes by the driver developer here : [Release] Nexia NX1000 . As this is a battery powered device, it 'sleeps' most of the time, so dynamically updating the display to the thermostat current setpoint may not be in a near real time... And Amazon reviews show short battery life.
If you can find it cheap on eBay it may be worth trying, but the price for a new unit is way too high.

Actually, the easiest solution would be an old Android phone running the Android Dashboard app : [RELEASE] Hubitat Dashboard - Android dashboard app . It will be very easy to make a custom dashboard with only these controls / virtual buttons that you need to remotely control the thermostat. And the updates are in a near-real-time.
The battery recharge problem will be less annoying if a wireless charger can be used with the phone.

That is a good idea with the android phone on a charging pad. I've got the Hubitat app on my phone but this seems like something different so I will look into it.

I did buy one of these Tuya Temp\Hum devices from Amazon but beware. Even though it clearly lists Zigbee in the networking protocols on the third photo the little instruction sheet only mentioned WiFi and Bluetooth and I could not get it to pair. So it's going back.

The Zigbee model is this one, And yes, on the leaflet iside the box the Network protocol should be clearly stated as Zigbee 3.0

Thanks, wish I had found that on Amazon but ended up buying one from Alibaba. Should arrive after I have forgotten I bought it and it will be a nice surprise.

1 Like

Damn, I got the wrong device too. Ordered from Alibaba and it says "WiFi ZigBee" in the description but it's not the ZigBee one.

Often on AliExpress /AliBaba sites the descriptions are wrong or misleading.. It's even worse, the same wrong descriptions are simply copied by sellers in Amazon and Walmart!

I now usually check whether the same seller offers explicit options for Zigbee and WiFi devices. And I never use a phone or tablet when purchasing anything, always make the orders from a desktop PC or laptop with at least 15" display! :eyeglasses::flushed:

1 Like

I just picked up one of these and since I had your driver prior to adding the device, it correctly paired as Tuya Temperature Humidity...

  • endpointId: 01
  • model: TS0601
  • application: 0120FFE43620FFE246
  • manufacturer: _TZE200_locansqn

However, I just can't get it to display Fahrenheit in the app or on the display no matter what I do.

My hub is set to Fahrenheit, but neither Auto Detect, Celsius, or Fahrenheit changes my reading to F. I've tried pressing Refresh alone, and also Initialize and then Refresh. When I hit Initialize, go to the Device List, and then return to this device, I lose the Advanced Settings and have to re-enable them.

I've also tried forcing the Model Group to TS0601_Tuya and TS0601_Haozee (which I believe is the correct setting for the _TZE200_locansqn). I'm on the latest version of your driver * driverVersion : 1.0.4 2022/02/20 9:58 PM that I can find.

This isn't really important, I just bought this device to play around with but after reading this entire thread I just wonder what I'm doing wrong.

1 Like

4 hours later... without changing anything, my temperature is reporting in Fahrenheit within Hubitat now. The LCD still shows Celsius and probably always will.

@Lee_K thank you for the feedback!

This seems strange, the 'application' data value is usually a decimal number... but with Tuya devices you never know!

Is there a button (probably on the top of the device) that changes the temperature scale C/F ?

Now I think that I have made it too complicated by exposing this C/F/Auto option as a preference.. I am planning to remove it, and simply use the hub global setting. There is no sense to choose a scale different than the one that is set globally for the hub. And not all devices support it.

'Initialize' button is another capability that I plan to remove from this driver. It is not needed for this type of sensors, was useful for me when I was changing different drivers back and forth, but now it is not needed.

When the 'Model Group' preference is set to 'Auto Detect' (this is the setting by default), the driver is trying to set internally the correct device model, based on the Model and Manufacturer data. But the actually detected model is not visible on the device UI page, so I can show it in the 'State Variables' section to avoid confusion.

That's a bit strange, could be a result from changing different C/F/Auto options.

I am afraid your device does not support displaying the temperature in Fahrenheit itself. This is exactly the case with the first device shown in the first post ( _TZE200_lve3dvpy). While changing C/F on the LCD display works for the third device ( _TZ3000_qaaysllp), that however has a physical button on the top...

Does your device have a buzzer built-in? I am not sure whether the alarm function is enabled by default - rapidly changing the humidity above 75% may produce a beeping sound. Does this device have a 'Reset' button on the top?

@kkossev Thank you for your detailed reply and all your work on the Tuya drivers!

Yes, my device has a button on top. Physically it looks exactly like the second image in your initial post. The button worked to find the device with a long press, but otherwise it doesn't appear to do anything.

My current humidity is 51% so I set the Minimal Humidity Alarm to 75% and also changed the Maximum time between humidity reports to 60 seconds. After a few minutes, there's no beeping. About ten minutes after making this change, Events shows a humidity report but no beeping has occurred.

For what it's worth, the product page on Aliexpress does not mention a built-in buzzer. It does state that the temp can be displayed in C or F but maybe they're referring to the App's display, not the LCD.

  1. Temperature Unit Selection in APP
    You can choose ℃ or ℉ as the temperature unit through app.

Like I mentioned before, none of this is a big deal. I only bought this unit for experimentation and whether the LCD displays in a familiar form or not, I can still use it as a trigger in rules if I want.

Thanks again for your help.
Lee

1 Like

@kkossev Do any of these devices show the time in 12 hour am / pm format?

Unfortunately I can't recall such an option.

Can you see how temperature changed over time on the graph with those drivers?

Yes, you can try the Hubigraphs community app to draw timeline graphs like this one.

Hi, friends. Newbie here. I tried to add this model (MANUFACTURER : _TZ3000_QAAYSLLP) to my C5 Hubitat, but it failed. I tried to (1) add new device); (2) add device manually - zigbee; but the device didn't appear. I paired this device to the tuya app before. How do I factory reset this device? How I start the zigbee pairing mode in this device? I tried the "reset" button - it starts the EZ mode (led flash quickly) and the AP mode (led flash slowly), but it didn't work. Any tips? Thanks!!!

Hi @tiagokm ,

Do you also have a Tuya Zigbee gateway device? If not, then there is a possibility that you have a WiFi model...

If this is the case, you can still use the temperature/humidity/illuminance sensor in Hubitat via Tuya Cloud integration : [BETA] Tuya Cloud Driver (Limited device support)

Thank you, @kkossev! You're right, I have the wifi model. I'll try the Tuya Cloud integration.

1 Like

Download the Hubitat app