[RELEASE] The Flasher - Flash your lights based on several triggers

Thank you!

@bptworld I'm trying to installed the bundle on my HE and I'm getting this message: library not found on line 44: #include BPTWorld.bpt-normalStuff

I got this from the zip upload.

Any help?

Read post #2 of Bundle Manager

@bptworld was this ever resolved? I'm having the same issue with the light only flashing twice then returning to normal state. I'm using a philips hue w/c bulb.

TF Settings:

Event Subs and App State

Logs from TF after turning switch on:

I'm using a virtual switch to test, and the switch stayed on the whole time. Hopefully the detail provided will help solve this. It seems like it's isolated to just myself and @wmoate and most likely a few others.


It does, thanks. You selected the same switch as both the Trigger device and the Control device. So when you turn on the switch to trigger the flashing, the control switch is disabling the app. So it only goes through 1 cycle.

1 Like

:grimacing: Sorry! I remember asking myself "what if I just want to use the same switch to stop the flashing?" And I went with choosing the same switch for that option. Thanks for the kind feedback!

I know the GIF complicates the flow of posts, but I just had to! So I'll mention up here that there's another question regarding TF below. :slight_smile:
Scared Homer Simpson GIF by reactionseditor

Next question

I can't seem to get the TF virtual device to show up in EE. I read in an earlier reply by @danabw that it's supposed to be available in the actions under "Notifications (speech/push/flash)." At the time of the post (Oct' 20), you said:

I'm positive I'm running the newest version since then, but I can't seem to find the option to choose the device as an action.

Using TF as in "stand alone" mode with device (using TF driver) selected

Notification Options - No selection for TF device


Thanks again!

1 Like

Ooops! Fixed over on the Event Engine side!

1 Like

@bptworld - OK, I know that we covered this recently, but I'm still having an issue with my lights only flashing twice, even with the "number of flashes" field left blank (indefinite).

Also, this time I'm using the 'controlled by other apps' with this instance since I can now use TF in EE, thanks for fixing that!

I double checked to make sure I didn't do this!

But it seems that this option (above) isn't available when "Controlled by other apps" is selected.

TF Logs

EE Logs

TF Settings

EE Settings

Looks like you left the 'Number of Times' to flash blank.

New version...
1.2.9 - 08/15/22 - Cosmetic changes

GOSH! I was trying too hard to NOT post another issue and figure it out myself. Must’ve convinced myself that it said to leave blank, not “0.” Such a minor element I completely overlooked.

Perhaps that’s what has been the case in most apps I’ve successfully integrated into my setup (eg. “Leave blank for default”)

Out of curiosity, why would it still flash twice instead of not flash at all?

Is it possible, for future HE noobs-who-are-1-year-in-and-make-jacka$$-mistakes-because-they’re-too-excited-that-they’re-starting-to-get-it like me, to have the app log an error if that field is left blank?

Thanks again for your kindness and guidance. I’m really not trying to waste your time. I guess I’m so good at it, I don’t have to try! :laughing:

I dont see it in HPM at all. Neither do I see it in the "control" section.
Is there anything I missing to check off ?

This app is no longer in HPM. It's in Bundle Manager now.

how did you eventually find it ? Im still not able to see this in HPM


Not sure if asked before 'cause I couldn't find it in the search. Is there a way to set this up to use groups of lights? Using this for my water-leak sensor.

I used RL to create a group for when the leak sensor is activated to flash blue, my concern is do I leave each lights device type as RGB with blue color and level preset in the table? Or do I just make them on/off switches and let Flasher handles the color and level?

No, It will only flash one light

Technically I think you could flash a group of lights if you chose a group activator as your switch in this app, but trying to flashing a group of lights would be a bunch of rapid on/off messaging to the different switches/bulbs in the group and more than likely not be very attractive even if it sort-of worked. Something I've never tried.

Just tested using a group from Groups and Scenes of just two bulbs (zigbee, Sengled and Hue, Zigbee messsaging enabled the G&S app) as a group in the Flasher app (put the group activator in as the switch). Not changing any bulb settings, just on/off every 2s and second test every 1 second.

Worked quite well, actually. I was impressed.

I ended up just repeating toggle on a RL group of lights every 3 seconds in the RM rule with a stop on event trigger. Worked as well as I could have hoped for. Thanks for your response.


If I setup a simple Rm rule like this my lights go back to original Color. using CTMode

When using The Flasher App it can't restore color mode. Is it possible to rework how this app captures and restores color?

A nice bonus would be adding a color picker to the app like in RM? Colors are very limited and sometimes off color if not just using a simple rgb bulb.

1 Like

I'd love to be able to alternator colors that are flashed. Is it possible to alternate 2 (or more) colors?

Thank you!