[RELEASE] Tasmota for HE - Auto-detecting Tasmota drivers + Tasmota firmware 7.x/8.x for HE (for use with Tuya, Sonoff and other ESP devices)

Yeh I didn't realise it checks for ip address changes. I fixed all my ip to ensure they don't change. Ip address defined in the device page off memory.

Edit: OK it seems it does check for changes. However I have always set their ip fixed before discovery. There is also a fall back ip in their device page you can set.

Any chances of the extra buttons on the topgreener 8 button scene controller being used with the tasmota driver?

I’ve been running with the excellent Tasmota drivers from @markus, for the last few months and all was well until I upgraded from 2.2.8.156 to 2.2.9.134. Since then, the control over my tasmota bulbs using Colour Temperature has stopped working, and I get errors in the log such as the following:

dev:6442021-10-20 05:48:29.266 pm errorgroovy.lang.MissingMethodException: No signature of method: user_driver_tasmota_Tasmota___Universal_Parent_673.componentSetColorTemperature() is applicable for argument types: (com.hubitat.app.DeviceWrapper, java.math.BigDecimal, null, null) values: [Far Lamp, 4000, null, null]
Possible solutions: componentSetColorTemperature(com.hubitat.app.DeviceWrapper, java.math.BigDecimal) on line 115 (method componentSetColorTemperature)

I’ve tried to work out what might be causing the problem, but I have to confess I don’t really understand the code or error. Has anyone else had this issue? The Colour, Hue, Saturation and Level device commands seem to work, but not the Colour Temperature.
Any help gratefully received.

Ron

1 Like

This was my post a few days ago for same issue.

Thank you @Flakie. I had a look at your earlier post and the reply you got re the changes in the built-in command. I'm going to check this out and experiment, and reply back on your earlier thread in the next couple of days. Cheers!

1 Like

If anybody needs it, I added HttpHook support to the Tasmota 10.0 firmware. For this release I also made Tasmota32 versions for devices with ESP32 chips. The ESP32's Bluetooth and Berry scripting seem like pretty exciting features for the future. Be aware: If you are on an old version of Marcus's Tasmota firmware, you might lose your settings after updating.

If you use this release, auto detection in Marcus' driver wont work anymore. You'll have to manually add your device using the ip address. The reason for this is I removed Marcus' ESP8266SSDP code. The SSDP library hasn't been included by default in tasmota for awhile. And I would have had to do separate libraries for the ESP32 chips. It was a pain.

Also for people having trouble with Marcus' driver, or just want something simpler. You might be interested in my own small Hubitat Tasmota drivers that work using HttpHook. You can find them here: There are things like Generic Switch, Bulbs, Power Monitoring Outlet, etc.

 

I have a Tasmota Button Controller - generic switch driver that will let you use the multi-press events. Just go to the driver settings and set the number of buttons you have. And chose "Decouple Relays".

 

Here is a Tasmota driver for the Topgreener Scene Controller. It's a little weird, with a secondary controller. So in order for it to work you have to set up a couple of rules. To do that run these four commands in the Tasmota console:

Rule1 on TuyaReceived#Data=55AA00070005650400010075 do var1 1 endon on TuyaReceived#Data=55AA00070005660400010076 do var1 2 endon on TuyaReceived#Data=55AA00070005670400010077 do var1 3 endon on TuyaReceived#Data=55AA00070005680400010078 do var1 4 endon on TuyaReceived#Data=55AA00070005690400010079 do var1 5 endon on TuyaReceived#Data=55AA000700056A040001007A do var1 6 endon on TuyaReceived#Data=55AA000700056B040001007B do var1 7 endon on TuyaReceived#Data=55AA000700056C040001007C do var1 8 endon

Rule2 on TuyaReceived#Data=55AA000700056D040001007D do var1 9 endon on TuyaReceived#Data=55AA000700056E040001007E do var1 10 endon on TuyaReceived#Data=55AA000700056F040001007F do var1 11 endon on TuyaReceived#Data=55AA00070005700400010080 do var1 12 endon on TuyaReceived#Data=55AA00070005710400010081 do var1 13 endon on TuyaReceived#Data=55AA00070005720400010082 do var1 14 endon

rule1 1

rule2 1
3 Likes

Ok that makes sense, but how do I get the rules in tasmota to trigger a action in Hubitat?

Do you have issues upgrading? Everytime I go to upgrade HTTPHook versions the only way I can do it is:

  1. Upgrade to Minimal,
  2. Upgrade to the new version,
    (it now has to be rediscovered via WIFI, and put back on the right SSID
  3. start from scratch (or restore a setting)

I can never just upgrade. It is so frustrating. I don't understand how the next version never fits.

BTW, thanks for your work on this!

You have to use that Topgreener Scene Controller driver that I linked. Markus's driver wont detect the button presses. Technically the Topgreener doesn't even send notifications of the button presses over the network. What the rules do, is set a variable on the device when a button is pressed on the secondary controller. My Topgreener driver detects this and registers it as a button press in Hubitat. And you can use the Button Controllers app or Rule Machine or whatever, to do actions in Hubitat.

Well... this is by design in Marcus's original firmware. He designed it so that the settings reset if you go to from standard Tasmota to his firmware. And vice-versa also happens. He used a different CFG_HOLDER value. (memory location for settings). There was really no reason to do this.

Basically it means you can't install any other version of Tasmota on top of Marcus's without losing your settings.

So what to do? I could keep Marcus settings location. But the last version he released was what? 8.3? And because of the upgrade path that means I would have to compile special tasmota versions for 8.5.1->9.1-> 10.0 and even more going forward. So I decided to just rip the band-aid off and go back to the standard Tasmota memory location for settings. So everything will be fine going forward and you can play around with beta releases of Tasmota and stuff with worrying about losing settings.

Thanks for that - I'm biting the bullet now and starting upgrading all of mine to your 10.0 build. Got 97 total tasmota devices, so you see my pain. This will be great moving forward.

So from 10.0 onward I should expect to not have upgrade issues? I'm trying to upgrade from your 9.4 to 10.0, using the gz file, and I get the "Upgrade Buffer Miscompare" failure message.

The majority of my upgrades I'm doing are the 8.5.1 HE version.

Thanks install the driver and it works fine from hubitat to send on and off commands, but it does not receive button press events from my sonoff. Any suggestion? I already set the option so73 - Decouple Relays / Enable Buttons to true

Ah! I see from your screenshot you are on Tasmota version 8.5.1. That explains things. You need to be on a higher version of Tasmota for it to work. My apologies! It's been awhile since I ran such an old version. If you install the Tasmota 10.0 HttpHook firmware from my previous post it should work for you. Please understand that it will reset your device settings when you update the firmware.

Old Tasmota used to not report which button number you pressed. Not good for if you have multiple buttons. It would come out as:
{"ACTION":"SINGLE"}

Starting with around Tasmota 9.3 it started reporting as:
{"Button1":{"Action":"SINGLE"}}

Much better! That's what my driver looks for.

1 Like

That's right it would be the same as if you are upgrading between standard Tasmota versions. You can even install and use a regular Tasmota firmware, it just wont have HttpHook.

"Upgrade Buffer Miscompare" just means not enough space. They actually changed the message to say that starting with v10.0. It's just with some devices you have to use minimal to update. For example: I have an IR Receiver that only has 392kB of free space. Even the .gz Tasmota is 433Kb so I have to install minimal to free space first.

Wow 97 devices! You really don't have to update, if you aren't using any of the new features. :smiley: Up to you though of course. I updated all my switches because I like using the buttons to do stuff in Hubitat.

Yea color bulbs (42) make it sound like a lot. I'll continue to upgrade in order to get them all in the good place.
I'm getting in a good pattern to upgrade, I'm doing them by device type. Finished the Treatlife Dimmers (14 of them) and Treatlife on/off switches (18 of them) Of to the Lohas and Feit bulbs!

Thanks, update the firmware and now it's perfect.

I just learned about so13 1 on tasmota that makes switches instantly turn on. With option 13 off, there is a pause looking for a double click. It makes the switches turn on wicked fast! As Travis says at DigiblurDIY! I saw it in one of Travis's latest videos. Great Discord channel! I've seen you there!

Hi there:

Can you please let me know how to do this? I am not sure what "so13 1 on tasmota" means

Thanks

By the way: AWESOME work!

If I understood right you broke the drivers into small ones instead of having a big APP/Parent/Child for all toghether right?

If so, there are 2 that I am missing, one is for IR-blasters and another fo RF-Bridges. Markus has not done any for the IR but there is one for RF but it is old and I think it doesnt work very well with the new firmware. Do you have plans to have some of it? The good part on those two drivers and httphook is that if you use the remote control of the devices you can track if the device was turned ON via remote or via automation.

so13 is short for 'set option 13' 1 is for on, 0 is for off.

From the console of the Tasmota device from the web gui, type so13 (Enter) and it will respond that it is set to 0 (Off). Typing so13 1 will turn that feature on.

I always thought the delay in response was the smart device having a cpu type of delay, it turns out it was on purpose for the option to do double clicking. It is much faster toggling with so13 set to 1.

Hope that helps!

Download the Hubitat app