[RELEASE] Sonoff (Connect)


#62

Even ST doesn't like this. It discovers them no problem but they can't be added. I am thinking that there is something wrong with the firmware. Is there a way to go back to the older firmware. I updated the firmware to 2.1.1 just before I started all this. Also, do I need to install the virtual switch part?


#63

Any more ideas on how to get this to work?


#64

Wait...you're trying to install the SmartLife RGBW controller, right? Are you using the Sonoff Connect app or the SmartLife connect App? Because I would think you'd want to use the SmartLife connect app in @ericm github repo.

You should also be using the SmartLife firmware...not the sonoff firmware. The firmware you linked to above is for a Sonoff, not for a SmartLife.


#65

Yes, I used the Smartlife RBG firmware. It is 2.1.1 and I have installed the SmartLife RGB Connect app. I didn't install the Smartlife Virtual switch. I don't know if I need it.


#66

Yes, it most certainly is. If you don't then it can't create the devices after it discovers them. That would explain it most definitely.
You did install the SmartLife Controller driver, right?


#67

Yes, I did install the controller driver. I will install the virtual switch and get back to you.


#68

So, when I go your Hubitat github I only see the device monitor.src and Smartlife connect and Sonoff Connect. Is it the device manager that I need to install?


#69

First of all, it's not my github, it's Eric's. Second of all, that is the section with the apps. You have to go to the drivers sections for the device drivers:
The two drivers I think you need are here:

and here:

And the App you need is here:

I'm pretty sure that those are the three things you need for the SmartLife but @ericm can correct me if I'm wrong.


#70

OK, I have all of those in. Do I need the device monitor.src?


#71

No, that's a different app. Are you able to add the device now? Did you reset your discovered devices list?


#72

How do I reset the Devices List? I just installed the Virtual Switch. The others I had installed already. It seems that I can turn the lights on and off in the Device but I will have to wait until dark to see if it is working properly or not. Thanks so much for your help! I will let you know.


#73

So you've been able to add the device now? I thought you weren't able to do that before? Wasn't that your problem all along?


#74

No, I did get them discovered but when I tried to do anything with them in hubitat, nothing worked. When I clicked the buttons to turn them on they wouldn't. So hubitat was unresponsive. But it seems that I can get them to turn on and off in hubitat now.


#75

So I can get the lights to turn on but even though they say they are at 100% they aren't. They are very low lighting. Any ideas how to fix this? I am starting to think that I should have left the firmware to what it was. Maybe I should go back to that firmware?


#76

This is still showing in the Logs for these lights. Any ideas why the error?

dev:312018-10-28 09:32:20.213:errorjava.lang.ArrayIndexOutOfBoundsException: null (parse)

dev:312018-10-28 09:32:11.302:errorjava.lang.ArrayIndexOutOfBoundsException: null (parse)

dev:292018-10-28 09:32:09.161:errorjava.lang.ArrayIndexOutOfBoundsException: null (parse)

dev:322018-10-28 09:31:34.730:errorjava.lang.ArrayIndexOutOfBoundsException: null (parse)

dev:302018-10-28 09:31:27.832:errorjava.lang.ArrayIndexOutOfBoundsException: null (parse)


#77

It sounds like you didn't install the right driver in Hubitat. Maybe you should delete it and start over. Make sure you're not installing the ST DTH. Either that of you didn't actually install the correct firmware. It sounds like you might have installed the Sonoff firmware.


#78

OK, I deleted everything and re-installed. It found the devices fine. But I notice that there is still an error in the logs for all these devices. This is the error:

:errorjava.lang.ArrayIndexOutOfBoundsException: null (parse)


#79

This is what shows in the logs.


#80

So, two out of the 4 lights came on with the Simple Lighting app. Two didn't and then they were really low light. So I went in to each device light in hubitat and I clicked on Configure and then clicked on WhiteLight ON and then the light came on full brightness. So something is wrong. It has to do with the error I think. Anybody have any ideas?


#81

Are they working now when you turn white light on and off? You say they worked but you think something is still wrong?