[RELEASE] Sonoff (Connect)


#42

I have the H801 and it hasn't found any of them. I am wondering if I need to add the smartlife-rgbw-light-connect.src,


#43

Did you have to do anything in the OAuth?


#44

So if I install the smartlife-rgbw-light-connect.src and I run this it will discover my 4 devices but when I hit Next it says Add devices but there isn't any listed and when I click Done and check the devices tab they aren't there.


#45

No OAuth enabled for me.


#46

Manually add the device by IP address.

[Edit: remember to assign static DHCP addresses to the devices if you haven't already done so]


#47

How would I add them manually? I did assign static IP addresses.


#48

Got it! Thanks that worked!


#49

giphy


#50

That's exactly what I did!:wink:


#51

Just for clarification, you have to click the drop down and select the devices that you want to add.

Also, as you seem to have found out, there is a separate App for the RGBW stuff.


#52

Yes, I did select the devices in the drop down but when I clicked next there was nothing there to add. I then tried the Sonoff connect again and manually added the devices but they aren't working. So I am going to put the RGWB one back in and manually add if they don't get discovered.


#53

I won't add manually either. Any ideas what is wrong?


#54

@ericm I installed the smartlifeRGBW controller and then the smartlifeRGBW connect and it did find the four devices and added them. So that is all good. But I can't seem to make them turn on? I only use the white not the colour on these H801s but when I pull up the device in hubitat and try to click on "ON" or "White1 On" or "White2 On" nothing happens.

Also this is showing in the logs for these devices:

dev:292018-10-25 21:18:05.576:errorjava.lang.ArrayIndexOutOfBoundsException: null (parse)

dev:292018-10-25 21:17:56.151:errorjava.lang.ArrayIndexOutOfBoundsException: null (parse)

dev:302018-10-25 21:17:37.527:errorjava.lang.ArrayIndexOutOfBoundsException: null (parse)

dev:322018-10-25 21:17:33.350:errorjava.lang.ArrayIndexOutOfBoundsException: null (parse)


#55

Can anybody help with this?


#56

Can you control them from the web interface of the device?


#57

I will check this when I get home and let you know. Thanks!


#58

Yes I can turn them off and on from a web browser. I click on the W1 and it will ask me for my username and password and then turn them on. Then I can turn them off when I click Off. But nothing works in hubitat.


#59

Sounds like you have authentication setup for control on the device?

Have you set the password up for the device in Hubitat?


#60

I tried that also but still nothing.


#61

Also, when I do turn the lights on using the web browser the lights are very dim. I only use the White lights and they don't dim.