[RELEASE] Sinope GT125 Hubitat Integration

Hi everyone, this is my first driver so bear with me. This should work with these Sinope thermostats:

  • Sinopé TH1120RF-3000 Line voltage thermostat
  • Sinopé TH1120RF-4000 Line voltage thermostat
  • Sinopé TH1121RF-3000 Thermostat for public areas
  • Sinopé TH1121RF-4000 Thermostat for public areas
  • Sinopé TH1300RF Floor heating thermostat
  • Sinopé TH1400RF Low voltage thermostat
  • Sinopé TH1500RF Double-pole thermostat
  • *Ouellet OTH2750-GT Line voltage thermostat
  • *Ouellet OTH3600-GA-GT Floor heating thermostat

And it is also available in the "Hubitat Package Manager"

Credit should go to @claudegel to make this integration possible for HA. I just ported it to hubitat.

1 Like

@rfg81 Thank You! Thank You! Thank You!

I've been waiting a long time for this. Testing it now, I'll let you know how things go.


You're welcome. Let me know how it goes for you :slightly_smiling_face:

What!! Just when I changed out all my wifi thermostats to Zigbee and you did this? :sob::grin:
My impatient failed me again.
Awesome job and thank you. My brother in law will love this for sure.

I initially had the same reaction but to change seven thermostats would cost me a lot. :stuck_out_tongue:
Just to be clear those are not the wifi thersmotats but Sinope's own protocol version using a GT125 hub.

Ahh , didn't know they also released a wifi version THxxxxWF. I stand corrected since I used to have the THxxxxRF.
Yeah, I changed out 5 of them to Zigbee because they had this great BC hydro rebate $40 per thermostat and an extra 10% off. Still costed me a bag full though.

I have four Sinope thermostats (TH1120RF-3000) and a Web interface (GT125) for sale in great condition if anyone is interested.

I am working to get this installed but so far I always seem to get an APIKey of all zeros. I assume this is not expected? Any idea what I might be missing?

I don't see any additional log messages after I press the "Web" button:

Yeah you are supposed to have something different from 00000000. Did you try to refresh the page to see if it gets updated? If that doesn't work I will try to add more logs. Just in case could you double check you Hub ID. I saw mine has 16 characters and yours has 17. But I don't know if this is normal.

Yes I refreshed and went through the steps a few times. I can dig around in the code some as well...just wanted to make sure I was on the right track.

Amy idea if the setting on the Neviweb site for the GT125 matters? I tried with it in both positions....


Mine is on Neviweb. I will try to think if I can find something after work for your problem.

I figured it out - I had a typo in the Hub ID and once I rechecked and fixed that it all worked! Installed now so I'll try things out.

One idea - would you consider adding this to Hubitat Package Manager? That makes it so easy to manage updates, etc!

1 Like

I am getting data now...some thing are notmatching up with the temperature, thermostatSetpoint (275!). I will do some more investigation on these. I have a single TH1400RF so its a bit different than the typical full function thermostat.

Hi brad2,

I'm glad it worked out for you. I thought the problem was the 16 vs 17 characters. I was about to do some change in the code to support that. But if it is working for you I'll not change it. We use Celsius over here, are you using Fahrenheit? Yeah, I'm thinking about integrating it in HPM. It would do matter easier. I need to look into it soon. A

Just to let you know, the driver is going to take 10 minutes (the default time in the settings) to update the temperature inside the dashboard when you change the temperature directly in the thermostat. You can set it to 5 minutes if you want. I was having problems at the beginning with 5 minutes and 7 thermostats. It was causing all sort of errors. I believe it will not be a problem for you if you set it to 5 minutes with just one thermostat.

And it's now available in the "Hubitat Package Manager" for easy install.

1 Like

There is something still wrong in the data values:

On this display, the maximum and minimums match what I have set as well as the "temperature" of 64.0. But the others are off, perhaps because of the type of thermostat I have. Here you can see the 64 that matches as well as a setpoint of 57 which does not show anywhere in the current State.


Hi brad2, sorry it took a while but I finally had some time to add a proper Fahrenheit support to the driver. Please update using Hubitat Package Manager.

1 Like

rfg81, excellent work on getting these thermostats working on Hubitat. Saved me a lot of $.

Just wondering if there's any appetite in the getting LIGHT SWITCHES integrated as well?

Thanks! Sorry but I don't have the light switches, what make it really hard to test it.

Thanks rfg81. I own 5 mi-wi thermostats with the gt-125 gateway and 5 Sinope zigbee thermostat. I am very happy to be able to integrate the 5 mi-wi thermostats to my home automation. Is polling the gt-125 hub necessary once you have added all your thermostats? I understand you want to poll your thermostat to be informed if the set point has been change using the thermostat. But why would you poll the hub?