[RELEASE] Schlage WiFi Lock Support


This is great! Thanks so much for creating the app. I am using a Schlage Sense lock with the WiFi module. I added the app and I can see my lock status. I can not issue a lock or unlock command from the device settings page.

I'm not sure how I want the dashboard to control the lock if it worked. I'm hesitant to allow a unlock without authentication.

I may need logs to see what may be happening there. I think there are two big ways the lock/unlock works. I coded both, but my lock only uses one of them. And the way you pick which method to use may depend on the model, but logs will help figure this out.

As to your second question, that is entirely up to you whether you add this device to your hubitat or not.

1 Like

I'll capture more log but this may help. This came up in the log when I hit the unlock button.

app:16322023-08-29 09:26:25.576 PMerrorgroovyx.net.http.HttpResponseException: status code: 502, reason phrase: Bad Gateway on line 379 (method componentUnlock)

My comment about allowing the unlock was directed at the idea of using the driver to indicate lock status, but not allowing a user to lock/unlock.

I will need the modelName: that you will find in the logs.


Is this using local control or cloud?

Cloud - I am not aware of any local API - if you know of any source of their local APIs, please point me to it.

1 Like

I added a preference to manually control the kind of lock method used. Please change it from auto to put and post and see if one of those works.

If you're feeling froggy, you might consider one for the be469's that allow alarm information :slight_smile:

1 Like

I tried Auto, Put and Post. All 3 options fail to unlock. I have captured the logs from the device. I hesitate to post the text from the log here. How do you want me to send the log snip? I can create a issue on github.

Thanks for adding the Allow Unlock switch. That was exactly what I wanted.

I would rather not change out the lock just yet. I am happy just getting lock status into Hubitat.

There is little identifiying stuff in your log. If you're worried about your codes, simply black those out.

It looks like there is a bridge involved that has a different deviceId.. I cannot debug that as I don't know what will work, but I added support for a bridge with one potential way of making it work - can you try this one and see if works?

I'm hoping that this app will save the day! I just received my Schlage Encode Plus lock yesterday, and have spent every waking hour since trying to figure a way to get it into Hubitat (or Smarththings or Home Assistant) so that I can include it on Sharptools dashboards.

I have the App installed, and it provided me with a lock device, which I've added to Sharptools. The problem is I can't get the device to do anything. It shows the lock is unlocked, and nothing I do either with the app or the device will change it. The lock works with the Schlage app, Apple Home app, and Alexa - but not with this app.

I sure want to get this to work but I don't know what to try. I'm not very competent in this subject so can easily get overwhelmed. I hope you can point me in the right direction!

Please DM me your logs and I can take a look at what might be happening.. Please x out your passwords etc.

Download the Hubitat app