[RELEASE] Rachio Community (dashboard + hose timers)

Let me watch this for a while and I'll get back to you. Also, if I understand correctly schedules are only set up in the official Rachio app, right?

right

Finally, I notice that much of the time when I try to access the links I get a message that the browser didn't respond. I have clicked on the link from within Rachio Community and I also copied it and tried in another browser window. Same result. Do you know if this is an issue with Hubitat or with Rachio?

There's no way for me to know without more information. Things like: are there any errors in the logs, what type of device (hose timer or controller), what error message shows in the browser, etc.

Howdy - I have a simple 7 zones set up on my controller and a hose timer, but my logs are piled up with this:
Approaching daily API Limit of 1700. Averaging 48485.828282828281819745555588846486800474747902121 API calls per day.
Seems like a lot. I had it set at 15 minutes refresh but just changed it to 30, but even half of 48000 is way over 1700. Any idea what I should be troubleshooting to see what's up?

I’m seeing this too. I will look into it.

1 Like

I noticed in my logs today the following:


I am not sure where to go to find the problem.

I have Rachio Community installed and it works fine, but there is one issue on my iphone. On a PC if I touch a dashboard link to turn on a valve I get a "Are you sure" banner at the top confirming my choice. However, on my iPhone I don't see the banner and I cannot turn valves on or off from the iPhone.

I notice in my iPhone if I lock or unlock a door I get that banner, so it seems whatever is different has to do with how the web page works on the iPhone.

Has anyone else noticed this? I cannot find a setting in the iPhone that would govern the display of that prompt, and I don't know if it has something to do with the Rachio Community app, my iPhone, or the dashboard app in Hubitat.

I just tested it because I haven’t used it since last year and the app has been updated, so I wanted to make sure.

I am using Safari on a iPhone 15pro and I DO get the pop up “are you sure”. I’m glad I tested because I don’t remember seeing it before. Honestly I only used the dashboard originally for my RM debug and for priming and blowing out the system.

I have my five zones linked to virtual dimmers so my wife can just set a zone to say 20 via Alexa and off it goes. The best part I like is I can say set front yard to 20 and my RM cycles all the front yard zones for 20.

What browser are you using? I can test chrome or whatever you are using.

I generally use Chrome, but I also tried Safari. It's got to be a phone thing. My phone is an iPhone 11 but the OS is up to date.

1 Like

I believe I found the problem. If I turn off the icons using the Simple CSS editor I am unable to operate the buttons on an iphone. It's no issue on a PC. I had removed the icons on my dashboard because the dashboard was clear enough what the function is. When I turned the icons back on the problem went away and I get the "Are You Sure" prompt.

1 Like

I have never used the Simple CCS editor but I do have the thread booked marked for future reading.

I have done some manual CCS tweaking on a couple of my dashboards and understand it can cause a world of trouble :wink:

But it may be a moot point. I am not part of the beta but a new and improved dashboard app is coming with the next Hubitat update.

Anyway. I am glad you found the root cause.

I've reworked the polling a good bit to reduce API calls. And separated out the API call count for irrigation and hose timers, since apparently they are governed by different limits. Also separated polling periods for irrigaiton and hose timers, to account for irrigation having webhooks but hose timers not. Will test for a few days and then update if all is good.

2 Likes

I am seeing this problem now, as well, and I haven't seen it before:


Also, I noticed in my Rachio Community setup there is no hub listed for the hose timers.
image
If I click on Tap to Select nothing appears.

@JustinL , after waiting a couple hours I was finally able to select the Wifi hub again. Links turned up to each of my 3 Hose timers:
image
but devices for them don't exist in the devices list for the hub. I see this in the logs:


If I click on the dashboard links for each of them I get this:


{"error":true,"type":"java.lang.Exception","message":"An unexpected error occurred."}

I can add a smart hose timer device, but I have no idea how to make it point to a specific hose timer (I have 3). I wonder if I should just remove the whole thing and start over.

If you're in need of an immediate fix, you can install a beta version that I am working on now. It should fix these errors. I believe this version will meaningfully reduce API calls. I am still trying to optimize app load, and ensure the API stats are being tallied correctly.

2 Likes

I may try your beta version. Thanks for sharing it. Right now a bigger question for me what I do about the missing Hose Timer devices with their associated wifi hub. How do I add them back in? In my logs I see this:

EDIT:

While trying to get the wifi hub and timers installed I checked the logs and noticed this error:

I had tried to set the poll interval to 60 minutes to see if that would help. However, it appears the CRON string stopped something essential from completing. When I changed it to 30 minutes it completed and I got my devices back.