[RELEASE] Other Hub SmartThings Integration 2.0

community_driver
community_app

#61

Did you select “Switch” as one of the capabilities to use for Real-time integration?


#62

Yes


#63

I had a similar issue when I migrated from the first version of the integration; somehow (due to my error) on the ST side the virtual device was using the wrong version DTH for the OH-virtual switch. You should be able to verify what handler it is using by looking at the device in the IDE. It should show a February date in the code.


#64

2.01 code, dated February. I never had installed the earlier version anyway. Just got the hub 2 days ago.


#65

I got Hubitat recently and just added 1 device to start with. I used this solution and it worked without an issue between ST and Hubitat. However, Google home and Alexia didn’t pick them up initially. I opened the Google Home app and it seemed to update on it’s own. I assigned the device to a room, done. I opened the Alexia app and removed the old device listing then had it find new devices. Found it without a problem.
Thanks for the solution.


#66

I opened the OH Device Viewer dashboard. If I click on the virtual device there, it tries to toggle the switch, but fails here also.


#67

In the Hubitat Event Pusher App, Click the button for “Send Hubitat URL to SmartThings”.


#68

Did that, didn’t help. Other devices work fine - lights, motion sensors, switches, etc.


#69

Kevin,
Could you add DTH for a Garage door opener?
Thanks.


#70

I’m not sure if this is causing my issue, but after installing OH in SmartThings, whenever I do add device, the log just keeps showing

trace addDevice evaluation: d: Hue 0AE670, selectedDevice: uuid:7f7f7e3d-0613-4a3c-85bb-909819245705::urn:Belkin:device:={ssdpUSN=uuid:7f7f7e3d-0613-4a3c-85bb-909819245705::urn:Belkin:device:, installed=false, networkAddress=C0A80020, ipFixed=false, ssdpNTS=null, mac=C44EAC17B473, deviceAddress=1F90, hub=adde5287-d5e4-4f81-b79f-bc5f77d6ff66, ssdpPath=/api/discovery.xml, ssdpTerm=urn:schemas-upnp-org:device:basic:1, stringCount=04, username=hubitatuser, verified=true, name=Hue 0AE670, devicetype=04}, dni: C44EAC17B473

I have not been able to pair new devices, specifically, a few Xiaomi devices. Any ideas on why I’m not able get them paired? They pair fine to Hubitat, but will not pair to SmartThings hub anymore.

Also, even after removing the viewer, the Hue Hub device, and anything else not ST related, every time I do device discovery in ST, it always finds, authenticates, and adds the Hue Hub again.


#71

Have you been able to reproduce the problem with Virtual Switch in Hubitat not being able to be controlled in ST?


#72

I just tried and I can’t reproduce the problem.

If you’re able to control other Hubitat devices from ST and this is the only one giving you problems then I recommend deleting it from both systems and re-creating it in Hubitat and adding it to the Event Pusher App again.


#73

@krlaframboise What about adding support for 5 button - button devices with push and hold functionality. I could use this to integrate my Pico remotes to ST without the need of the node app running on my raspberrypi.

Also a proper Temp/Humidity virtual DTH right now my temp sensors just show up as motion and I had to change them to the Other Hub Device DTH.


#74

That’s on my to do list, but there are a lot of other things in front of it.

As a temporary solution you could create Virtual Switches in Hubitat and use Rule Machine to temporarily toggle them when the button is pushed. It’s a little messy, but it should work.

Almost all capabilities have been implemented so you shouldn’t have to use that 'Other Hub Device" DTH.

The primary tile of the Other Hub Motion Sensor DTH is motion, but there are also tiles for Motion, Temperature, Humidity, and Illuminance.


#75

I think I figured this out. If the virtual switch is named with one word, it works. Two words, it doesn’t


#76

That shouldn’t be. All of my virtual switches are named with two words, and they all work.


#77

I’m having similar issues, but with both physical and virtual switches. In ST, a command to turn on/off shows “turning …” for a short while, gives up and reverts to the original state. Nothing in ST logs. I created a one-word test virtual switch in Hubitat, pushed it to ST (shows in ST as an “Other Hub Switch” device type) and get the same result. Similar results from the OH web viewer - it gives the green banner that the switch has been turned on but it never actually does. Hubitat logs do not show any event that was initiated by either ST our the OH web viewer. OTOH, anything I do from Hubitat is correctly reflected in ST.

EDIT: to add that I have several virtual switches that worked well until Friday sometime during the day; now all failing.


#78

Does this have GitHub integration?


#79

No. Devices and apps code must be entered manually at present.


#80

By the way, SmartThings will be ending GitHub integration with the transition to the new developer platform this year.