[RELEASE] Other Hub SmartThings Integration 2.0

community_driver
community_app

#41

This is exactly how I control my office Hue lights. No need to create a separate virtual decice…and it’s very responsive.


#42

Same sensor, except mine is a Sylvania Lightify. Just a different skin. Still the same Centralite. Same setup, except I wanted another rule to interact with the light and I don’t use webCoRE, and didn’t want to use Stringify to act on a SmartThings device. I want to get comfortable with RM.


#43

It’s odd. Motion events are pushed to SmartThings very quickly and as @stephack confirmed, works well to turn on Hue lights. However, changes to Hue lights refresh very slowly, so using a ST Smart Lighting rule in the reverse direction to inform Hubitat for a rule, works very slowly. Not a Hubitat problem, the update in SmartThings is very slow.


#44

Somehow Stringify is so much faster at updates in SmartThings. If I try to use RM, monitoring Hue lights in SmartThings, because SmartThings updates Hue events so slowly, it will take 18 seconds for RM based on a ST update of a Hue bulb, but Stringify can do it in 4 seconds!


#45

I’m migrating from beta 0.1 version. What should I do on the ST side with the old Hubitat device that I previously updated from Hue bridge type to Other Hub Bridge type? Should I change it back to the bogus Hue type, leave it as-is, change to some other type, or remove it? I sort of like seeing it in my ST list of devices so I hope it doesn’t harm anything to just leave it.

EDIT: I left it as is and installed everything. Devices show up in ST and log prints out update status okay, but any attempt to control the device throws a java exception. What am I missing? I tried the two buttons in the instructions but it didn’t help.

When I push the sendURL button on Hubitat the log shows this error:


#46

These are the instructions for removing the old version and installing the new one.

Make sure you updated the App in Hubitat, SmartApp in SmartThings and all the SmartThings DTHs. Everything is located in that new OtherHub2 Repository.

If that doesn’t fix those errors let me know.


#47

Thanks … that didn’t help but I figured it out. Turns out I was using a super old firmware version 1.0 (I have Hub #3) that doesn’t suppprt the api call used in your code. So the fix was to update the firmware, reset the OAUTH on the Hubitat side, and then refresh the endpoint push from Hubitat you ST. You might add the firmware update to your install instructions.

Thanks for writing this. It works great. I also appreciate the example code for accessing Hubitat from cloud that I can use in my HousePanel development.


#48

This is great! I finally got some virtual devices from Hubitat created in ST via this app/DTH set and it’s working great, allowing me to keep my logic in its existing ST SmartApps/Routines/webCoRE pistons until I figure out how to re-implement the same in Hubitat, and it also allows me to continue using ST to compensate for missing features (e.g., voice control beyond switches).

Would it be possible to add an “Other Hub Thermostat” as a possibility? Hubitat’s Alexa integration doesn’t work with thermostats at all now, but SmartThings’ implementation of this is mature, so it would be great to move the device itself to Hubitat while still allowing ST to manipulate it. (If not, I’m trying to figure out how to use MQTT to do the same, but my issue is that any “virtual thermostat” DTH I can find doesn’t seem to respond to commands to change its setpoint except via the device tiles.)


#49

None of the virtual devices work for me in AVS unless they’re in a group. I don’t imagine Alexa Groups support thermostats, so you’re going to need a device specific driver.


#50

Do you mean even physical thermostats? I have my Zen Thermostat paired to ST and integrated in Alexa, and it works-as is, but I also have a “Thermostat” group with just this device in it so the name is easier for me to say. I’m pretty sure both work. I don’t think it’s all virtual devices either, as I have virtual switches that Alexa works fine with as well (but not virtual “momentary” switches, as I’m guessing the capabilities they implement do not include ones the ST integration looks for). In any case, Hubitat doesn’t support anything besides switches right now, so long term, that’s what I’d really like to see be improved. I was just hoping I could use OHB to bridge the gap in the meantime without needing to keep my ST ZigBee network up.

EDIT: Didn’t realize you meant virtual switches from Hubitat rather than ST. I haven’t tested that, so you could be right.


#51

If I add a virtual switch from ST to Alexa, it works. If I add a virtual switch from Hubitat, it doesn’t work until I put it in a group. I don’t know if everyone is experiencing this, but I’m not the only one.

Not a big deal to me, as we have been told there is a skill coming post launch and a new Alexa Wizard app coming. Those together should address the issues of devices not being discovered by Alexa that some are experiencing, the group requirement that I and others are experiencing, and allow groups for Alexa to be created within the app.


#52

I use Alexa with virtual momentary buttons all the time and they work great. It is how I control my Harmony hub since I set it up before they had a stable native integration and I am a believer in leaving stuff alone that works well.


#53

OK, maybe something has changed since I tried, or maybe I’m just using an weird DTH for mine. I’ll have to try again—though I really hope Hubitat just gets improved Alexa support soon, anyway. :slight_smile:


#54

I installed my hubitat a few hours ago. Only device is a Xiaomi original motion (a/k/a body) sensor using @veeceeoh 's driver. Motion shows in Hubitat. Went through the OH installation and didn’t have any obvious errors. The ST app shows the OH-Xiaomi device and events are ACTIVE or INACTIVE in accordance with the actual device. So far, so good.

My problem is that no ST smartapp sees the OH-Xiaomi as an eligible motion detector. I don’t think I have any useful logs since the device is seemingly functioning. Here is the device:

Did I miss something that declares the device to ST smartapps?


#55

I was about to tell you that only the OH bridge should be using the Other Hub Device dth…and then I noticed that my Zwave motion detector was also using this DTH. My Iris motions all show as Other Hub Motion Sensors. I changed the Zwave dth to OH motion in Smartthings and it seems to work fine. Give it a shot.


#56

Thanks, @stephack! I changed the ST DTH from Other Hub Device to Other Hub Motion Sensor and all is good. Just didn’t occur to me to specifically set the correct child. (Bad enough having to learn Hubitat, but now I have to re-learn ST stuff that I haven’t used in a couple of years.)


#57

I just want to point out that the “Other Hub Bridge” was part of the original integration and that code should be deleted from SmartThings because it no longer works.

If you added the original code through the GitHub integration you should delete those devices and use the code in my Other Hub GitHub Repository.

If you installed all of those DTHs before installing the SmartApp and that device supports the Motion Sensor capability, it should have created it as an Other Hub Motion Sensor.


[Release] Xiaomi / Aqara device drivers
#58

I just finally got a chance to install OH 2.0, and I had the same thing happen to me - my motion sensor got a “Other Hub Device” DTH assigned to it, and my temperature/humidity sensors got the Other Hub Motion Detector" DTH assigned to them. I followed the the install instructions given in post #1, in the order they are listed.

My fault for not reading through the entire thread first, but can I make a suggestion? Perhaps move “Installing the Child Device Type Handlers” section to the top of the instructions if those ST DTHs should be installed first?

Otherwise, this is fabulous, and as I’m using your Dome Alarm DTH and plan to see if your Simple Event Viewer App will work on Hubitat, I’ve sent my support!! Thank you so much for this.


#59

I created a virtual switch in Hubitat. I checked the box to add it to ST in the pusher app and it appears fine, ST shows it at OH Switch.

Problem is if I try to change the switch on the ST side, it sticks on ‘TURNING ON’ (or OFF) and does nothing on the Hubitat side. I can control it on Hubitat and it works fine.


#60

I’ve moved the Driver part to the top of the instructions. Thanks for the suggestion.