Struggling with that right now. All the documentation notifications for only 2-locations. Now, I can load up my free plan with 8 locations, but I did get a message to upgrade when I enabled the location notifications for more than 2-locations in the app. I turn them off in the app, since I want it through HE not life360.

Up to a couple days ago, I was getting push notifications for 8-locations, on the free plan. Now I'm getting zero pushes regardless of how many locations are in the app. Now, in fairness, I did get a pop-up a while ago about "you have been upgraded to gold for free", which I never thought anything about. But everything in the app points to the free version not gold, so maybe that was a temporary deal.

When I check the app settings for my circle, it's showing I have no locations updates left. Not sure if I "broke" the free plan or what. Do others have a number in the locationsUpdatesLeft field?

features={premium=0, skuTier=null, locationUpdatesLeft=0, priceYear=0, ownerId=null, priceMonth=0, skuId=null}, unreadNotifications=0, color=7f26c2, unreadMessages=0, memberCount=4, name=Family, id=<>, type=basic}

I wonder if the webhook needs to be re-registered from time to time in order to continue to work.. I believe the driver only registers it once and never again.

I did a lot of testing a few months back but all of my testing relied on polling. Of course, getting the push events will be more efficient/timely if they're working reliably.

I'll try to spend some more time looking at this -- maybe add a few more locations (I only have 3 or 4 now and am on the free plan)

1 Like

No sure. I did make up another life360 test account, and it reports the same features as above. I'll play with it a bit more to see what is up.

You are talking about push event in Life360 app which is limited for two places on free version.
That's why you can save as many places you want to and use webcore or rule engine to trigger push notifications from HE.

Yes, that appears to be the case. If you have the free version, it appears you can save as many as you want, put you can only toggle the arrive/leave bell in the app for 2.

I was successfully getting HE push updates for 8-locations up to a couple days ago. Not sure what happened, how I get no push updates to HE from the internal Life360 Connector or Life360+. I can drop the webhook URL into a browser and that triggers HE, but nothing is coming from Life360 cloud. Digging into that one!

Question for others, when you log into your life360 Mobile App, what does the "Membership" options look like (bottom right button)? About 2-days I lost my push notifications to HE. Just checked the app updates, and there was a Google Play Store update for Life360 on Sept. 19. When you look at the change log, it no longer lists a "free" plan, only "silver", "gold" and "platinum". The paid "silver" option 100% overlaps with the previous "free" version. Their website still lists "free" and not "silver" though. Wondering if this an end to the "free" era?

Plans from the Google Play changelog:

Plans from the life360 website:

I did notice the webhook wasn't being called yesterday while we were out and about. I tried re-registering the webook again and will check the logs to see if it's called today. If so, I can have the app re-register every once and a while -- but first just want to see it work at all

Thanks, just wondering what is going on. I tried the free upgrade to gold, but not getting any webhooks either.

My silver membership includes 5 place alerts. Stated within the app.


Anybody experiencing new errors as of a couple hours ago?

Yeah, I see some between 4 and 5 but working fine since

humph, I'm still getting errors every minute. Others?

Edit: In case anyone else has similar problems today, here's what I experienced upon seeing errors spamming the log. Went into the Life360+ app. It took me to the logon screen (username and password) that included a message about a login error (sorry don't remember the exact wording). So I re-logged in, done'd out of the app, and the errors went away. If I go back into the Life360+ app, it now takes me to the expected configuration page. Things are behaving normally again.

Hope this helps others.

I noticed one of the more recent issues on the Life360 Tracker thread has to do with errors about sendHistory and sendTheMap not being supported by the device (see Life360 Tracker and later posts). I have been getting similar errors to what @jb1 is experiencing (though I don't know which driver they are using).

I took a peek at the driver code and noticed those methods are not in the Life360+ code anymore. Not sure what the resolution should be, but it seems like it might be misalignment between this driver and the other app that @bptworld made.

Trying to pull everyone together on it. Thanks in advance.


I kind of remember seeing these commands in the driver when I first started working on it. I'll take a look at it


I don't understand why HPM can't go one step further and perform the 'add user app' step. It's ALWAYS excluded from release pages/install notes, and it causes me a ton of annoying time to remember I need to do it. Authors, PLEASE BE EXPLICIT in your "install" section to remind those of us who attempt to set and forget our home automation, not live in this daily. for the love of god! :wink:

PS THANK YOU for the app - I was fine with the in-built 360 for a while but had to make this jump. One (okay second) suggestion? It would be nice to be able to replace an existing presence child device during setup/install - so one doesn't need to play the game of running down/updating all the old child sensor dependencies?

1 Like

FYI - [RELEASE] Life360 Tracker - Works with the Life360+ app! - #504 by jpage4500

I like everyone had Life360 app working like a charm.
Now I’ve installed Life360+
setup the presence devices (2 iPhone)
In dashboard I added them as Presense devices but they come up with the name and just a question mark. Where before it would give Home or Away.
I did verify that those devices are In use by Life360+ (parent app)
I do know life 360 is working as I am using it for other non Hubitat uses.

1 Like

Did you verify their template is set to "Presence" in each dashboard tile configuration? Just a thought.

Yes, just verified, Thanks