[RELEASE] Iris SmartPlug Z-Wave Repeater (3210-L + others)

Thanks for sharing this, have been hoping you would since you mentioned it in another thread. :slightly_smiling_face:

Thanks for sharing! I hit configure on this, but it still shows association group failed. Not sure how to interpret this.

**edit all 7 of my repeaters show the same thing

Don't forget to press save after pressing configure.
It's working for me. Thank you @srwhite for the great driver.

Configure, save, interrogate...same thing. It has an association group name in the state variables though?

This is what I have

1 Like

Good news.. The association group command is taking, otherwise the plug wouldn't be able to send the reports back to the hub. My first guess is to question the version of hub code you are running? Back in December I reported that the Z-Wave stack was not properly parsing that command class.

They fixed that, but I have tested so many interim builds I don't know exactly what version fixed it.


I'm on the latest version. Can't remember offhand but I just updated 2 days ago.

@srwhite, is it true that for your repeater handler to work properly you also need to use your smart plug handler?

1 Like

I'm wondering the same thing. If not, is there an advantage to using that handler instead of the generic one?

Nope... They are two completely independent things. You can use the stock handler for the Zigbee SmartPlug portion if you wish. Within the device, they are two entirely separate radios as well.

My plug driver adds voltage & AC line frequency reporting. It also allows for time and threshold-based consumption (wattage) reporting, whereas the stock driver only exposes threshold based reporting. I also added support for in-device toggle, and device identification, which blinks the LED on the plug for 30 seconds.

Unless you want any of the extra reporting or functions, the stock SmartPlug driver works just fine. And either driver will work with this Z-Wave repeater driver too.

1 Like

Turn on debugging and run another interrogation. I'd like to see the output in the live log. I'm still thinking that the hub is not parsing that particular command class.

@srwhite you nailed the instructions for pairing these devices. If you precisely follow your instructions you can almost always get both zigbee and zwave to pair. Sure wish I'd found them a year ago. Then with your zware driver you can tell exactly what's going on with them.

Now back to seeing just how far and through how many walls they will reliably repeat.

Thanks again for all of your efforts on these plugs.


Hi, Steve. Thanks for this. I have four of these paired as Z-Wave repeaters (for many months). One took your DH and responds great; the other three show offline and, probably obviously, don't respond to any poll or interrogate commands.

I thought that when HE found the Z-Wave device of this plug that I was safe in the expectation that the Z-Wave repeater was working. But, I guess not. Any ideas for a next step?

@srwhite are these 3210-Ls able to daisy chain connect via z-wave? Mine all seem to connect to the hub until moved a distance too far for connecting direct. And then even after a zwave repair they are not able to connect through another smart plug that is halfway between it and the hub.

This driver has now been updated to support the Power Level Node Test command class which was introduced with hub version 2.0.6. The Test Communication command now functions as expected!

Github has been updated. Anyone who has experienced or reported any issues is strongly encouraged to upgrade to this release.


After updating the driver code, do we need to do anything (Configure, etc)?

1 Like

Nope.. Nothing further is required beyond updating the driver code.

1 Like

Cool, thanks :slight_smile:

What does this mean?

Also, FWIW, I'm still seeing the same behavior as before on Interrogation, where the device page says assocGroup failed, but the logs show it as part of Lifeline. I'm not worried about it, but thought I'd mention it in case it means anything to you.

1 Like

That is very weird. I have tried to replicate withotu any luck. How does the test communication function work for you?