[RELEASE] IKEA window roller blinds

I used the buttons on the shade itself to set the lower limit. That seemed to have done it for me. I think if you set it to where you want it and then double-click the down button on the shade that will do it.

I’ve done that with no luck, odd.

Set it to the position I want it. Press down button twice (it moves up and down a tiny bit to confirm).

But then in the app I press close and it goes forever!

Hmmm. That is odd. It worked fine for me.

Must have been user error. I just did it again, seems to have kept this time.

1 Like

I find the shades a little finicky. I have 8 of them and I space the commands a second apart. Sometimes one of them just doesn't respond, so I have additional logic to confirm they did what they were supposed to. But hey the shades were not that expensive so I guess you get what you pay for.

Having owned IKEA blinds for over 2 years, there are idiosyncrasies with certain blinds.
I have two spare batteries charged and ready to swap with discharged batteries. When replacing the battery on a few of my 11 blinds, the shade retracts fully as it is supposed to, but if the upper and lower limits are not set after battery replacement , the next time a command is sent, the blind will unroll completely and wind up in reverse. So, I have made a habit of setting the upper and lower limits when replacing the battery. It just takes another minute, and might not be necessary for every blind but I do it anyway.

The button that comes with the shade only has two actions (full up and full down). The Sonoff SNZB-01 button has three actions. A tap raises them to 50% and a double tap closes them. A push fully opens the blind.

I use a Pico for blind control. Or Alexa. I have tried some automated methods, like closing the blinds when the TV turns on, but I find it's just easier to say "Alexa, close blinds."

Battery level is actually frequently reported but only displayed once it changes.

1 Like

@a4refillpad Thank you for writing this, It's great!

Can anyone help me with the following:
I have a rule set up which closes 2 blinds at sunset +30mins, and opens both on sunrise.
It was working well for a few days, but now, sometimes only 1 blind opens or shuts :frowning:

I can see this in the logs this morning for the blind that didn't open:

windowShade	closed			DEVICE		Kitchen Blind Left		
2023-01-20 09:27:21.276 GMT
command-open			Command called: open	DEVICE	command	Open Blinds		
2023-01-20 08:07:00.733 GMT
windowShade	closing			DEVICE		Kitchen Blind Left		
2023-01-19 16:56:05.761 GMT

The blind in question shut correctly at 16:56, but then didn't actually say it was closed until 9:27 the next day!
When I clicked on my dashboard to open the blind, a few hours later when I noticed it wasn't open, it opened fine.
Anyone know what could cause this?


Did you hit configure after adding them in? Doing that initialises the zigbee reporting settings for that blind. Try also adding it again to the zigbee network and remember to hit configure right afterwards.

Thank you for the quick reply.
Reporting seems fine, as usually when they open or close both report their % opening or closing as they are changing state, and battery level is reported every couple of hours usually.
I will try again, I will have to add both blinds again, as both are being temperamental.

Then it looks more likely you have a problem with losing packets due to either, interference, low signal strength or a malfunctioning relay in your zigbee network. These blinds are quite chatty and the stream of data can overwhelm and reveal some hidden issues. I have 5 of these in the kitchen and do not have your issues.

Is there a simple way to modify the driver to correctly display battery level with graywind/yoolax zigbee roller shades? The value always gets reported as double (e.g. hubitat shows battery 200 when shade is fully charged). Otherwise everything else works perfectly.

Sorry I don't have any experience with driver code...


@a4refillpad Thank you. Yes, it does seem to be signal strength. I moved the hubitat closer and it seems more reliable now.
Do you know if there is any way of using the zigbee repeater that comes with the blinds to overcome this problem?
The hubitat found it and knew it was a "system device", when I paired it, but i guess it's not using it as the repeater is between the blind and the hubitat, and made no difference.

I personally found the included Ikea smart outlet to be a fairly poor repeater when paired directly to hubitat. To be fair, the blinds worked perfectly for about a year with no repeater nearby at all before they began dropping from the Zigbee mesh. I suspect it's due to some nearby 2.4ghz interference.

After a few weeks of fiddling with the Ikea repeater I ended up just picking up a cheap little Securifi Peanut Smart Plug from Amazon for around $15, paired it to hubitat and placed it in an outlet directly below the 3 Ikea blinds in my Master Bedroom - It's been about a month now & since then they have been solid as a rock.

1 Like

The Ikea repeaters make great repeaters in hubitat. I have even purchased a few more to dot around the house.

I just added one of the repeaters to Hubitat using the reset hole, do I need to do anything else to get Hubitat to use it as a repeater?

If you see it on the Device list and driver type is IKEA Tradfri Signal Repeater, I don't think you need to do anything else.

1 Like

Hitting the configure button resolved the issue of the blind randomly not responding to rule triggers. Thanks!

Is there a way to have groups of these respond to the "open" and "close" commands through Alexa or am I stuck with "set shades to 100%?" I didn't have any luck trying switching the group device to Virtual Shade type, but maybe I missed something. Thanks!