[RELEASE] Hubitat Package Manager (HPM) -- HubitatCommunity

Done and fixed. Thank you both for your help.

Hi there!
I updgraded HPM today to 1.8.7. I've removed the older version, removed deprecated apps/drivers.
After matching everything, I've tried installing, repairing, and updating various packages and each time HPM hangs. I've waited up to 20-30 minutes, which never took so long before. So I'm not sure it's actually connecting to anything to be able to install/repair/update. (And I don't have Hubitat Security enabled.)

Any tips for troubleshooting?
Hub version

Logs please.

Didn't look at my log OR this thread before upgrading :scream: :sob: The upgrade from 1.8.2 froze and (not paying attention) I either refreshed the page or clicked on Apps --> HPM then re-ran the HPM update. The second one completed but now HPM shows 2 installed instances. Tried repair on both (no change) and uninstall on either one gets this error:

Error Occurred During Installation
An error occurred while installing the package: Failed to uninstall app https://raw.githubusercontent.com/HubitatCommunity/hubitatpackagemanager/main/apps/Package_Manager.groovy, it may be in use. Please delete all instances of this app before uninstalling the package..

Sooo, before I mess things up further, any ideas for cleaning up my mess? Should I try deleting the HPM app?

Do an Unmatch on the oldest instance and you should be good.

1 Like

Or, follow along with the step-by-step that walks you through the same...

1 Like

Once I figured out how to find the Package Manager Settings button, it worked like a charm. I posted a tweak to the instructions in that thread. Thanks!

1 Like

I'm quite confused on the steps to replace 1.8.3 (Dominic's version?) to 1.8.7 (@csteele 's version).

There is no "update" showing, so is it just a matter of replacing the HPM code in the original install with the code in the link above?

The simplest path is to open HPM, click Repair, find HPM in the list and click Next.

  • Screen Shot 2022-07-25 at 2.57.31 PM
  • Screen Shot 2022-07-25 at 2.57.50 PM
  • Screen Shot 2022-07-25 at 2.58.26 PM

The latest code is downloaded into the Apps Code area. Since HPM is running at that moment, there's a rare chance that swapping the code out can cause a fault with the display of the "success" message. Imagine the code is at Line XX and then the code gets swapped. Instead of running line XX+1, it's running YY. It doesn't damage anything, it just gives a log message and sometimes, appears to hang. (No "Success" message.)

Click on Apps in the Left Menu and start HPM again.. check the running version shown in the upper left corner:
Screen Shot 2022-07-25 at 2.58.48 PM

An Update from 1.8.3 to 1.8.7 often has another cosmetic issue where two instances are shown. v1.8.7 has a new feature called UnMatch that, along with its other uses, also clears the two instances display.

Thanks - it took 2 tries like you said. The first attempt gave the following error and it never got to the "success" part.

Date/Time: 2022-07-25 19:21:41.116
Message: java.lang.NoClassDefFoundError: user_app_dcm_hpm_Hubitat_Package_Manager_58$_copyInstalledItemsToNewManifest_closure87 on line 3573 (method performRepair)

I then followed @thebearmay 's suggestion earlier on in the thread and did the repair again. It finished and the code is v1.8.7

Would this be in the Apps section? I'm not seeing a duplicate either there or in Apps Code section, so :crossed_fingers:

Thanks for your help

Click View Apps and Drivers at the bottom of HPM's menu. You might see:

Screen Shot 2022-06-12 at 7.46.42 AM

And now you have the method to fix it. :smiley:


Thanks - only seeing one listed!

Strange error, and the first time I'm seeing it. HPM is reporting that there are updates available, but they show as "Null" when listed.


any suggestions on how to fix? maybe uninstall the app and reinstall? I'm on Current Version: v1.8.7

Basically, use a more modern Platform release... and then that will probably raise another, answered by:

1 Like

Is there a plan to add in a Package Explorer type feature, or possibly take over the original?

Package explorer has been throwing errors(I assume since his other apps transitioned to Bundle Manager?). Although, maybe I'm just missing something. Is there a better way to search through HPM?

If you select add, it has some built in search features.

My history with HPM is mostly one of practicing the fine art of procrastination. The packages I was involved with at the time didn't fit HPM well. I have to admit even less demand to understand Package Explorer. Even today, I'm not sure what it did... I do know two things, it's mothballed and it was built to solve a problem that doesn't exist any more. @thebearmay points out that HPM gained external search features long ago and I enhanced (fast search) those when I chose to provide support.

I can say that I have no plan for that.


It's back! I've had several requests for this, so I've added it to Bundle Manager. :+1:

I too am a semi high functioning PRO-crastinator, so I fully get it.

I liked it because search was a little faster(at the time?) and I could compare app summaries. I just re-ran a few searches in HPM to see if I was missing something, and my original question seems to have stemmed from the perfect lineup of results with terrible descriptions. It just seemed like there was no info before having to commit to an install.

One thing I do like about the explorer results is that they include the community and github threads. It makes it easy to compare what is available in HPM before opening up the search to the general community.

Nice, good timing (or maybe I should have just waited a couple more days) for my question.

Just transferred it over to Bundle Manager.