[RELEASE] Hubitat Package Manager (HPM) -- HubitatCommunity

I am not seeing Un-Match in HPM. Where and how to Un-Match? I am running HPM 1.8.6.

EDIT: I found it in Settings at the bottom. I guess the first 2 times I looked there my eyes failed me!

1 Like

search is not working to install. i get this page.. selecting next just shows busy for a sec ... ie spiinning icon and returns to the same page.. nothing relavent in the logs.

guess it did install the code. no indication that it did however..

I just tried to update HPM and got an almost identical, but not quite the same error as those above.

@csteele Hi, I submitted a pull request a few days ago to add a Tag to the settings.json for HPM. Would you be so kind as to approve it? I'm going to be gone for a while and was hoping to get my HPM stuff all squared away before I leave as my access will be very limited.


The PR was against the old set of repos.

I added "Tasmota", to settings.json on the HubitatCommunity repo.


Updated to 1.8.6 and found the switcheroo to bundles-first! Thanks, @csteele!

A normal update went a bit awry with this, though:

So I hit "Repair" and it reinstalled everything and now appears fine, including the library install from the bundle and the new Fob install (which is the only one updated to use the library at the moment).

I'll see if it behaves on the next update, but I feel happy enough to start migrating my other drivers to using the library feature. :+1:

1 Like

Hi all...for some reason I show that I've got two versions of HPM installed (1.8.4 and 1.8.6)...should I uninstall 1.8.4?


Perfect, thank you!

I'm going appologize now. I ran an update I notice I was getting error for The Flasher app for the jason for https://raw.githubusercontent.com/bptworld/Hubitat/master/Apps/The%20Flasher/TF-parent.groovy location.
See there is a bundle for I un-match this and attempted to update/rematch to migrate to the bundle deployment. However, it didn't find it.
Thus, I downloaded that buldle and attempted to upload the bundle into that hub and attempted to copy it into the existing application code and this still fails.

I am on an older version 1.0.2 and this build/bundle is 1.0.4.
What is the process moving to bundle?
Did I do this wrong or is this something else going on?
Thank you agian for your help.

To use my apps, you'll need to download Bundle Manager. You'll find the update to The Flasher there.



Is there any chance you or someone else that contributes to GitHub - HubitatCommunity/InfluxDB-Logger could add influxDB-Logger to to HPM. This seems to be coming up allot now with Hubigraphs having it's issues.

I'll be happy to build HPM manifests for @ogiewon (owner of) but I bet he can do it about 10 mins faster :slight_smile:

Thank you! I will work on this.

I have never used HPM. Also, I haven’t used the InfluxDB Logger app in years. If anyone wants to take over that repository, that’d be fine with me! :wink::sunglasses:

1 Like

we have a Manifest specifically for 'abandoned but useful' packages... with the altogether brilliant name of: HubitatCommunity :smiley:


I can certainly add another package to the set. Is that your preference?


Whatever you think would be best. If you create a Pull Request, I’ll gladly merge it.

Like that?


Looks great!