[RELEASE] HubConnect Netatmo Weather Station Client (HubConnect not req'd)

I already have 24h format in my HE settings and other devices report in 24h.

My Shelly 1:
image

It is supposed to follow the time format the hub is using. But I see a minor bug that you can easily fix..

On line 397 in the app code,

String formatTs(ts, ds = false) {new Date((long)ts*1000).format((ds ? "MM-dd-yyyy " : "")+(location.timeFormat == 24 ? "HH:mm" : "h:mm aa"), location.timeZone)}

There should be quotes around the number 24. Like this:

String formatTs(ts, ds = false) {new Date((long)ts*1000).format((ds ? "MM-dd-yyyy " : "")+(location.timeFormat == "24" ? "HH:mm" : "h:mm aa"), location.timeZone)}

That'll get the time format rendering correctly. I'll get an update out shortly.

1 Like

Lovely! Thank you for your fast replay.

Nice idea but there are duplicate entries... which to use?

@srwhite I am not getting the redirect for the page to generate the app id and secret. Any ideas?

This is the correct link..

https://hubconnect.to/download/category/5/HubConnect-Netatmo-Weather-Client.html

If you use the search function you'll also pull up the drivers for the old ported community integration of Netatmo. I'll rename those to be more clear in the future.

Did you enable oAuth in the Netatmo Client app? Anything in the event logs?

@srwhite oAuth is enabled and the following is what I received

2020-01-28 02:27:27.963 pm errorhttpPost() failed with error
I can delete code and start fresh if you feel that is a good course?

I would reinstall, keeping the logs open in another tab to see if anything failed during the initial setup. It's got to be something super simple.

completely agree, will update shortly.

@srwhite no joy, same error code in log

When you click the “Connect to Netatmo” link, is the browser popping a new window and taking you to the Netatmo authorization page?

If that’s not happening you need to check to make sure pop ups are allowed by your browser. If you are getting through the auth process and clicking the Close Window button after a successful auth and if the httpPost is failing it means that the hub is unable to communicate with the outside world. I would suggest checking your firewall

@srwhite I am connected, did not know that I was to create an app through netatmo. Now that I am connected I need to figure out getting devices to show. (update) Devices are being created the two apparently had not started communicating.

It's actually in step #5 in the installation instructions.

  1. Visit the Netatmo Developer’s website to get your application credentials.

:smiley:

The only item that I can't get on dashboard is my wind gauge. I can select it but its a blank tile no speed or direction.

You are making progress! I would check the wind device to see if it’s receiving updates.

Also check that you are using the attribute tile and are selecting the correct attributes.

@srwhite the wind device is reporting as shown in this screen shot

and when i pick the device and attribute it only lists the items shown in this screen shot. .

Something is not right with your install. I see all of the wind attributes.

1 Like

Thanks the url imports are now working. Now installed and looking very good. Will do some further testing then move off my test HE. A very impressive piece of work.

1 Like

Ok, I uninstalled everything and reinstalled even drivers. The wind items will not show on dashboard but still the same? This is all new to me so i am sorry to be the pain.

Download the Hubitat app