[RELEASE] Homebridge Hubitat v2.0

Wanted to let you know that I went in to the Hubitat app and changed it from type plug to light and rebooted and that appeared to work - it's no in Home as a light with brightness control. Thank you for your quick response. Sorry, I did not realize I could manually reclassify it!

1 Like

@tonesto7 created this integration (and if I’m remembering correctly, the previous Homebridge integration that was converted for use with MakerAPI). He has been kind enough to share this with the community and keep it maintained.

6 Likes

I posted about this sometime ago and didn't get a response but would like to resolve it. All of my curtains connected to Qubino Flush Shutter Modules permanently show "closing" as shown below:

Though in the status bar at the top of the room page they correctly show their status as below:

The Homebridge debug for the device is shown below:

{
"name": "Lounge Curtain",
"basename": "Qubino Shutter Module",
"deviceid": "476",
"status": "ACTIVE",
"manufacturer": "Unknown",
"model": "Qubino Shutter Module",
"deviceNetworkId": "76",
"lastActivity": "2022-04-12T07:00:08+0000",
"capabilities": [
"Actuator",
"Configuration",
"EnergyMeter",
"PowerMeter",
"Refresh",
"Switch",
"SwitchLevel",
"TemperatureMeasurement",
"WindowShade"
],
"capabilities_processed": {
"Actuator": 1,
"Refresh": 1,
"Switch": 1,
"SwitchLevel": 1,
"WindowShade": 1
},
"capabilities_filtered": [
"TemperatureMeasurement"
],
"commands": [
"calibrate",
"close",
"configure",
"off",
"on",
"open",
"refresh",
"reset",
"setLevel",
"setPosition",
"startPositionChange",
"stopPositionChange"
],
"commands_processed": {
"calibrate": 1,
"close": 1,
"off": 1,
"on": 1,
"open": 1,
"setLevel": 1,
"setPosition": 1,
"startPositionChange": 1,
"stopPositionChange": 1
},
"customflags": {

},
"attributes": {
    "energy": 19.1,
    "energyDuration": "372.65 Days",
    "energyTime": 1617451429185,
    "level": 99,
    "position": null,
    "power": 1377.2,
    "powerHigh": 1380.2,
    "powerLow": 0,
    "switch": "on",
    "temperature": null,
    "windowShade": "open"
},
"attributes_processed": {
    "energyDuration": "372.65 Days",
    "energyTime": 1617451429185,
    "level": 99,
    "position": null,
    "powerHigh": 1380.2,
    "powerLow": 0,
    "switch": "on",
    "temperature": null,
    "windowShade": "open"

I'm guessing that Homebridge uses "windowShade" to show "open" in the rooms page but I'm not sure where it is getting "closing" from. I've compared the debug data with a Fibaro Roller Shutter 3 that controls my garage door. It appears identical in that it shows the "level" attribute but not the "position" (shows null), except the garage door is correctly displayed. Any help appreciated.

I don't even know if there is a detection for the name plug. Based on the users response who was having the issue, there is not, it was Home Kit in fact which auto-selected plug (based on the name possibly). Also the developer based on feedback not that long ago added the option to disable the automatic light and fan detection as you pointed out. Personally I have it disabled because I want more control but I also know what I am doing. But in the case above if the user had named the device with "Light" in the name the app would have solved the problem itself, since they did not know you could reclassify some devices in HomeKit. So it can be good for users in some situations.

@tonesto7 keep up the good work we are lucky to have your apps available for free or optional donations!

6 Likes

Well, you have all the Groovy sources for @tonesto7’s HomeBridge integration. So you can modify it as suited for your needs. One would think that would be a more productive use of time.

5 Likes

Let's all work together to create and share awesome things, and spend less time criticizing others' efforts. One way to accomplish that, is to improve the discussion in some way, however small. If you are not sure your post adds to the conversation, think over what you want to say and try again later.

12 Likes

This is a tricky one as most of the issues I've seen with the blinds revolve around the drivers doing something weird.
I tried to build the logic using the built-in shade drivers, I will try to look and see if I can find the code for the driver you are using.

No problem -thanks

I've been using this great App to get Hubitat devices into Homebridge with success but am now wondering how I get Homebridge devices into Hubitat. e.g. leak sensors. Is that not possible or am I missing something?

Thx

  1. Create Hubitat virtual switches that correspond to each of your HomeKit sensors and expose them to HomeKit via Homebridge.
  2. Create HomeKit automations that flip switch state based on sensor state (eg. wet = on; dry = off)
  3. Use switch status within Hubitat to trigger Hubitat automations.

Hope this helps!

3 Likes

Ya, that's what I thought. Not a terribly elegant solution, in my opinion. I was hoping Homebridge devices could be imported into Hubitat with their native type preserved.

You know Apple doesn’t share. Same thing with Homekit. It’s still nice to be able to use the Home app and maintain local control.

4 Likes

Hi,

I added the Homebridge 2 in Hubitat. It created a QR code, but Homekit doesn't recognize it. I wanted to try the 8 digit code, but I couldn't it. Please advise?

thanks,

James

That can happen if your Homebridge instance is not on the same subnet as your Apple Home device. Make sure you do not have a "double-nat" situation.

For example if you have a separate WiFi router plugged into your ISPs router and have the Wifi router set to "router" (which is usually the default) instead of access point ("AP").

I believe the homebridge driver repository json file has a typo - it seems to show up in package explorer under " convienence "... Here's a screen shot to help isolate:

1 Like

Someone just reported on GitHub that the latest WatchOS release fixes support for opening/closing shades with Siri (using Watch). I've not tried yet as mine is still updating...

Edit: Confirmed fixed in WatchOS 8.6

How are you doing this? I have a Rinnai w/ControlR and am still using the horrible app. Please advise.

Quick question - though I'm guessing maybe removing the device and adding it back may fix it.

I have a Smart things z-wave multipurpose sensor I have on my front door. I went into HE and the addon and removed temperature readings from the device, but it still reports temperature changes. I had replaced the battery recently so not sure if that's why, but it seems to be the only device in my home that doesn't obey the "ignore X feature"

I have got a new router and the IP addresses have changed and now Homebridge wont work? Any idea how to reset without having remove and re-add my hub and devices?

Edit: Found it, put the new IP address into the config section on HomeBridge. Working as normal now.

Reserve the ip of Hubitat and any other iot devices you have in your routers dhcp table. This will ensure that no matter what they always get the same IP when they boot. You can put a static IP into Hubitat itself, but if you do, change the default DNS to 1,1,1,1 instead of it's current 8.8.8.8 (We've see problems of it not connecting to the internet after that change due to DNS)

1 Like

Download the Hubitat app