[Release] Google Home Assistant Relay Driver (v1 and v2)- text to speech on Google Home devices

sorry, I do not get it, could you be more specific

I followed line by line your document. Where can I see the version of the assistant relay NodeJs ??

for the driver I copied from your repo in GitHub and it is v2:

Should I type anything in the Assistant Relay Username field ??

If the assistant-Relay server is running, in the terminal window, you should have a big colorful ascii text graphic on the screen, right? It will keep running until you use the “ctrl-c” key sequence on the keyboard. Afterwards you’ll be back at the command prompt.

Yes, should be the same name you used for assistant-Relay.

I actually closed this window, so I guess I killed the application and that is my error right ?? I thought that it can run anyways if it was closed as this way is how works with the cast-web-api. I guess I have to reopen it. Let me try

LOL! Don’t close the terminal window! :stuck_out_tongue_winking_eye:

PM2 would run it in the background, but that’s not working for now...

oh man that was the problem, now it worked LOL !!

how can I troubleshoot to make the PM2 work in the background ? I would have to unistall the cast-web-api?

1 Like

That would be a better question for someone like @Ryan780 or @SmartHomePrimer. I really don’t know what the problem is is how to troubleshoot it. PM2 has always just worked for me.

great, thanks a lot, and wait to hear if they have suggestions

with google assistant relay is not possible to have specific devices to cast right? it will just cast to all devices available for what I am just testing

Correct, a broadcast goes to all devices.

ok, at least my music resumes after the TTS, thanks a lot

1 Like

PM2? That's for auto-startup correct? I don't use that. Sorry. I run all my apps on a MacBook Pro. Lots of horse power to spare. It's on a UPS and runs 24/7. I just open another terminal window and start the next app. I have 5 running simultaneously right now.

The real value in Google Assistant Relay (in my opinion) is the [CC] do this thing
(whatever that thing might be) feature.

1 Like

I see a lot of value in the assistant relay as well because my music in spotify will resume after a TTS and that was something that I was looking for. Will try the [CC] as well. Thanks

Cast-web-api let's you send a TTS message to an individual speaker but it is not a broadcast. It will interrupt whatever is playing. The only way to do a broadcast to individual devices is to create dummy Google account and link each one to only one speaker. Then when that user broadcasts it only goes to that speaker. However, this is only a theory developed by Greg, the developer for AR. I tried it and couldn't get it to work.

Did you figure out your PM2 problem? If not, and you have installed cast web, just reinstall your version of node using the script I linked to above. Even if you reinstall the same version it will repair all the linking to PM2 that got broken. That's how I fixed mine.

1 Like

no, PM2 is not yet working. Let me reinstall NodeJs. Any version you suggest? I have currently 8.11.3

Just use the script I linked to to reinstall the same version. That will automatically reinstall all of your global node libraries (installed with - g) and fix the linking to PM2.

so it would be this command right? (sorry for double checking but I do not want to screw up my cast-web-api that took me days to make it work)

Working through the process. Had some trouble with v10 of of nodejs being loaded instead of v8 but managed to downgrade it. In case it's of use to anyone else, this helped...

Got to the npm install and it worked away but now seems stuck here...

What to do? The cursor isnt responding to mouse movement so I'm assuming the RPi is locked up.

[Update - fixed as noted below]

Restarted the Pi and did an audit fix and it completed the install ok. Assistant relay is running! Onward.

Ah, another issue....not sure what this means...

[update] opened a fresh terminal window and retyped the command and now it seems OK. Process is running and command issued successfully.

But now when trying to set up so that Assistant-relay starts every time the RPi boots, I get the terminal window hanging at this....

I've done a reboot and tried again but it hangs at the same point. Very exciting install this :smile:

[Update] finally got npm to complete. Seems many people have issue. I found these 2 references helpful...


Specifically, clearing the proxy settings...

npm config delete http-proxy
npm config delete https-proxy

npm config rm proxy
npm config rm https-proxy

set HTTP_PROXY=null
set HTTPS_PROXY=null

Setting the maximum sockets...

npm set maxsockets 3

Splitting the command into 2 lines...

npm install -g pm2
pm2 install

And trying the 1st line until eventually all the files were loaded into cache and then I could complete the install successfully with the 2nd line.

That was interesting :smile:

Anyway, hope my notes help someone in the future. Keep at it - eventually you will get it to work!

1 Like