[Release] Google Home Assistant Relay Driver (v1 and v2)- text to speech on Google Home devices

I haven't used this driver in a loooong time but wanted to play around with it and see what was new. These custom commands are great! I can now send my nest cams to my nest hubs when HE receives motion!

  • [CC]show front door camera on living room display

Unfortunately, "[CC]stop living room display" doesn't seem to work. Anybody find a command that stops the stream?


1 Like

I believe the correct command would be "turn off" not stop, but I can't seem to get it to work either.

I know this isn't a great option, but I believe the stop command from the Chromecast Beta implementation works correctly still. I'm having the same problem with Cast-web-api at the moment. I think google did something with the stop command.

Thanks, I was going by this...

Didn't even think of this! Worked perfectly. Thanks!

Yeah, I know....it works when you say it to your GH but for some reason the Assistant SDK doesn't like "stop" anymore. I don't know why, I just know it's affecting Cast-Web-API as well, which makes me think it's not just an AR problem but a Assistant SDK problem. But i could be totally wrong...it's just an idea.

I was going to suggest the stop command also, but I'm not using the Chromecast integration at this time and didn't know if you were either.

Okay...i don't know what I am doing wrong but I cannot get PM2 to work. I ran the assistant-relay installer fine but after I run sudo npm install pm2 -g install and the try to do pm2 startup, i get -bash: pm2: command not found. I am following @ogiewon's instructions to the letter and it just will not work.

UDPATE: Never mind, it's Cast-web-API-CLI screwing with it. It uses PM2 for it's new native process management. Unfortunately that locks out PM2 for anything else to use! Lovely. UGH!

1 Like

As @Ryan780 said, something changed with the Assistant SDK. I used to be able to use [CC] stop streaming, but that won’t work from Google Assistant Relay or Cast Web API now. But I can confirm that the Chromecast Integration (beta) does indeed stop the stream with the custom action stop()

I said I suspected that....and only after he reported having the same problem in Assistant Relay that I'm having with cast-web-api's stop command. But, if you read the whole post I said i might be completely wrong. Please don't quote me so inaccurately.

I didn’t. You wrote...

I wrote that you thought something changed. Something ain’t the same, therefore something changed right?

THINK being the word that you left out when you non-quoted me.

Just a suggestion. Personally I use cronjobs to start my node servers at startup of my pi. I figure if something is repeatedly crashing I want to know about it. Not just keep restarting it.

Plus I just find those service programs to be annoying and not very intuitive.

Hey @ogiewon I am at page 25 from the .docx instructions document but when typing the command pm2 startup it will show as command not found. As I understand from the previous command in my screen the pm2 was succesfully installed right? so am I missing something ??


Do you have cast web api installed on that pi? I think I read somewhere that cast web api messes with pm2 somehow.

You don’t need it for testing. Just run assistant-relay interactively for now. You should hear “assistant relay is running” when you start it up?

yes I have the cast-web-api installed

when doing the steps from page 23 from the .doc document yes I heard the “Assistant relay is now setup and running for aldo" but now if I do some tests by typing some text in the boxes and then pushing the button, there is no sound and in the logs this is the error:

In your config.json file, are you sure you’re running on port 3001?



Maybe try changing the port to 3301 in config.json, restart the assistant-relay, and also in the Hubitat device.

I don’t know what else you’re running on your RPi, so you need to make sure to avoid port number conflicts.

Also, you’re sure the IP address of the RPi is correct?

how to restart it ? any command in the terminal ?

the only other thing running in my Rasberry is cast-web-api-cli under port 3000, is brand new and I have not used it for anything else

yes, this is the IP that the command ifconfig -a will give me:

To restart it, you would system ctrl-c to stop it. Then run it again.

Are you sure you’re running both the v2 assistant relay NodeJS server and the v2 driver in Hubitat?