[RELEASE] Follow Me - Speaker control with priority messaging, volume controls, voices and sound files!

New version on GitHub...

2.1.7 - 05/30/20 - Fixed a typo with contact sensors

Still not updating, do I need to revert the change i made to ln 367 on the driver?

App log is always true if open closed

I can't troubleshoot changes you have made. I have enough of my own issues to deal with. :wink:

My suggestion, update to my code in GitHub, open each child app and make sure the settings are what you want them to be and hit 'done'.

Then report back any issues you may be having.


Re download every thing, still not updating active/inactive on contact change

Thanks, I'll take a look in a bit

1 Like

@bptworld, I have the same error as some users above, I can't really find how to solve, there is not really an issue, everything seems to work (except the same problem as [here])([RELEASE] Chromecast Helper - Simple way to help keep your Google/Nest devices alive)

Is it something I can solve by configuration?

The error:
error java.lang.NullPointerException: Cannot invoke method put() on null object on line 367 (sendFollowMeSpeaker)
App: 2.0.2 - 04/27/20
child: 2.1.7 - 05/30/20
Driver: 2.1.7 - 05/29/20


New version on GitHub...

2.1.8 - 05/30/20 - Virtual Device can now be automatically created - Recommended to delete device and recreate

2.1.8 - 05/30/20 - Fixed the bug with Speaker Map


Still doesn't seem to be updated closed events

The error is gone, it still works:-),
but still the issue when Google home mini media source is becoming None, the first time ONLY the volume change is ignored, the second time the trigger comes the volume is changing well.

After Media source None, we see at the first trigger the message media source is set to Hubitat (17u55min10sec) , in that case the volume to 80 procent is ignored but the message is played (not visible in de log's), the second time (17u55min24sec) everything is working well.

Working just fine here.

  • open contact - changes zone to true
  • close contact - waits the selected time (in this case 1 minute) and then changes zone to false

This is an issue with the Chromecast Beta app, not with Chromecast Helper or Follow Me.

Strange added 1 min delay, still showing true 1min later

I suspected it already, given the fact it stays so long Beta I guess it is not easy to solve the issues or there is no time/priority to look at the problem...

Ln 549 in speechOff still calls the state.motion and its going down that path

Edit created a completely clean version and its working now, must have been hanging onto motion sensor event

New version on GitHub...

2.1.9 - 05/31/20 - Adjustments to zone off handler and a few other little bits

Be sure to open each child app and hit 'done'

Updated to the latest child and driver from GitHub and currently on the most current version (2.0.2) of the parent.

Made sure to open each child app and click done as well.

The previous error I was seeing (and posted above) is no longer occurring, but it looks like a new one has taken its place.

Similar to before, everything still seems to be working properly and I'm getting the event text that I expect, just seeing this error in the logs.


2.2.0 - 05/31/20 - Chasing a bug in push handler

I don't suppose you have an ingenious workaround? 2 of mine aren't responding to the initial volume command even via the chromcast driver.
Could we send a blank txt then volume them message?

That seemed to have worked. No errors in the log anymore!

Thank you sir!

Hi all, so i've finally gotten round to playing with Follow Me - I installed it and setup child devices and then created a rule to send a message to active device if a switch was flipped. flipped the switch and hey presto devices in active zones played the message. I thought it had all gone too well!.

So I then added my follow me virtual device as a notification option to one of my existing rules and fired the rule and I got this: the bottom one being the Pushover notification that came through fine but the voice notiication through follow me never arrived and is showing null:

dev:622020-06-01 10:17:39.803 pm info Echo (v3.6.2.0) | SpeakCommand Sent | (null) | Runtime: (30 sec) | QueueItems: (0)

dev:622020-06-01 10:17:39.557 pm warn Echo (v3.6.2.0) | No Message sent with speak(null) command

dev:1642020-06-01 10:17:38.107 pm infoSending Message: Outside Lights on 09:34 PM Priority: 0 to Device: Josh

Is this because the message was created entirely of variables? i.e in rule manager the message is; %device% %value% %time%

Need to see a debug log of Follow Me receiving this message.