[RELEASE] Envisalink App & Driver for Vista/Ademco/Honeywell Alarm via smartthings-nodeproxy

I can't change the type because is grayed out but it seems you can. Do you know why?

No idea. I guess it’s the integration with #1. I don’t think that’s the issue.

For some reason it decided to show on the list now. I didn't change anything and all is good now. Thanks for your help! :slight_smile:

1 Like

I'm migrating from ST to Hubitat and just finished implementing this integration. Everything appears to be working. I have a question, though.

Is there a way to be forced to enter a user code when changing the state of the alarm system? I don't like the idea of not having to do that when issuing commands to the alarm panel.

thx

No idea. I know hubitat supports user pin on their dashboard if that’s what you’re looking for.

While I mirror my security system status, contacts and sensors in my home automation system, it has been my philosophy to keep security control separate from home automation. That being said I have been experimenting with virtual buttons for arming and disarming. They have been working well and the convenience is tempting. I had the same question that you were asking and came across these posts on the subject. I have not tried them them yet.




Hope they help.

Thanks, I'll check those out.

My preference is like yours, not to have any alarm controls within the home automation app and just monitor the zones, I especially don't like that you can disarm the system from the Honeywell partition device without entering a code. I've disabled the Disarm function.

Thanks again

1 Like

Hello,

I'm migrating from ST to Hubitat. I'm trying the #2 option. I did not previously have this running in ST so this is a new install on the Hubitat side. I have the node running and it is communicating with the envisalink. I used the docker that Brian created. I can check the log inside the container and it is definitely getting comms from the system (A Vista 20P if that matters at all). I can see disarmed state and see comms when my sensors fault so everything looks good there.

Now, trying to get this working in Hubitat is a different story. I've read the ST post multiple times, read Brian's posts multiple times, read the install instructions and believe I followed everything correctly but it just doesn't seem to be communicating with my proxy. Drivers imported fine. The app code worked but I had to make one change on line 155 and change "physicalgraph" to "hubitat", then it imported fine. I add the app and then go into the settings. First off, I'm not sure what I need to type in the "Select Hub" field. Next, Brian mentions you need the MAC address for your proxy but I don't see where to enter it in the settings. The proxy address seems to want an IP address. Is this where you put in the MAC? If so, what is the format? ":" delineated, no delineation? lowercase on letters, upper case? Once I configure this and click Done, no matter what nothing goes into logs and the proxy continues to state: "Notify server address and port not set!" I believe these should be set once the app is communicating with the node proxy, correct?

Any help is greatly appreciated! Thanks!

Nevermind. Apparently I'm an idiot. Somehow I did not get Brian's version of the app code and got the original instead. If anyone reading happens to run into the same issues I did, that's the answer. Make sure you are using the Honeywell Security app code from Brian's repository and not some other code. It is working now and I'm using the devices in webcore. I should be able to use the sensors for home automation now. Thanks Brian! Excellent work!

2 Likes

Hi I'm considering implementing this solution using option #2 (Raspberry Pi) but I'd like to first know what the latency on the sensor state reporting is? Can anybody tell me what their experience is like? Does it take 1 second or several?

For me it's faster than zwave. I have all the perimeter doors and windows set to 10ms. (This is set on the alarm panel). I think the default on the Vista's is 100ms.

Interesting. How do you change it on Vista? Are there any negative repercussions to setting it so fast? Why would the default be slower?

Depends on where the zone is and what type of zone. Most of my exterior zones are on expansion zones since I wanted the panel attached zones (2-16) for some other stuff. The zone expansion modules use polling loops. I had the time off a bit though. Normal is 300 ms not 100 ms and Fast is 10 ms.

image

With either setting it's still faster than a zwave contact sensor. My zigbee sensors are usually around 110 ms to 150 ms. I have about 64 zones and haven't had any issues with the faster polling. The only perceivable delay is with whatever device you are activating. The 1 ms for the network send from the Envisalink to the hub, and the 40 ms or so delay for the hub processing are essentially nothing. You're still stuck with the 400 ms or so delay for zwave devices or around 120 ms for zigbee so that is the main thing driving up the delay time.

1 Like

I should mention that before we moved into this house I had never messed with anything other than replacing the sensors for the alarm panel. The house came with a wired alarm panel but the alarm service was not activated.

I had intended on buying a Konnected board to use some of the wired zones as sensors. I also wanted to have dual monitoring in case the internet or cellular went down. The original panel was a Honeywell Vista 20p with an ATT 3G cell board. I found out that ATT was discontinuing the 3G service so opted to upgrade the cell board to a 4G LTE. While doing the research for that Honeywell had just released the Honeywell Vista 21ip alarm panel board and it was pretty cheap so I decided to go ahead and replace it as well. The zone doubling on it is a nice feature. I wanted full control over the alarm panel and was tired of ADT bending me over so I found one that does dual monitoring for about 27 bucks a month. The service from them has been great and they can do remote programming so if I want them to make a change I can just call in and they do it within a few minutes. Usually though I'll just do it myself unless I'm reprogramming a zone since they have to change some reporting on their side.

Konnected had some production issues with wireless interference and I got tired of waiting and started looking for alternatives, then happened across the Envisalink. With the Envisalink I no longer had to wire into each zone and didn't have to tune the resistances or whatnot. Just wire in the 4 wires to the addressable and I had every zone including wireless. Yes, I needed a raspberry pi, but I already had one laying around for some other stuff.

Programming the alarm panel looked very intimidating at first with all the different settings to configure so I watched a few YouTube videos from YouTube - AlarmGrid It took me about 45 minutes to program all the settings while following along with the videos and then maybe another 15 minutes tinkering around with stuff to see what settings I liked better. Looking back on it it was really easy and I made way more out of it than necessary. My 11-year-old daughter could have programmed it.

1 Like

I am getting this error message from the Honeywell Partition device:

dev:302020-11-27 11:16:50.232 pm errorgroovy.lang.MissingMethodException: No signature of method: user_driver_brianwilson_hubitat_Honeywell_Partition_385.both() is applicable for argument types: () values: [] Possible solutions: with(groovy.lang.Closure), off(), each(groovy.lang.Closure), notify(), wait(), run() (both)

Also, I am getting this message from the Hub:

2020-11-28 08:09:06.636 am warn Received data from 192.168.1.36, no matching device found for 192.168.1.36, C0A80124:824A, 00508D9FFA05 or C0A80124

The IP address & MAC are for the Linux server running smartthings-nodeproxy

Maybe these are related.

I can send commands (arm/disarm) to the Vista 20P, however, I am not receiving its status.

Appreciate any help resolving these issues.

I am using Enivsalink 4 with a Vista 20P. My linux server is Manjaro (Arch Linux based).

Not sure on the first error. Can you search the partition driver code and look for “both”? Perhaps send the section of code where this exists.

For 2nd error looks like you need to update your MAC address to be 00508D9FFA05.

I searched for "both" in the partition drive code and found nothing.
I corrected the MAC address - error is gone.
Also, I checked "Discover Zones" - waited a few minutes and status and all zones on the Vista 20P are visible.

Looks like I am good to go - Thanks

I had a shutdown of my system (Manjaro Arch Linux) and when I restarted it, I had to restart both docker and the smartthings-nodeproxy container to re-establish linkage to my Vista 20P. Is this going to be my normal procedure when I take my system offline and re-start it?

What is restarting? Your system that runs your docker container for smartthings-nodeproxy, your Envisalink, or something else? I seem to recall if my Envisalink goes offline, I have to restart my smartthings-nodeproxy container, but I'm not sure. Neither of these things happen often enough to be an issue for me.

Download the Hubitat app