[RELEASE] Echo Speaks V4

I never said it was a better way, I just prefer it. It puts my virtual switches in one place, I think is what I like most

Hi all!

I'm having trouble installing Echo Speaks. I followed all the instructions from:

When I get to step 7, I see:

But when I click on Goto Login Page, this is displayed:

Echo Speaks 2

Any suggestions?


Check my tips here on how to get it working with Heroku right now. Heroku made some changes and there is not an easy fix for the app, so I came up with a workaround for everyone.

Tried the "rem out" on line 2800 and still get same errors in logs.

app:2282023-11-23 01:13:35.807 PMerrorEchoApp (v4.2.3.0) | getDeviceActivity | Response Exception | Status: (404) | Msg: status code: 404, reason phrase: Not Found

app:2282023-11-23 01:13:35.796 PMerrorEchoApp (v4.2.3.0) | getDeviceActivity | Stack Trace: groovyx.net.http.ResponseParseException: status code: 404, reason phrase: Not Found at user_app_tonesto7_Echo_Speaks_107.getDeviceActivity(user_app_tonesto7_Echo_Speaks_107.groovy:2784) at user_app_tonesto7_Echo_Speaks_107.getDeviceActivity(user_app_tonesto7_Echo_Speaks_107.groovy) at user_driver_tonesto7_Echo_Speaks_Device_451.getDeviceActivity(user_driver_tonesto7_Echo_Speaks_Device_451.groovy:1054) at user_driver_tonesto7_Echo_Speaks_Device_451.refreshData(user_driver_tonesto7_Echo_Speaks_Device_451.groovy:627) at user_driver_tonesto7_Echo_Speaks_Device_451.refreshData(user_driver_tonesto7_Echo_Speaks_Device_451.groovy)

Maybe different lines need attention?

I think I figured out my issue. I was looking in driver code and not apps code.


I just got a new Echo Show 8, 3rd gen. Anyone know how to get that added? I see it in the app but I can’t select it for announcements.

Well, I don’t have an Echo Show 8, so I can’t test this, but this should do it:

Make a backup, save locally in case things go badly.

Open the Devices page, open your Echo Show 8 device. Scroll down to State Variables, look for the entry “deviceType:”, copy the device type entry. For an echo show 8 gen 2, it would be, for example,

Now, open the apps code for Echo Speaks. At about line 7491, you will see the entry for Echo Show 8 (Gen2). Copy that entire line, then insert the copied line after the Gen2 entry (i.e., duplicate the line).

Replace the device type string with the device type for your Echo Show 8 gen 3, which you obtained above from your device’s State Variables entry. Edit the Gen2 text to be Gen3.

Save the file. Reboot your hub. That should do it.

Thanks for this @672southmain! I was having issues with my Echo 5, Gen 3 (wouldn’t speak…)

Added line 7477:
"A11QM4H9HGV71H" : [ c: [ "a", "t" ], i: "echo_show_5", n: "Echo Show 5 (Gen3)" ],

However, « Play Anouncement » or « Play Text » still aren’t working. Some of the commands, like « Voice cmd as text », « say good night », « say compliment », etc. do work correctly.

(File was saved and device was rebooted before I tried this...)

I assume you have other echo devices on which the commands do work? Everything works on my 6 Echo Gen 1 and one Echo Flex, which is all i have.

Thanks! I’ll try this tomorrow.

Yes, this is the only one that isn’t working properly. Has been an issue for a while now (since I got it), but I hadn’t gotten to it yet… I figured since I saw this solution that I’d give it a go. Unfortunately, it didn’t seem to change anything… :frowning:

UPDATE - tried it again today (4 days later) and it’s working now. Yay!

I would have thought it would have worked, I added a Echo Show 10(3rd gen) earlier this year and it worked right off the bat.

It does work, I just can't select it in the Actions app.

Thanks, this worked for me. I wonder if there will be an issue if there is an update to this app. Would I have to re-do this?

My Show 10 does with no issues. Never had to add anything, thus my statement that I was surprised a Show 8 would not.

Yes, unless there is a PR to update this into the app. You are welcome to do a PR for @tonesto7 .

Otherwise, you would need to make this change again.

This may have been covered is probably a silly question but is there any issue with using ES and Gen5 dots?

I have one and it seems to work fine. I just checked and on it's device page from ES it says it is a Echo Show 5, but it works.

1 Like

Putting this here too: Echo Speaks error getDeviceActivity - #23 by jeremyleestewart

My echo devices accept a value of 0-10 for volume. the driver for them seems to accept 0-100. Can anyone verify a possible bug here? I have (Had) rules that sent values like 'setvolume 75' and no errors occurred but the device volume wasn't changing. If I send it a 'setvolume 7' it works. Seems the device created by ES may have a bug.