[RELEASE] Echo Speaks v3 + Actions

Here are a few errors that show up, 3 different places however they are all tied back to ES

All my code is current

Thanks, Rick

1 Like

Yeah it’s not ES.
It’s either Amazon or something in the hub.
I see it occasionally myself



@toy4rick you can follow where the error comes from by clicking on the red "error" in the logs.

1 Like

Yup which is how I know all three circle back to ES devices or rules :slight_smile:


Everything seems to be working but I'm getting this in the log.

dev:9472019-10-01 09:26:49.016 am errorEcho (v3.1.0.2) | getPlaybackState | Improperly formatted request sent to Amazon | Msg: Bad Request

Here is what is currently installed:
Echo Speaks:
Actions: (no actions configured)
Server: 2.3.0
Config: 3.0

@tonesto7 I have ES on both ST and HE. I'm not sure if it's necessary, but I have two Heroku apps on the same account: one each for the two platforms. When I redeployed the Heroku app for v3, which happens to be for ST, I started getting this response:

The Other instance, which happens to be for HE, gives what I expect and have always seen previously:

I have you as a collaborator on both. And both seem to work correctly. Is the former app status something I need to fix? Thank you!

I've seen it where the server doesn't startup sometimes. When that happens try refreshing the page, and it that doesn't work restart the heroku dyno under the settings.

1 Like

I've tried refreshing without success, so I moved on to....

I'm trying my best to figure that out, but I'm not seeing it. Under the Overview page, I see:

And under Settings, I see:

But I can't figure out how to restart the dyno. A little more hand-holding, please?

That server was not correctly deployed it doesn't contain any data or parameters... Go under the heroku settings and delete it.

Then perform a server redeploy that's described in the documentation: Server Redeployment - Echo SpeaksDocumentation (I'm going to redo the images right now because they are outdated but you can figure out the steps for now)

Done. And added you again as a collaborator. Thank you.

1 Like

I'm liking the this new web socket stuff with Alexa... I'm just about done building out the feature and then I need to finish my Zones feature and then I will be looking for some testers.


Still adding lots of devices into Hubitat, having just moved in to a refurbished house (builders are still working on finishing touches) so little time to do my job, all the work around the new house, install devices etc. so little time to test anything.

However I updated Echo Speaks to (no idea if previous version had same problem) and noticed that it wasn't working on scheduled time setting, although the test worked fine.

Having checked the logs I found 2 errors, one relating to the time issue
java.text.ParseException: Unparseable date: "Mon Oct 07 09:14:00 BST 2019" on line 2864 (scheduleTrigEvt)

and this one, which relates to a Majority Darwin Smart Speaker (with Alexa) plugged in to the bathroom shaver socket
Echo (v3.1.0.2) | getWifiDetails | Improperly formatted request sent to Amazon | Msg: Bad Request

I live in the UK which may have something to do with the date/time issue and not overly worried about the speaker issue

Help with a date/time fix would be appreciated

Thanks for reporting this. I will look into it

And I just set up a brand new 2nd Hubitat yesterday, and moved Echo Speaks over to it from my main hub. I did a fresh install over on #2, and the logs are hammered with bad requests that seem to be coming from a couple of my echos (they're all Echo Dot 2nd gen's, no mix of different generations or products):

You can ignore those errors. They will be handled differently in the next release

1 Like

Should the logging switches on the devices or Echo Speaks app control whether these error messages are logged?

This is why I only have 3 of the echos attached. With more than 3 I was getting errors for ES as well as for the built-in Alexa app. I presume d/t Amazon throttling the requests (which is what the error said on the Hubitat's Alexa integration. With 3, I rarely see an error.

Its really difficult to ignore in my system.
it is 95% of my logs

Go into each Echo device and turn off all of the logging levels... It seems to have solved my chatty error messages since turning them off and saving.