[RELEASE] Echo Speaks v3 + Actions

I was a bit hesitant at upgrading... appeared to be working fine for me but have bit the bullet... so far, so good! :sunglasses:

I've had no issues with any version installed so updated to 2.1.5, still no issues at the moment :slight_smile:

Same no issues. Actually I have better performance. :grin:

1 Like

thanks for the info guys :laughing:

@tonesto7
I was getting this warning in my logs - "Amazon Cookie Has Expired or is Missing!!! Please login again using the Heroku Web Config page", which i assumed was because i manually added the cookie data.
So i have cleared amazon login information, and tried logging in - but i keep getting the "you are not logged into amazon" error

It sucks that there are just some people that this cookie registration doesn’t work for.

It happens with other tts products as well.

That it does!
I can only get it to work, via manual cookie entry.

Would the json data help identify anything?

Actually if you could add me as a collaborator to your Heroku server that would be better.

Will do..
Pm me your email and ill add you

I've updated to:

  • Echo Speaks: 3.1.0.1
  • Device
  • Server: 2.3.0
  • Config: 3.0

And still having lots of log messages about timeouts, such as:

Echo (v3.1.0.2) | getAvailableWakeWords Request Timeout | Msg: Connect to alexa.amazon.com:443 [alexa.amazon.com/52.94.241.2] failed: connect timed out

same thing for getNotifications Request, getPlaylists Request, etc.

I don't think it's anything related to my pi-hole DNS or anything, as the addresses are resolving, and it appears it's getting a valid IP for the endpoint...

I see this in very small occurrences every day as well. Maybe this is part of the issue everyone is having.

Mine occurred at 7am and 8am on 3 different Hubitat hubs (C-3, C-4, and C-5).
This didn't occur on ST though which is weird

Hopefully by next week we won’t be polling for device data any more.

I’m about 40% complete on converting the JavaScript version of the web socket to groovy. Amazon has 4 handshakes that need to occur before they will initiate the stream.

3 Likes

Also have you observed what might cause the messages:

warn Echo (v3.1.0.2) | speechCmd | Too Many Requests Made to Amazon | Msg: Too Many Requests

I have 5 Echo Dots around the house, and 4 of them were being used this morning to announce departure / arrival... Is there some rough idea of how many speech requests are allowed at a time?

I set up Alexa Guard a few days ago and today noticed that it was not going into Away Mode via Echo Speaks. I pulled up the logs and toggled the switch from withing the ES app and this is the error message that was logged:

error EchoApp (v3.1.0.1) | setGuardState Exception: groovy.lang.MissingMethodException: No signature of method: static com.hubitat.hub.executor.BaseExecutor.JsonBuilder() is applicable for argument types: (java.util.LinkedHashMap) values: [[controlRequests:[[entityId:AAA_OnGuardSmartHomeBridgeService_554e1b60-5317-3939-9b89-17824a9c2128, ...]]]]

Echo Speaks (v3.1.0.1)
Device (v3.1.0.2)
Server (v2.3.0)
Config (v3.0)

Hubitat Elevation® Platform Version
2.1.4.130
Hardware Version
Rev C-5

A long time ago, I noticed this issue cropped up if >2 Echos were used to make an announcement.

This is one of the items I need to add to the queue check so that when this command hits this error message it will retry it I’ll get to this in the next release

If you use the actions app to send announcements.
It will actually send to all the devices you want because it sends it as one command and then Amazon does the work on the backend.

3 Likes

just an FYI - was showing my mate HE today and walking through the apps / drivers page and ES was still there even though I did the remove/uninstall from within the app (or does that not remove the driver/app that way it has to be manual?)

It doesn’t remove the app/driver code from HE, if that’s what you’re asking. That way you can uninstall an app or driver and reinstall if it becomes corrupted.

1 Like

ah - thanks for that ken.