[RELEASE] Echo Speaks v3 + Actions

I'm fully patched on all, even the server is at 2.2.3

Oh well

2.3.0 is the latest server. I had to reset my server data in the Service Deployment Option page, then redeploy.

The documentation link is broken,

Anyone have instructions to update the server?



omg lol I need to just copy the instructions . Server install is very fast to update if you don't get halfway through the process to find that the server config link is broken lol. Oh well funny thing is my echo speaks actions are still working without a server. let's see if I can remember how to do it

Okay that was easy if you need the server deploy steps Server - Echo SpeaksDocumentation

Finally got this to work.
I deleted the server, and redeployed.
Once i was at the login screen, i manually set the the cookie, using instruction found in the alexa TTS thread, then proceeded to login to amazon as per docs..

Not sure what was the cause previously, but is now working

Thanks @tonesto7 for all you help and hard work on this app...:+1::+1:

By doing this you will need to manually update your cookie as opposed to the automatic refresh

So, my echo's are not staying connected reliably. After a cookie refresh my echos work, but then at some point an hour, several hours or day later they stop. A manual cookie resend to the devices has to be done to make it work.
I am mainly using RM and Notifications App to send commands right now, but I have one routine set up in Echo Speaks Actions as well. Doesn't seem to matter which route I use, they still drop off. Looking at the logs, after the dropoff starts happening, there is no log entry for a command being sent to an echo, just nothing. Once a dropoff happens, manual test speaks also do not work.
I am keeping a log of issues, corresponding to log entries for future reference.
Should it matter whether we use Echo Speaks, Rule Machine, or Notifications to send commands?

That's a good question. I've just started pausing RM speech notification rules. Ever since I installed V3 of Echo speaks and started using the Actions app I haven't had a dropped device. I hope I just didn't jinx myself.

Interesting. I believe the problem still occurred when I was only using ES Actions to send commands, but I can't be sure without testing more.
I really need to have the flexibility of using RM with ES if ES is going to become a larger part of my home automation. Echo Actions has a lot of potential for some use cases, but RM has the full logic control that I will need.

RM definitely has the full Logic but without echo speaks what else would you use to hear those Notifications or whatever else. I've tried them all I think Sonos is pretty good and reliable but I'm really loving this Echo speaks now. I don't really care if it runs local or not when it comes to speech notifications. I'm pretty sure the actions App is going to get more powerful in near future.

I have been using a Google Home along with phone notifications, which has been very reliable and good. However, I only have one Google Home, but I have Echo's in every room so I want to be able to notify in different rooms with the Echo's.
I want to use the echo's as a reminder type device for example when I walk in the garage at a certain time of night before trash day it reminds me to take out the trash. This requires RM at this point for the full logic control. I see that the Actions app has a lot of capabilities and more are coming. It certainly has some advanced control of the Echo responses. But in terms of logic processing, it's not the same as RM.
I'm ok with it not being local as well, but I need it to work at least 99% of the time without having to touch it for months.

Have you tried powering down your echo devices I have 1 old echo dot device that's on old firmware that's showing up in the logs with errors but seems to still function like normal. I'm not saying it will fix your problem but it can't hurt. We have to make sure it's not the echo devices that are causing the problem maybe your wifi needs a looking at?

I have 1 or 2 echos that have been powered down, still same story. I don't think it's a wifi issue as I've never had a single problem with the normal functionality of the Echo's or losing connection. I went ahead and looked at my wifi controller anyway. All looks good, everything has been connected for a while.

Good point.
Since I manually added the cookie, it didn't say authentication good till I logged in as per normal. So will just have to wait and see if the auto cookie refresh keeps things going

I have everything updated to the latest:

  • ES
  • ES Actions
  • ES Device
  • Server 2.3.0
    ... and I am getting this the log:
    app:32972019-09-18 06:59:59.261 pm warn EchoApp (v3.0.2.1) | CODE UPDATES REQUIRED: Echo Speaks Integration may not function until the following items are ALL Updated [Echo Speaks Actions]...

... and the app says:

Is there something else I need to update?

Mine says the same thing. :frowning:

Odd, it updated for me.

I updated everything last night, including the Heroku server and tested fine. Notifications were working this morning at 7:00, came home from work at 5:30 and it's not working again.

Logged into Echo Speaks app, test notification through the app wouldn't work. Tried testing the device directly and it worked fine.

I then checked for updates to the code, the app says the Actions needed to be updated but nothing came through using the import function. I also selected the Amazon login option from the app, it gave me a success, did not refresh the cookie. Now it's working again

Let me know what you need

Really odd. I have not change anything. I just looked again and the errors stopped and the App show that it is current now.