[RELEASE] Echo Speaks v3 + Actions

Just installed for the first time. I have a million questions and curiosities but right now i'm experiencing some... weirdness.

Two things.

  1. The setup process talked about waiting for a minute and your devices showing up within the Echo Speaks app. I waited for 20 minutes and they never showed up. I happened to notice that a bunch of new Hubitat Devices did show up in my list reflecting all of my Echo devices. If i click on the devices and issue commands, they seem to work perfectly. However, i still see no devices listed in the 'Manage Devices' area under the Echo Speaks app.

  2. The second issue is more concerning. My Hubitat log is getting an error message every few minutes.

" 2020-05-21 12:39:40.481 pm errorEchoApp (v3.6.2.0) | receiveEventData Error: com.hubitat.app.exception.UnknownDeviceTypeException: Device type 'Echo Speaks WS' in namespace 'tonesto7' not found"

Any ideas? Are the two issues related?

Did you add all the necessary files for both apps and drivers?

Looks like websocket (WS Driver) not installed?

I think the reason those are showing up as unsupported is that you don't have the "Tablet" option checked when setting up the Echo Speaks app? I'm only saying that because the reason ignored is "Tablets not enabled." I know you said you only use them as controller panels, but just in case:

1 Like

I just checked the instructions again and I don’t see anything about a websocket driver. Did I miss something?

Are there any instructions for diagnosing this? Is it something on the hubitat or on the server?

It is in the instructions. Here is a page with all the drivers and apps listed in one place. Echo SpeaksDocumentation Software (Current Release) Hubitat section.

The other option would be to use Hubitat Package Manager. It can install, update, and makes it much easier to manage apps and drivers. It is also nice to explore new apps.

1 Like

That did it. Errors are not showing up any more and the Echo Speaks app now sees devices.

Thanks for the link.

The instructions here, under device install don’t mention that driver at all.

Had to check, I thought I remembered it being there.

0

Well, would you look at that! Ok, we’ll thanks for sharing the other link because I’d overlooked that step five more than once.

1 Like

@davin You're exactly right, hadn't noticed that was even an option! Thanks for clearing that up, I probably still don't need them as they're just showing SharpTools dashboards and are in rooms that have Echo Shows already but at least I know why it was happening :slight_smile:

2 Likes

Hi all, I saw an old question posted elsewhere that didn't seem to get responses, but I'm also running into the same question/issue:

I'm using Echo Speaks with some of my rules. For most of those rules, contextually I know which device I will be speaking to when I ask to trigger the rule. However, for more general notifications (eg: asking status for a device like a Thermostat or Alarm), I'd like to be able to ask Alexa from anywhere in the house. Since I don't know where I will be, I have the announcement set to playback on all my devices. Is there any way to localize the response back to the triggering/initiating device?

Tagging @mick.baker who posted the original question a few months ago.

Thanks in advance!

I don't know if Echo Speaks permits this. However, it is definitely possible with this Node-RED Alexa integration.

As an example, I stood between two of my Echos (Cat Room & Ashok's Sonos One 2nd edition). They both heard my question, but only one of them responded. The identity of the responding Echo can be used to direct the response to a specific Echo. It would only cause a delay of a second or two.

Thank you for taking the time to even test that. It's good to know that at least the responding device can be captured. I'm not sure I'm at a point to look into adding Node-Red into the mix, at least not for this particular, minor challenge. I'll keep it in mind if there's not an easier solution and I start to get annoyed by hearing Alexa's voice coming from all directions!

1 Like

Should you decide to go that route, I just want to point out that there is already a pre-built set of Hubitat nodes for Node-RED (thanks to @fblackburn!), and a very active community of Hubitat users who use Node-RED for their automations.

1 Like

There is a way to do this, but there is some delay involved if you are fine with that. You can use the wasLastSpokenToDevice attribute. Here is an example of how I use that for my goodnight routine, so that if it was spoken in the master bedroom, it disables motion sensing.

1 Like

Anyone notice lately that spoken messages that have periods or commas in them now seem to run together?

Started noticing it last week IIRC

Fixed by Amazon within the last day or so, tested it on Alexa and via Echo Speaks

A single period/comma works with the same pause, adding multiples doesn't increase the pause

Enjoy

Just updated to latest version of Hubitat 2.2.0.132 and saw this in the logs about 1 min after it rebooted after the update, any ideas, the app 9 is echo speaks

[dev:9] (http://192.168.0.10/logs#dev9)2020-05-24 21:32:37.344 errorgroovy.lang.MissingMethodException: No signature of method: java.lang.String.slice() is applicable for argument types: (java.lang.Integer, java.lang.Integer) values: [64, 94] Possible solutions: size(), size(), split(), split(java.lang.String, int), wait(), trim() on line 320 (parse)

I am very new to HE and just want to say THANK YOU for this code and the great documentation! I had one small problem during the install because I didn't follow the instructions closely. When I followed the documentation it worked great. Again, thank you for all your work.

Does anyone know how I would go about changing the volume of my echo devices per mode so that I can hear them in the middle of a loud day, but they aren't super loud at night? I tried using RM and I kept getting too many requests made to Amazon. Then I tried using the actions app with one action for each mode, and I get this error:
groovy.lang.GroovyRuntimeException: Cannot read write-only property: volume (volume)

Any ideas on what I should do or is there an easier way to do this?

I am a new user and recently installed echo speaks. I am having problems with the search actions. I can search for radio station WBMW under Tunein using the HE defined device itself without issue. However using Echo Speaks it seems that the search info is not getting passed to the command (from the logs): 2020-05-25 11:48:03.005 am errorgroovy.lang.MissingMethodException: No signature of method: user_app_tonesto7_Echo_Speaks___Actions_258.executeTuneInSearch() is applicable for argument types: () values: [] on line 4271 (searchTuneInResultsPage)

In the application I receive:

Unexpected Error

An unexpected error has occurred trying to load the app. Check Logs for more information.

Error: No signature of method: user_app_tonesto7_Echo_Speaks___Actions_258.executeTuneInSearch() is applicable for argument types: () values: []

Seems I may be missing something simple in my search argument? Any assistance would be appreciated.

Download the Hubitat app