[RELEASE] Aqara P1 Motion Sensor (RTCGQ14LM)

Can't believe it, the P1 has gone offline for the first time on C8 (never happened on C7 hub).


dev:15352023-06-16 11:32:50.118 AMinfoAqara P1 :trackball: ping...

dev:15352023-06-16 11:32:48.248 AMinfoAqara P1 :trackball: configure...fullInit = false (driver version 1.4.2 2023/05/21 10:48 PM)

dev:15352023-06-16 11:11:48.227 AMinfoAqara P1 :trackball: ping...

dev:15352023-06-16 10:03:53.878 AMwarnAqara P1 :trackball: healthStatus changed to offline

dev:15352023-06-16 07:21:32.599 AMinfoAqara P1 :trackball: Motion reset to inactive after 16 s.

dev:15352023-06-16 07:21:22.634 AMinfoAqara P1 :trackball: Motion is active 6s

dev:15352023-06-16 07:21:22.571 AMinfoAqara P1 :trackball: illuminance is 108 Lux

dev:15352023-06-16 07:21:20.698 AMinfoAqara P1 :trackball: Motion is active 4s

dev:15352023-06-16 07:21:20.584 AMinfoAqara P1 :trackball: illuminance is 109 Lux

dev:15352023-06-16 07:21:18.610 AMinfoAqara P1 :trackball: Motion is active 2s

dev:15352023-06-16 07:21:18.558 AMinfoAqara P1 :trackball: illuminance is 107 Lux

Device Health app

If you press the physical button on the device, will it bring it back to life?
Or you need to pair it again to HE?

I just paired it again.
I did notice that the LED was still blinking when motion was detected but not reflected on software.

As I remember, when just paired the LED will always blink when the motion is detected in the first 5-10 minutes, no matter how the LED option is set. This is the time frame in which the P1 sensor also accepts configuration commands without the need to press the device button at the same time.

If you look at the Zigbee map, is the sensor now connected directly to the hub or via a router?

1 Like

Went offline yesterday morning and it was still blinking in the evening when motion was detected, I guess, but was still offline.
I see that it is now directly connected to the hub and settings were reset when I paired it yesterday evening.

Use the community app, not the built-in one.

I noticed this ''(tentative)' label on the built-in map for the first time now :

Another hint to determine whether the Aqara P1 is connected directly to the hub or through a router :

Enable the Debug logs, then press the button on the back of the device shortly. Observe the live logs:

This is the router NWK reported by the sensor itself!
In my case E038 is the Tuya Repeater address.
NWK 0000 means the Aqara device is connected directly to the hub.

1 Like

Yes, the P1 is connected directly to the hub.
Note that it is not showing in the community app map although it is listed as a child in the data section.

Community app


You can experiment with pairing it through a routing device of your choice - just bring it extremely close to the mains-powered router and pair it again (without deleting it first). You may need more than one try until it changes its path to HE ... Now we have tools to know whether it is paired directly of via a repeater (router).

But actually, this is useful only for the older generation Aqara devices, which used to 'stick' to one repeater/router forever.

Aqara P1 is using the newer '3.0' SoC and actually doesn't need this 'sticking' procedure IMO.

1 Like

Thanks will try this on two of my older aqara sensors.
I gave up trying to keep them connected, and I am now bringing them in to HE via Zigbee2QTT/Home Assistant.

Nooooo ! :slight_smile:
All my old Aqara sensors (motion and contact sensors) are rock solid - just forcibly pair them via a compatible repeater/routing device.

I counted 24 Aqara devices, no one is giving me any trouble.


The old Aqara contact sensors are the ones with a highest WAF - almost invisible, and I have not changed the batteries for probably 3 years now!

1 Like

Thanks for the tip.
I paired the aqara devices, including a few devices which were showing outcost of zero close to a repeater of choice and I believe they have paired to these respective repeaters.
Will monitor and see how they behave!
Also, you are right the community Zigbee app is more reliable; it was correctly showing offline or zero outcost devices in grey colour, the system app gives no hint!

I bought two of these and got them installed yesterday running the latest version of HE (, but I could only get them to work using the Pair while trying to avoid Zigbee 3.0 repeaters option (which I don't recall seeing before). I had pulled all of the nearby Zigbee repeaters and even tried pairing right on top of the hub, but simply could not get all of the states to show up until pairing this way. Not sure if there is anything to it, but they've been rock solid and very fast to respond since then. I bought a third just to be sure, and it paired first time to full state reporting on the first try.

1 Like

I picked up 2 earlier this week on Prime day. Installed without any special handling and operating splendidly. I’m sharing to provide a recent purchase experience for anyone that may be curious on these.

I installed it in a temporary location in my home office triggering a simply TTS announcing motion to test before I most it to the permanent location. I set my motion reset to 10 seconds and it’s working as expected. I would however expect the 5 yr battery life estimate to be at the default 30 seconds.

1 Like

Awesome Driver. Thanks! The only issue I am having is saving the device preferences after I change them. I see it says to "press the pair button at the same time as save preferences" But I still cant get the blinking light disabled. So not sure if thats just an issue with the driver or I am not saving the changes right

Try pressing the button a second earlier before you click on the 'Save Preferences' button.
Look at the live logs, there should be a confirmation whether the parameters change was successful.

As I remember, when you pair the Aqara P1 to the hib, the device is running in a 'configuration mode' for several minutes. During this period the LED will always blink, it's a kind of diagnostic feature.

Are you able to successfully change the motion detection timrouts?

1 Like

Having same issue with the LED disable… unfortunately I have sensor in bedroom have you had any success?

Just installed the P1 sensor I recently purchased using your driver via HPM and everything worked perfectly! Many thanks to you for developing this driver.

1 Like

Hi everyone, I'm getting back into my SmartHome game after falling off for 2 years. Just updated my c-7 to

My problem is with my Aqara motion sensors as they do work as trigger when I set their state to "active" but the physical sensors don't detect any motion. See the attached screenshot.

After some surfing I find this thread (and also the Package Managers which is a GAME CHANGER)

Please tell me If I have to provide more info to get help solving my issue, right now I'm reconnecting my devices and setting them up one by one, room by room while I re-learn and discover what has happened in this space since I left.

Updated another driver and repaired my sensor without whiping it, and now it's back in buseiness! :slight_smile:

1 Like