Release 2.3.3 Fibaro switches not working

Has release 2.3.3 affected Fibaro FGS-223 switches, since upgrading mine have stopped working?

Please see this post. Help us, help you!

I am reporting this from my tablet while sat in the UK in the evening, with my wife complaining why on earth are you trying to automate the house, it's far easier to operate the lights without HE and just using the switches on the wall as well as being less expensive! I'll post the details in the morning when I am at the laptop. You guys concentrate on getting HE to do what it's supposed to do first time instead of complaining you haven't got enough details.

I am having trouble with Fibaro light switches following the upgrade. Two sets are not working (FGS-223), I have run a zwave repair which doesn't get beyond pinging, and neither switches work from the hub, but they do work manually. Suspect they have done something in the upgrade as they only stopped working this week.

Nothing was done with z-wave. Have you tried a full power cycle? Settings>>shutdown.. Unplug power to the hub (at the wall) for 5 mins and power back up...

1 Like

I don't think a firmware update would affect specific devices. I have the Fibaro Dimmer 2's, 223's and 224's. All are working normally. (I just checked as your message spooked me!)

1 Like

Tried recycling, but limited success. Managed to get one switch to operate, but HE is still reporting as off. Tried refreshing but no luck.

First thigs first, if you think the update caused the problem, go to Diagnostic Tool and Restore provious version. If the update was the problem, everything will work again, then you can gather more details, if you wish, so we can fix if something is wrong in the newest version.

1 Like

If you revert back to the last platform version on your hub (via the Diagnostic Tool), and the problem disappears, it would prove the issue with your Fibaro switches since the platform update is causal. OTOH, if the problem persists, then we know the solution lies elsewhere - perhaps warranting a re-evaluation of the device's function in your z-wave mesh.

So I would encourage you to do that.

My Fibaro z-wave plug (UK version) is working ok with the latest update. Trying to find the exact model but Vesternet prefers to give their SKU...

... I guess it must be this one FGWPG-111, so probably not relevant

1 Like

So reverted to previous version (on C4), slightly better, but not much, switches were coming on, but wouldn't turn off, looked into it a bit more and it appears AEOTEC devices (switches) are also affected. I have two hubs a C4 and a C7, so have started to move some more devices to the C7 as supposedly better range. C7 hub is in middle of house, but will not control devices around 10 metres away (I say not control, sometimes they respond, sometimes they don't), with plenty of Z-Wave devices inbetween. Z-Wave Repair run, but fails to ping furthest away device. I have a Zniffer, so can see the commands going (hub directly to device), but no idea why the system won't use a powered device inbetween. Totally frustrated, not sure if fault lies with hub(s) or Z-Wave in general, but just not good enough. Will try and move more devices across tomorrow if hub not in bin:-(

Thought I'd also show topology: Device 16 is the one that won;t ping from the hub, but looks to be connected via other ones:

Following image shows device 16 and 17:

17 is between hub and 16, but doesn't appear talk to 16 (it looks to have 3 hops already, despite being close to hub).

If the problems persist after reverting to previous version, then the issue was not caused by the update. With no changes to Z-Wave firmware in the recent updates. I didn't think the problem could have been caused by the update itself, but is always good practice to rule that out.

1 Like

Download the Hubitat app