Refresh / Remove buttons missing

The Z-Wave ghost device threads rely heavily on the Refresh button on Z-Wave settings...

But I don't have those buttons:

I've tried in Orion, Safari and Edge. (I don't have Chrome, but don't expect it should be that specific.)

This ghost device has survived repairs, reboots and 10-minute power-offs.

Did an update remove or move that functionality?

What platform version are you running, and on which hub?

The buttons have not been least not intentionally. :slight_smile:

That looks like a C5 or < ?
Z-Wave details is totally different on those hubs.

C5, updated today, Macintosh.

You would have to use a USB stick secondary controller on a C5 I think. If I recall, you are trying to migrate to a C-8, so once you migrate you might be able to remove it from the hub UI.

Oh. Well, that could pose an issue.

Right. They sent a replacement C8Pro, which I was about to try, but figured I'd try to remove this device first.

Oh well, perhaps the new C8P will work. Fingers crossed.

1 Like

I wouldn't count on it but maybe. I just went through this two nights ago on my C8, not Pro. I had a old GE ON/OFF switch go bad. It would not remove on it's own, I tried, I had to force remove it and, of coarse, it left a ghost device.

After many tries of refreshing, trying to remove and rebooting I gave up and broke out the Z-stick. That is still a bit of a pain but it did finally work.

I am not at all familiar with the Z-wave protocol but what does simplicity studio do to allow you to remove a device that HE can't do with the hub?

I think if you have Z-wave devices at some point you are going to need a Z-stick. That is the second time in the last 4 to 5 months I have needed it.

But were you migrating, and from what model? One problem above is that the C-5 and older simply don't have a "Remove" button in Z-Wave Details, so this isn't possible at all like it is on newer models like the C-8. That's the only reason migrating might help.m

I was not, as I stated, and I said it might work. It's just a bit frustrating, I thought I had about a 10 minute job to replace a switch and ended up taking me better than hour to finally get everything going again.

It had been quite some time since I have had a ghost device and the last time before these last two was probably back when I was still on my C7 and although it took a few rounds of refreshing and removing it finally did remove the ghost. It's a small sample size of only my system, but from my perspective it is worse now that it was on my C7.

The issue is that the Hubitat hubs are certified consumer Z-Wave devices. That certification imposes certain restrictions and limitations. Simplicity software is a development tool and so gets to follow different rules. Not under Hubitat's control.