[RE-RELEASE] Netatmo (Connect) - Weather Station

I just want to thank you for posting this. You saved my life as my Netatmo app broke in smartthings, and Netatmo app in smartthings will go away in coming few weeks or months. Thank you for putting out in HE!!

2 Likes

No worries :+1:


Also Enable Debug logging is disabled but I'm seeing debug entries in my Logs:

image

I believe these are Netatmo Server side errors - I see them occasionally too.

I'll have a look at the code to see why the debug logging setting is being ignored.

I commented these out in def refreshToken() to remove from my logs. I think you need an if statement to respect the debug logging setting, for example if (debug) log.debug “In refreshToken”

1 Like

The previous maintainer/author never bothered including proper "debug == true" logic and just commented out many of the debug lines. I've re-instated all debug code but made it conditional to you actually turning it on. eg:

if(enableDebug == true){log.debug "Generating AppDebug Event: ${results}"}

And I've released it as version v1.2.

Upon upgrade attempt with HPM, I’m getting the below error that I’ve never seen before. I thought maybe it was actively polling at the time I tried to upgrade, but after a few attempts, still getting the error. I also tried a match up and repair in HPM, but got the same error. I can always manually update, but just wondering if it was something with the package or you had another thought.

An error occurred while installing the package: Failed to upgrade app ${getVendorName()} Connection.

Be sure the package is not in use with devices.

That’s weird, I’m now seeing it too.

If you go into “apps code” section, and into the Netatmo connect app, can you use the import function (then hit save) to update?

I just tested this and it works to update to v1.2.

I’ll look into the HPM issue tomorrow.

That actually worked to pull the code in, but HPM is still showing that an update from 1.1 to 1.2 is needed, even after doing a match up and repair in HPM (actually getting the same “in use” error when trying to do a repair)

No worries, I’m seeing the same thing. I’m off to bed now, but I’ll investigate it tomorrow.

Run this again, and it'll work fine - I accidentally changed the file format from "UTF-8" to "UTF-8 w/ BOM" and HPM was choking on it.

Ok, now Im really going to bed (problem was driving me nuts!). :rofl:

Worked! Sweet dreams

1 Like

Can you please tell us what v1.3 has been changed or fixed?

Sure, it fixed the issue below. I’ll update the notes properly later today (I was working on this at midnight so got a bit lazy).

Thanks so much for your hard work.

1 Like

No worries. :sunglasses:

PS release notes have been updated.

@dJOS - I don't recall, but if I deselect a Netatmo device that I have (e.g. rain gauge), does the app completely delete the child device from Hubitat? I'm asking because I take my rain gauge in for the winter (per Netatmo's recommendation in freezing temperatures) and with the batteries removed, I receive an error (understandably so) for each poll. If the device is deleted, that will affect my rain logging rule, dashboard and other places the rain gauge is used.

I realize that you probably don't have this use case down under, but do you think it would be possible to add a toggle to disable polling for a specific device for these situations? I could comment out the code for rain gauge polling or export my rules to reinstate once the rain gauge is added back in the spring, but would prefer a less brute-force manual approach if possible.

Thank you!

I think it does. I have two Netatmo's and two HE's. Each Netamo is connected to their respective HE, but all the devices appear in my drop down selection. I'll add one and then remove it to test for you.

Yes. I just verified this on my HE. I probably should have put a timestamp in my screenshot, but from top to bottom, I had 6 devices. I added the Outdoor unit from my second Netatmo and went to 7 devices. Then back to 6 after removing it from the pull down.

Yes it does.

Sounds possible, I’ll take a look.

Download the Hubitat app