Ran update for C5 - hung, now no response

While running the update process for my C5 hub, it hung up - no response, no connection to the network. After 2+ hours, I gave up. I tried a power reset - no response. I also tried a hard reset, but still not working - the light will be blue for a few seconds, then go off, then back on for a few seconds, then back off. No response, and can't connect via the network. Is it dead?

The LED turning off completely sounds like it might be an issue with the power supply. Have you tried a different USB cable and a known-good USB charger to rule out a problem with both of those?

Of course, an update shouldn't cause this problem, so my thinking is that it could just be coincidence. If you can't reach it normally, try the Diagnostic Tool (port 8081), but if your LED isn't staying blue, it's likely that no part of the hub is running at all, including this.

1 Like

If the Diagnostic Tool is available as @bertabcd1234 suggested, then follow these steps:

If Diagnostic Tool isn't available, you are likely dealing with a hardware malfunction, including a possible power supply failure.

1 Like

Thanks, all. After 2+ hours, the LED finally turned green and I was able to access the web interface. It finished the update and seems fine now. I doubt it's the power supply, as it's plugged into a USB battery pack (3000 mAh) that ensures it stays on during power outages.

It's been a little flaky for the past few weeks, so I ordered a new C7 last night and will upgrade when it arrives.

Appreciate the help.

1 Like

I would have recommended the C-8. The external antennas make a big difference in performance.


This one is in a 1500 ft2 vacation home - range isn't an issue.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.